Microsoft Excel

Herbers Excel/VBA-Archiv

Fortlaufende Monate erstellen mit Max. Angabe

Betrifft: Fortlaufende Monate erstellen mit Max. Angabe von: Patrick
Geschrieben am: 29.08.2014 15:49:39

Hallo zusammen,

ich erstelle gerade einen Tilgungsplan für Annuitätendarlehen und möchte, dass Excel die Monate selbst erstellt.

Vorgabe: In Feld E12 wird die Laufzeit eingetragen (zwischen 12 und 120 Monaten). Es soll somit exakt die Anzahl an Monaten beginnend ab Monat ... (Feld G21)fortlaufend erstellt werden.

Ich komme leider nicht auf eine Formel, kann mir hier jemand helfen?

Danke und Gruß,
Patrick

  

Betrifft: AW: Fortlaufende Monate erstellen mit Max. Angabe von: fcs
Geschrieben am: 29.08.2014 16:12:50

Hallo Patrick,

wenn du nur mit Formeln arbeiten willst/musst, dann musst du Formeln für bis zu 120 Monaten vorbereiten.
Ist die Laufzeit kleiner 120 Monate, dann wird in den entsprechenden Zeilen ein Leertext ausgegeben.

sieht dann so aus:
in Zelle G21 trägst du ein die Formel: =WENN(E12>0;1;"")
in Zelle G22 die Formel =WENN(ODER(G21="";G21=$E$12);"";G21+1)
Die Zelle G22 kopierst du dann und fügst sie im Zellbreich G23:G140 ein.

Gruß
Franz


  

Betrifft: AW: Fortlaufende Monate erstellen mit Max. Angabe von: Patrick
Geschrieben am: 29.08.2014 16:41:20

Hallo Franz,

danke für den Ansatz, leider klappte er aber nicht in der benötigten form, daher poste ich hier zusätzlich mal ein Bild wie es aussieht.


In B23 (aktuell steht 1 drin) soll das Datum aus G21 (01.09.2014) Übernommen werden, soweit so einfach. Dann G24 bis .... die fortlaufenden Monate gemäß E12 120)

Vielleicht ist es damit etwas verständlicher.

Danke

Gruß,
Patrick


  

Betrifft: AW: Fortlaufende Monate erstellen mit Max. Angabe von: Christian
Geschrieben am: 29.08.2014 18:02:42

Hallo Patrick,
in B23 die Formel:
=WENN(ZEILE()-23>E$12;"";DATUM(JAHR(G$21);MONAT(G$21)+ZEILE()-23;1))

und nach unten ziehen.

Gruß
Christian


  

Betrifft: AW: Fortlaufende Monate erstellen mit Max. Angabe von: rene
Geschrieben am: 31.08.2014 00:29:55

danke wieder was gelernt
lg rene


  

Betrifft: AW: Fortlaufende Monate erstellen mit Max. Angabe von: Patrick
Geschrieben am: 01.09.2014 11:06:44

Vielen Dank!

Nun läuft alles.


 

Beiträge aus den Excel-Beispielen zum Thema "Fortlaufende Monate erstellen mit Max. Angabe"