Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

fortlaufende Rechnungsnummern prüfen

Betrifft: fortlaufende Rechnungsnummern prüfen von: Max K.
Geschrieben am: 26.06.2015 10:50:52

Hallo,

in Spalte E einer Tabelle werden Rechnungsnummern aus zwei Nummernblöcken (Tausender
mit Zusatz der Jahreszahl und Fünftausender : 1002/15 oder 5008/15) vergeben.

Dank der Hilfe aus diesem Forum wird zwar die letzte vergebene Nummer über der Spalte angezeigt, aber Fehler können bei diversen Anwendern trotzdem passieren.

Die Vergabe doppelter Nummern habe ich per Datenüberprüfung verhindert. Zusätzlich soll sichergestellt werden, dass nur fortlaufende Nummern vergeben werden, die Zelle E2 +1 oder E3 +1 entsprechen. Ideal wäre eine MsgBox, die auf eine falsche Nummer hinweist.

Es wäre schön, wenn jemand von Euch eine Lösung dafür hätte. Eine Mustertabelle ist angehängt: https://www.herber.de/bbs/user/98498.xls

Vorab schon mal vielen Dank für die Mühe.

Mit freundlichen Grüßen

Max

  

Betrifft: AW: fortlaufende Rechnungsnummern prüfen von: MCO
Geschrieben am: 26.06.2015 11:51:09

Mahlzeit!

Bei Eingabe des Kundens wird aus der Zeile vorher die nächsthöhere Nummer generiert.
https://www.herber.de/bbs/user/98503.xls

Gruß, MCO


  

Betrifft: AW: fortlaufende Rechnungsnummern prüfen von: Max K.
Geschrieben am: 26.06.2015 12:38:14

Hallo MCO,

danke fuer deine Hilfe, aber es geht nicht
darum, eine Nummer zu erzeugen, sondern vergebene Nummern (je nach Artikel mal aus dem Tausenderblock, mal aus dem Fuenftausenderblock) auf fortlaufende Vergabe zu pruefen.

Zwei verschiedene Nummern die zwar zufaellig (je nach Artikel) vergeben werden aber trotzdem in jefem der beiden Nummernbereiche fortlaufend sein muessen sind mein Problem.

Gruss

Max


  

Betrifft: AW: fortlaufende Rechnungsnummern prüfen von: Max K.
Geschrieben am: 26.06.2015 13:42:33

Hallo,

die Frage ist weiterhin offen...;-))

Gruß

Max


  

Betrifft: noch offen: fortlaufende Rechnungsnummern prüfen von: Max K.
Geschrieben am: 26.06.2015 13:47:33

...die Frage ist noch offen....


  

Betrifft: AW: fortlaufende Rechnungsnummern prüfen von: fcs
Geschrieben am: 27.06.2015 05:21:26

Hallo Max,

mit ein paar Hilfberechnungen kann man eine entsprechende Prüfung machen.
Dabei wird die Summe der eingegebenen Nummern mit der theoretischen Summe der fortlaufenden Nummern beginnend mit dem Startwert verglichen.

Die Summe einer fortlaufenden Folge von Zahlen berechnet sich nach:

Summe(Zahl_1 bis Zahl_n)= n * (Zahl_1 + Zahl_n) / 2

Zur Vereinfachung der Formeln hab ich für den Zellbereich mit den Nr.-Werten den Namen "Nummern" vergeben.

Gruß
Franz
Rechnungsnummern

 CDEFJKL
1  zuletzt vergebene Nummer Startwert10005000
2  5001/15AB Nr.Anzahl Werte32
3 eingegebene Nummer ist nicht fortlaufend1003/15AW Nr.KontrolleFALSCHWAHR
4       
5KundeDatumNr.Bemerkung   
6Meier19.03.20155000/15    
7Müller07.05.20151001/15    
8Schmitz07.05.20151002/15    
9Krause17.06.20155001/15    
10Heinrichs24.06.20151003/15    

Formeln der Tabelle
ZelleFormel
D2=WENN(L3=FALSCH;"eingegebene Nummer ist nicht fortlaufend";"")
E2=VERWEIS(2;1/(LINKS(Nummern;4)*1>=L1); Nummern)
K2{=SUMME(WENN(Nummern<>"";WENN(WERT(LINKS(Nummern;4))<L1;1;0); 0))}
L2{=SUMME(WENN(Nummern<>"";WENN(WERT(LINKS(Nummern;4))>=L1;1;0); 0))}
D3=WENN(K3=FALSCH;"eingegebene Nummer ist nicht fortlaufend";"")
E3=VERWEIS(2;1/(LINKS(Nummern;4)*1<L1); Nummern)
K3{=SUMME(WENN(Nummern<>"";WENN(WERT(LINKS(Nummern;4))<L1;WERT(LINKS(Nummern;4)); 0); 0))=K2 / 2 * (K1+K1+K2-1)}
L3{=SUMME(WENN(Nummern<>"";WENN(WERT(LINKS(Nummern;4))>=L1;WERT(LINKS(Nummern;4)); 0); 0))=L2 / 2 * (L1+L1+L2-1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: fortlaufende Rechnungsnummern prüfen von: Max K.
Geschrieben am: 27.06.2015 09:33:52

Hallo Franz,

zunächst einmal vielen Dank für deine Hilfe!

Ich wäre da nie drauf gekommen....;-))

Deine Lösung, die sicher hervorragend funktioniert, werde ich nachbauen und dir gerne nochmal eine
Rückmeldung geben. Dazu komme ich aber leider erst am Montag, da ich mich auf Wunsch meiner häuslichen
Chefin heute um den Garten kümmern darf und morgen eine Radtour geplant ist. Ja, es gibt noch Tage ohne
Excel....;-))

Ich wünsche dir ein schönes Wochenende!

Gruß

Max


  

Betrifft: @Franz von: Max K.
Geschrieben am: 29.06.2015 17:33:17

Hallo Franz,

ich habe deine Lösung integriert und sie funktioniert einwandfrei....;-))
Also noch mal recht herzlichen Dank für deine Hilfe!


Gruß

Max


 

Beiträge aus den Excel-Beispielen zum Thema "fortlaufende Rechnungsnummern prüfen "