In einer Spalte Text formatieren

Bild

Betrifft: In einer Spalte Text formatieren von: Peter
Geschrieben am: 11.02.2005 13:23:18

Hallo!

Ich habe folgendes Problem.
Habe eine Arbeitsmappe.
In einer Spalte stehen Kundennummern.
Die sind 8stellig, 9stellig oder 10stellig.
jetzt soll folgendes passieren:

10stellig:
schreib "D" davor sodass es so aussieht: Dxxxxxxxxxx
nimm das D und die ersten 5 ziffern und lösch den rest: Dxxxxx
also im grunde: schneide auf 6 zeichen.

bei 9 stellig:
schreib "D0" davor sodass es so aussieht D0xxxxxxxxx
schneide auf 6 zeichen.

bei 8stellig
schreib "D00" davor sodass es so aussieht D00xxxxxxxx
schneide auf 6 zeichen.


Kann man das irgendwie automatisieren?
Ich kann doch nicht alles von hand machen ?!?!

Bild


Betrifft: AW: In einer Spalte Text formatieren von: UweD
Geschrieben am: 11.02.2005 13:34:56

Hallo

so?
 
 AB
112345678D00123
2123456789D01234
31234567890D12345
Formeln der Tabelle
B1 : =LINKS(LINKS("D00";11-LÄNGE(A1))&A1;6)
 


Gruß UWE


Bild


Betrifft: AW: In einer Spalte Text formatieren von: Peter
Geschrieben am: 11.02.2005 13:41:43

Ja, ganz genau.
Die Kundennummern stehen in der Spalte a und sollen da auch ersetzt werden.
Bitte sag mir, dass du eine Lösung für mich hast :)


Bild


Betrifft: Nur mit VBA möglich von: UweD
Geschrieben am: 11.02.2005 13:55:40

Hallo nochmal
entweder diese Hilfsspalte dort als Wert hinkopieren

oder per VBA

Sub Kundennummer()
    'Bereich vorher markieren
    Dim z
    For Each z In Selection
        If z <> "" Then z.Value = Left(Left("D00", 11 - Len(z)) & z, 6)
    Next
End Sub


Gruß UWED


Bild


Betrifft: AW: Nur mit VBA möglich von: =Peter=
Geschrieben am: 11.02.2005 14:00:01

Hallo Uwe,

oder in der Hilfsspalte die Formeln über Bearbeiten - Inhalten einfügen - Werte umwandeln und anschliessend die Spalte A löschen.

Gruss
Peter


Bild


Betrifft: AW: In einer Spalte Text formatieren von: =Peter=
Geschrieben am: 11.02.2005 13:40:47

Hallo Peter,

die Lösung von Uwe gefällt mir zwar besser, aber nachdem ich jetzt schon was zusammengebastelt habe:

Tabelle1
 AB
11234568790D12345
2123456789D01234
312345678D00123
Formeln der Tabelle
B1 : =WENN(LÄNGE(A1)=10;LINKS(VERKETTEN("D";A1);6);WENN(LÄNGE(A1)=9;LINKS(VERKETTEN("D0";A1);6);WENN(LÄNGE(A1)=8;LINKS(VERKETTEN("D00";A1);6);"")))
B2 : =WENN(LÄNGE(A2)=10;LINKS(VERKETTEN("D";A2);6);WENN(LÄNGE(A2)=9;LINKS(VERKETTEN("D0";A2);6);WENN(LÄNGE(A2)=8;LINKS(VERKETTEN("D00";A2);6);"")))
B3 : =WENN(LÄNGE(A3)=10;LINKS(VERKETTEN("D";A3);6);WENN(LÄNGE(A3)=9;LINKS(VERKETTEN("D0";A3);6);WENN(LÄNGE(A3)=8;LINKS(VERKETTEN("D00";A3);6);"")))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruss
Peter


Bild


Betrifft: AW: In einer Spalte Text formatieren von: Peter
Geschrieben am: 11.02.2005 13:50:54

Achso jetzt habe ich das erst verstanden, dass die Formel dort schon steht wie ich das generieren kann.
Ich habe die Formel oben reinkopiert und auf bestätigt, aber der macht nix.
Statt dessen steht nun in meiner Zeilenüberschrift die Formel "B1 : =LINKS(LINKS("D00";11-LÄNGE(A1))&A1;6)"

Mit der Spalte A ist nix passiert :(


Bild


Betrifft: AW: In einer Spalte Text formatieren von: =Peter=
Geschrieben am: 11.02.2005 13:54:01

Hallo Peter,

das ist die Formel:

=LINKS(LINKS("D00";11-LÄNGE(A1))&A1;6)

Wenn du die in Spalte B kopierst klappt es.

Gruss
Peter


Bild


Betrifft: DANKE!! von: Peter
Geschrieben am: 11.02.2005 15:23:42

Herzlichen Dank für die Mühe!
Ihr habt mir viel Arbeit gespart!! Weiter so!


Bild


Betrifft: erledigt oT von: Piet
Geschrieben am: 11.02.2005 15:25:31

t


 Bild

Beiträge aus den Excel-Beispielen zum Thema "In einer Spalte Text formatieren"