Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sortierreihenfolge (Kombination mehrerer Zellen)

Sortierreihenfolge (Kombination mehrerer Zellen)
Karsten
Hallo zusammen,
ich habe vor einigen Wochen Hilfe vom User CitizenX bekommen.
Er konnte mir bei meinem Sortierproblem helfen.
Mir ist gestern allerdings aufgefallen, dass die Datei einen Fehler produziert, den ich selber nicht beheben kann.
Trägt man für ein Projekt, aber verschiedene Vorgänge mehrfach das selbe Datum ein, überträgt Excel lediglich den Ersten Vorgang in die Übersicht (gelb markiert).
Ich bekomme es nicht hin, dass die verschiedenen Vorgänge in der Übersicht angezeigt werden. Habt ihr vielleicht eine Idee?
Gruß
Karsten
Hier der Link zur Datei:
https://www.herber.de/bbs/user/72242.xls
Hier der Link zum alten Beitrag:
https://www.herber.de/forum/archiv/1180to1184/t1183270.htm#1183656

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Sortierreihenfolge (Kombination mehrerer Zellen)
11.11.2010 21:40:06
fcs
Hallo Karsten,
wenn die identischen Datum immer in aufeinander folgenden Spalten stehen, wie im Beispiel H bis J, dann kannst du zur Korrektur der Spalte die Formel wie folgt anpassen. Die Formel in J27 kannst du dann nach unten kopieren.
Gruß
Franz
Tabelle1

 J
26Vorgang
27VM

Formeln der Tabelle
ZelleFormel
J27=INDEX($H$5:$M$5;;VERGLEICH($H27;(BEREICH.VERSCHIEBEN($H$5:$M$5;VERGLEICH($I27;$G$6:$G$20;0); ;;7)); 0)+SUMMENPRODUKT((H27=$H$27:H27)*(I27=$I$27:I27))-1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige
AW: Sortierreihenfolge (Kombination mehrerer Zellen)
11.11.2010 22:59:38
Karsten
Hallo Franz,
danke, das ist schon mal super. Das Problem sind mögliche Verschiebungen in den Montageterminen.
Es ist also durchaus möglich, dass beispielsweise auch in der ersten und einer der letzten Spalten das gleiche Datum auftaucht. Habe ich hier eine Möglichkeit das abzufangen?
Gruß
Karsten
AW: Sortierreihenfolge (Kombination mehrerer Zellen)
13.11.2010 18:27:09
fcs
Hallo Karsten,
eine sollche Streuung der Daten lässt sich nach meiner Einschätzung nur mit Hilfsspalten mit Standardformeln auswerten.
Gruß
Franz
Tabelle1

 GHIJKLMNOP
5 VMEMRolle VMRolle EMFußSpitze   
61030.09.1030.09.1001.10.1007.10.1027.09.1030.09.10   
72020.09.1004.10.1028.09.1011.10.1027.09.1008.10.10   
83022.09.1006.10.1001.10.1014.10.1029.09.1012.10.10   
94024.09.1008.10.1006.10.1019.10.1030.09.1013.10.10   
105029.09.1013.10.1012.10.1025.10.1007.10.1020.10.10   
116004.10.1018.10.1014.10.1027.10.1019.10.1001.11.10   
127007.10.1022.10.1015.10.1028.10.1014.10.1027.10.10   
138008.10.1022.10.1020.10.1002.11.1021.10.1003.11.10   
149013.10.1026.10.1020.10.1002.11.1021.10.1003.11.10   
1510015.10.1028.10.1025.10.1005.11.1022.10.1004.11.10   
1611021.10.1001.11.1027.10.1009.11.1028.10.1010.11.10   
1712022.10.1004.11.1028.10.1010.11.1029.10.1011.11.10   
1813028.10.1005.11.1003.11.1016.11.1029.10.1011.11.10   
1914029.10.1011.11.1004.11.1017.11.1005.11.1018.11.10   
2015003.11.1012.11.1010.11.1023.11.1005.11.1018.11.10   
21    Hilfswerte     
26 DatumProjektVorgang123456
27 20.09.1020VM111111
28 22.09.1030VM111111
29 24.09.1040VM111111
30 27.09.1010Fuß000011
31 27.09.1020Fuß000011
32 28.09.1020Rolle VM001111
33 29.09.1030Fuß000011
34 29.09.1050VM111111
35 30.09.1010VM122223
36 30.09.1010EM122223
37 30.09.1010Spitze122223
38 30.09.1040Fuß000011


Formeln der Tabelle
ZelleFormel
H27{=KKLEINSTE($H$6:$M$20;ZEILE(A1))}
I27{=INDEX(G$6:G$20;KGRÖSSTE(WENN(H$6:M$20=H27;ZEILE($1:$15)); ZÄHLENWENN(H27:H$116;H27)))}
J27=INDEX($H$5:$M$5;;INDEX($K$26:$P$26;VERGLEICH(SUMMENPRODUKT((H27=$H$27:H27)*(I27=$I$27:I27)); K27:P27;0)))
K27=WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); K$26-1); 1;1); 1;0)
L27=K27+WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); L$26-1); 1;1); 1;0)
M27=L27+WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); M$26-1); 1;1); 1;0)
N27=M27+WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); N$26-1); 1;1); 1;0)
O27=N27+WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); O$26-1); 1;1); 1;0)
P27=O27+WENN($H27=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I27;$G$6:$G$20;0); P$26-1); 1;1); 1;0)
H28{=KKLEINSTE($H$6:$M$20;ZEILE(A2))}
I28{=INDEX(G$6:G$20;KGRÖSSTE(WENN(H$6:M$20=H28;ZEILE($1:$15)); ZÄHLENWENN(H28:H$116;H28)))}
J28=INDEX($H$5:$M$5;;INDEX($K$26:$P$26;VERGLEICH(SUMMENPRODUKT((H28=$H$27:H28)*(I28=$I$27:I28)); K28:P28;0)))
K28=WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); K$26-1); 1;1); 1;0)
L28=K28+WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); L$26-1); 1;1); 1;0)
M28=L28+WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); M$26-1); 1;1); 1;0)
N28=M28+WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); N$26-1); 1;1); 1;0)
O28=N28+WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); O$26-1); 1;1); 1;0)
P28=O28+WENN($H28=INDEX(BEREICH.VERSCHIEBEN($H$5;VERGLEICH($I28;$G$6:$G$20;0); P$26-1); 1;1); 1;0)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige
AW: Sortierreihenfolge (Kombination mehrerer Zellen)
14.11.2010 18:45:13
Karsten
Vielen, vielen Dank!
Das funktioniert tadellos!
Gruß
Karsten

303 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige