Summe von leeren Zellen nicht als 0



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Summe von leeren Zellen nicht als 0
von: Arnd
Geschrieben am: 20.06.2002 - 16:49:31

Hallo Forum

ich habe folgendes Problem:

In einer Tabelle bilde ich für einige Zellbereiche (immer so ca. 50 Zellen) Summen. Nun sollen diese Summenzellen leer sein, wenn in den Zellen, die aufsummiert werden nichts steht.
Es soll aber nicht so sein,

=WENN(Summe(A1:A50)=0;"";Summe(A1:A50))

denn es kann vorkommen, dass die Summe wirklich 0 ergibt.
Ich habe aber auch keine Lust folgendes zu tippen:

=WENN(UND(A1="";A2="";A3=""...usw.);"";Summe(A1:A50))

Gibt es nicht eine Funktion, die den ganzen Bereich (A1:A50) abdeckt?

z.B. =WENN((A1:A50)="";"";Summe(A1:A50)) (Ich weiß diese Formel geht nicht!)

Ich hoffe Ihr könnt mir helfen.

Vielen Dank im voraus.
Gruß Arnd








nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: MikeS
Geschrieben am: 20.06.2002 - 17:10:20

Hallo Arnd,

probier`s mal damit:

=WENN(SUMMEWENN(A1:A50;"<>""";A1:A50)=0;"";SUMME(A1:A50))

Ciao MikeS

nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Hajo
Geschrieben am: 20.06.2002 - 17:26:25

Hallo Arnd,

vielleicht hilft Dir diese Formel:

=WENN(PRODUKT(A1:A50)<>0;SUMME(A1:A50);"")

Voraussetzung ist, daß Deine Tabelle keine explizite "0" hat.

Gruß Hajo

nach oben   nach unten

Re: An MikeS
von: Arnd
Geschrieben am: 20.06.2002 - 17:46:01

Hallo Mike,

ich kapiere die Formel nicht so ganz, vielleicht kannst Du mir mal erklären, was Du meinst.
Mir kommt es auch so vor, als ob in Deiner Formel ein paar Anführungszeichen zuviel sind?!?
Wäre nett wenn Du antworten könntest.

Gruß Arnd


nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Arnd
Geschrieben am: 20.06.2002 - 17:48:40

Hallo Hajo,

es ist leider möglich, dass in den Zellen, die aufsummiert werden, 0 vorkommt.

Trotzdem Danke

Gruß Arnd


nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Hajo
Geschrieben am: 20.06.2002 - 17:58:29

Hallo Arnd,
noch etwas besser:

=WENN(ZÄHLENWENN(A1:A50;"")=50;"";SUMME(A1:A50))

Gruß Hans-Joachim

nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Arnd
Geschrieben am: 20.06.2002 - 18:05:45

Hallo Hajo,

ich habe die Formel kopiert und ausprobiert, klappt aber nicht.

Gruß Arnd


nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Hajo
Geschrieben am: 21.06.2002 - 08:59:00

Hallo Arnd,
ich habe die Formel nochmal geprüft. Bei mir funktioniert es. Man muß aber darauf achten, daß die Zellen wirklich leer sind und nicht etwa Leerstellen enthalten. Der Inhalt einer Zelle muß also "" enthalten anstatt " ".


Gruß Hajo


nach oben   nach unten

Re: Summe von leeren Zellen nicht als 0
von: Arnd
Geschrieben am: 21.06.2002 - 09:38:54

Hallo Hajo,

bei mir funktioniert es jetzt auch, aber nur in meiner richtigen Datei. In der Beispieldatei, in die ich Deine Formel kopiert habe, geht es nicht.

Ich verstehe zwar nicht wieso, aber so ist es halt.
Vielen Dank nochmals.

Gruß Arnd


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Summe von leeren Zellen nicht als 0"