Zelle "jungfräulich" lassen

Bild

Betrifft: Zelle "jungfräulich" lassen
von: NDYpsilon
Geschrieben am: 18.05.2015 22:01:54

Hallo,
folgendes Zenario,
Eingabezelle A1
B1: =Wenn(A1="";"";A1)
Ausgabe C1: =B1+1
Wenn keine Eingabe gemacht wurde, liefert C1 #WERT! zurück.
Soviel weiß ich.
Liegt daran, dass [Dann_Wert] mit ;""; B1 als Text formatiert.
Wenn ich [Dann_Wert] mit ;; angebe liefert C1 sehrwohl 1 zurück, aber
in B1 steht 0
Wenn möglich, wie muss [Dann_Wert] lauten, dass C1 ein Ergebnis liefert
und B1 wie A1 aussieht & verhält?
Bedingte Formatierung, Istfehler() und dergleichen ist bekannt, möchte ich aber vermeiden.
Danke für Eure Hilfe,
auch wenns nur ein "Geht nicht" ist...

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: Nepumuk
Geschrieben am: 18.05.2015 22:13:48
Hallo,
das geht nur per VBA.
Gruß
Nepumuk

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: Uwe Küstner
Geschrieben am: 18.05.2015 22:14:11
Hallo,
einfach in C1: =SUMME(B1;1) eintragen.
Gruß Uwe

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: Spenski
Geschrieben am: 18.05.2015 22:16:03
Hi
Also mir fällt da auch sonst nur noch C1=wennfehler(B1+1;"") ein aber das suchst du ja nicht.
Bin mal gespannt ob was kommt, würd mich auch mal interessieren
Hans mal offen gelassen
Gruss

Bild

Betrifft: Zelle quasi "jungfräulich" ist tatsächlich nur ...
von: Luc:-?
Geschrieben am: 19.05.2015 01:19:51
…per VBA zu erreichen, NDY;
allerdings gibt's auch noch andere Möglichkeiten, von denen bereits ein(ig)e genannt wurde(n). Darüber hinaus sind auch folgende Varianten möglich:

 ABC
15112
16  1
17 -01
18001
19B15[:B16]:=WENN(A15="";"";A15)
20C15[:C16]:=N(B15)+1
21Format (B17:B18): 0;;0
22Formel (B17:B18): =WENN(ISTLEER(A17);Neg(0);A17)
23Formel (C17:C18): =B17+1

In der 2.Variante ist hier zwar auch VBA (in Form der UDF Neg) im Spiel, deren Ergebnis einer echten roten Null lässt sich gelegentlich aber auch mit StandardFktt erzielen. Das ist aber nur dann sinnvoll, wenn sonst keine negativen Werte vorkommen, weil so eingetra­gene Nullen erhalten bleiben und nur die hier rot dargestellte nicht angezeigt wird. Damit kann dann in C auch die einfache Addition fehlerfrei angewendet wdn.
Mir scheint die 2.Variante aber unnötig aufwendig zu sein, da man ein analoges Ergebnis in C auch nach Variante 1 durch Anwendung der XlFkt N erreichen kann, was noch simpler als SUMME sein dürfte.
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: Peter (hpo)
Geschrieben am: 19.05.2015 13:25:33
Hallo
Mach doch
Eingabezelle A1
B1: =Wenn(A1="";"";A1)
Ausgabe C1: =A1+1
Viele Grüße
Peter (hpo)

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: NDYpsilon
Geschrieben am: 19.05.2015 17:29:01
Danke für die Hilfe!
@Peter (hpo)
... musste Schmunzeln
und Entschuldigung für die missverständliche Erklärung.
Ich versuchs nochmal.
Wenn nichts als Lösung irgend einer Syntax in einer Zelle steht,
dann steht eben nicht nichts.
Die Standardformatierung geht verloren.
Vielleicht macht der Dateianhang das Gedankspiel etwas deutlicher...
https://www.herber.de/bbs/user/97723.xlsx

Bild

Betrifft: Haben wohl alle außer evtl Peter verstanden, ...
von: Luc:-?
Geschrieben am: 19.05.2015 18:29:22
…NDY,
aber auf die anderen Vorschläge gehst du ja nicht ein! Was soll das also wdn…? :-/
Die Xl-Realität kannst du nur wie gezeigt oder mit VBA umgehen! Dein Datei-Bsp nutzt da gar nichts!
Luc :-?

Bild

Betrifft: AW: Zelle "jungfräulich" lassen
von: Peter (hpo)
Geschrieben am: 20.05.2015 07:14:41
Hallo
Dann vieleicht so:
Eingabezelle A1
B1: =Wenn(A1="";"";A1)
Ausgabe C1: =Wenn(B1="";1;B1+1)
Viele Grüße
Peter (hpo)

Bild

Betrifft: Ich fürchte nur, Peter, NDY meint das Ganze ...
von: Luc:-?
Geschrieben am: 20.05.2015 14:37:55
…etwas grundsätzlicher, was aber aus seinen Texten nur schwer herauszu­interpretieren ist.
Gruß, Luc :-?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zelle "jungfräulich" lassen"