Microsoft Excel

Herbers Excel/VBA-Archiv

ersten Wert einer Spalte


Betrifft: ersten Wert einer Spalte von: Thomas
Geschrieben am: 01.04.2018 21:58:05


Hallo Excelfreunde,

mit der Formel in Tabelle2 ( c5 ) :

=VERGLEICH("?*";INDEX(Tabelle1!A1:A999&"";0);0)

kann ich feststellen an welcher Stelle sich der erste Wert in der Tabelle1 Spalte A befindet. Das Ergebnis ist eine Zahl.

Nun möchte ich aber gern den Inhalt dieser Zelle ausgeben.

Mein Problem ist das ich vorher nicht weiß in welcher Zeile sich das erste wert befindet (es sind Importdaten ).

besten dank schon mal im voraus

mfg thomas

Wichtig ist auch noch das ich die komplette Tabelle1 vor dem Import löschen muss ( mit Worksheets("tabelle1").Cells.Clear

Da dieser Löschvorgang in den Formeln meist ein Bezugsfehler ergibt suche ich eine
vielleicht mit INDIREKT oder so. So das Sie das löschen der Tabelle 1 überlebt.

Hat jemand eine Idee wie ich dies lösen könnte?

  

Betrifft: AW: ersten Wert einer Spalte von: SF
Geschrieben am: 01.04.2018 22:03:39

Hola,

da wo du die Formel her hast, steht es doch schon:

http://www.excelformeln.de/formeln.html?welcher=49

Gruß,
steve1da


  

Betrifft: AW: ersten Wert einer Spalte von: Thomas
Geschrieben am: 01.04.2018 22:50:41

Hallo steve1da,

erstmal besten dank das du dir dies mal angeschaut hast.

Deine antwort hat mir zur Lösung gebracht so funktioniert es.

=INDEX(INDIREKT("'temp'!$a$1:$a500");VERGLEICH(WAHR;INDIREKT("'temp'!$a$1:$a500")<>"";0))

hab rechtvielen dank

MFG thomas


  

Betrifft: ups ist nicht mehr offen sorry von: Thomas
Geschrieben am: 01.04.2018 22:51:30

.


  

Betrifft: AW: ersten Wert einer Spalte von: Gerd L
Geschrieben am: 01.04.2018 23:09:48

Hi

=INDEX(Tabelle1!A1:A999;VERGLEICH("?*";INDEX(Tabelle1!A1:A999&"";0);0))

Gruß Gerd


  

Betrifft: besten dank GerdL von: Thomas
Geschrieben am: 01.04.2018 23:39:08

Hallo GerdL,

hab besten dank für dein Vorschlag. Dies gefällt mir sogar noch besser.

Ich musste nur noch den Bereich mit INDIREKT("'tabelle1'!$a$1:$a500") angeben damit kein Bezugs Fehler entsteht.

super.

MFG Thomas


Beiträge aus dem Excel-Forum zum Thema "ersten Wert einer Spalte"