Microsoft Excel

Herbers Excel/VBA-Archiv

"" mit Suchen zählen

Betrifft: "" mit Suchen zählen von: Micha195
Geschrieben am: 13.09.2004 15:20:02

Habe jetzt mit "Anzahl(Suchen({"~?"."~*"};A1))eine Funktion, die mir alle Zellen mit 1 bewertet, welche diese Einträge enthalten. Nun sollen aber noch die Zellen mit dieser Formel erfasst werden, die leer sind, bzw. keine Werte enthalten. Bei der "Wenn"-Funktion trägt man hier "" ein, das funzt aber bei Suchen nicht, da werden dann nämlich auf einmal Zellen mit Werten versehen, auch wenn nur irgendwas drin steht.

Gruß

  


Betrifft: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Boris
Geschrieben am: 13.09.2004 15:27:56

Grüße Boris


  


Betrifft: AW: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Micha195
Geschrieben am: 13.09.2004 15:41:20

Wunderbar. Danke nochmal.
Aber wieso muss ich das so trennen und wieso zählt Excel sonst jeden Eintrag?
Achso, so nun gehört es zu der Funktion Anzahl, oder?

Nebenbei habe schon selber gerade etwas anderes gebastelt und nochmal das Wenn ausgegraben. Ist das auch ok? (Nachteile?)

=WENN(...H3="";ANZAHL(SUCHEN({"~*"."~?"};G3));WENN(G3="";1;)*0)

wobei H3 die Prüfung einer anderen Zelle ist, welche funktioniert. Das Sternchen hat mir Excel vorgeschlagen, wieso eigentlich?

Ok, danke nochmal für die Hilfe !!!!


  


Betrifft: AW: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Boris
Geschrieben am: 13.09.2004 15:54:17

Hi Micha,

Achso, so nun gehört es zu der Funktion Anzahl, oder?

Nein, gehört es nicht. Sieh dir mal die Klammersetzung genau an.

Nebenbei habe schon selber gerade etwas anderes gebastelt und nochmal das Wenn ausgegraben. Ist das auch ok? (Nachteile?)

Ich mag halt kein WENN (schon mal gar keine dieser unsäglichen Verschachtelungen), da es in 99% der Fälle auch ohne geht.

=WENN(...H3="";ANZAHL(SUCHEN({"~*"."~?"};G3));WENN(G3="";1;)*0)

wobei H3 die Prüfung einer anderen Zelle ist, welche funktioniert. Das Sternchen hat mir Excel vorgeschlagen, wieso eigentlich?


Das letzte (fette) WENN ist völlig sinnlos durch die Multiplkation mit Null - das Ergebnis wird immer Null sein. Meintest du das mit "Sternchen vorschlagen"?

Grüße Boris


  


Betrifft: AW: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Micha195
Geschrieben am: 13.09.2004 16:07:09

Hm, das Problem ist, das er nun die Leeren gar nicht mitzählt, warum auch immer... Ja habe jetzt gesehen, dass es nicht zu Anzahl gehört, aber wozu gehört es dann?

Wg. dem Stern: Ja eigentlich wollte ich keine Multiplikation, dadurch gibt es keine Zählung. Die Null gehört eigentlich zu einer Abfrage ob die Zelle H3 leer ist, denn nur dann brauche ich den anderen Kram überhaupt berechnen.

Hm Schade irgendwie, war das doch noch nicht die Lösung...

Gruß


  


Betrifft: AW: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Micha195
Geschrieben am: 13.09.2004 16:52:34

Ah!
Jetzt klappt es! Da waren in der vorgelagerten Wenn-Überprüfung noch Verknüpfungen zu aktualisieren. Also Danke nochmal.

Habe jetzt auch gesehen, dass diese letzte Klammer wohl eine Richtig oder Falsch-Prüfung ist? Also nun hoffe ich dass es für heute auch genug ist.

Gruß


  


Betrifft: AW: =ANZAHL(SUCHEN({"~?"."~*"};A1))+(A1="") von: Boris
Geschrieben am: 13.09.2004 22:50:54

Hi Micha,

dass diese letzte Klammer wohl eine Richtig oder Falsch-Prüfung ist

Genau so ist es.

Grüße Boris


 

Beiträge aus den Excel-Beispielen zum Thema """ mit Suchen zählen"