Tabelle auf Doppeleinträge überprüfen (mit VBA)

Bild

Betrifft: Tabelle auf Doppeleinträge überprüfen (mit VBA) von: Martin
Geschrieben am: 21.02.2005 21:50:24

Hallo,

kann mir bitte einer mit VBA weiterhelfen.
Angenommen ich habe eine Liste, bei welcher in Spalte A1 - A10000
eine Artikelnummer und in Spalte B1 - B10000 die Bezeichnung steht.
Wie kann man mit VBA einen Vergleich auslösen, welcher die doppelten
oder dreifachen Einträge Fett markiert. Da vermutlich viele unterschiedliche
Doppeleinträge existieren wäre es ideal, wenn diese gefundenen Werte nummeriert
würden und zwar in der Spalte C.

Beispiel:
Spalte
A________B________C
001______Art.1____1
002______Art.2____2
003______Art.3____
004______Art.2____2
005______Art.4____
006______Art.1____1

usw.

Vielleicht existiert bereits ein solches Beispiel.
Für jeden Vorschlag oder ein VBA-Beispiel wäre ich sehr dankbar.

Mit besten Grüßen

Martin

Bild


Betrifft: AW: Tabelle auf Doppeleinträge überprüfen (mit VBA) von: paula
Geschrieben am: 21.02.2005 22:14:27

Hi Martin
kanns auch ohne VBA sein?
hier eine Beispiellösung:

Doppelte Einträge
Annahme: Deine Werte stehen in A1 bis Axx
A2 anwählen, Format, Bedingte Formatierung (bei bedingter Formatierung soll es eine Grenze von 2050 Zeilen geben, mal selber Testen)
- "Formel ist" auswählen NICHT "Zellwert ist"
Bei der Formel eingeben =ZÄHLENWENN(A$1:A1;A2)>=1
Bei Format dann z.B. Musterfarbe rot auswählen mit OK beenden.
Die Formatierung auf Die Zellen A3 bis Axx kopieren. Fertig
Dann werden Doppelt farblich gekennzeichnet

oder
kann man auch die Doppeleingabe selber verhindern:
z.B.unter Daten, Gültigkeit, benutzerdefiniert
Formel
=ZÄHLENWENN(A:A;A1)=1
nach unten kopieren


Gruss paula


Bild


Betrifft: AW: Tabelle auf Doppeleinträge überprüfen (mit VBA von: Martin
Geschrieben am: 21.02.2005 22:29:22

Hallo Paula,

danke. Das habe ich schon gehabt.

Warum VBA?
Mit der Nummerierung in Spalte C hat es eine Besonderheit.
Sobald ich den Button Vergleichen betätigt habe und alle Nummerierungen
eingetragen wurden, kann ich mit dem Filter alle Doppeleinträge mit 1, 2 od. 3
herausfiltern und manuell bearbeiten oder löschen.

Nochmals vielen Dank.

Schöne Grüße
Martin


Bild


Betrifft: AW: Tabelle auf Doppeleinträge überprüfen (mit VBA von: Josef Ehrensberger
Geschrieben am: 21.02.2005 22:37:15

Hallo Martin!

Wird aber bei 10000 Zeilen einige Augenblicke dauern!


      
Option Explicit

Sub MachFettMitNummer()
Dim rng As Range, Bereich As Range, f As Range
Dim arr As Variant
Dim r As Long, i As Long, c As Integer

Set Bereich = Range("A1:A10000"'Bereich mit Artikelnummern hier anpassen

arr = Bereich

Bereich.Font.Bold = 
False
Bereich.Offset(0, 2).ClearContents

   
For c = 1 To UBound(arr, 2)
   
      
For r = 1 To UBound(arr, 1)
      
         
If Application.CountIf(Bereich, arr(r, c)) > 1 Then
         
            
If Bereich.Cells(r, c) <> "" And _
               Bereich.Cells(r, c).Offset(0, 2) = 
"" Then
            
            i = i + 1
            Bereich.Cells(r, c).Font.Bold = 
True
            Bereich.Cells(r, c).Offset(0, 2) = i
            
            
Set f = Bereich.Find(arr(r, c), after:=Bereich.Cells(r, c), _
                                                      lookat:=xlWhole)
            
               
Do
               
               f.Font.Bold = 
True
               f.Offset(0, 2) = i
               
Set f = Bereich.FindNext(f)
               
               
Loop While f.Font.Bold = False
               
            
Set f = Nothing
            
            
End If
            
         
End If
         
      
Next
      
   
Next

End Sub 


     Code eingefügt mit Syntaxhighlighter 3.0



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Tabelle auf Doppeleinträge überprüfen (mit VBA von: Martin
Geschrieben am: 21.02.2005 22:43:26

Hallo Sepp,

wau, genau das habe gesucht.
Habe es ausprobiert und funktioniert bestens.

Vielen Dank

Gruß Martin


Bild


Betrifft: AW: Tabelle auf Doppeleinträge überprüfen (mit VBA) von: th.heinrich
Geschrieben am: 21.02.2005 22:39:49

hallo Martin,

schon mal an den Spezialfilter gedacht?

gruss thomas


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabelle auf Doppeleinträge überprüfen (mit VB"