Arbeitszeiten aus Einzelblättern in Gesamtübersich

Bild

Betrifft: Arbeitszeiten aus Einzelblättern in Gesamtübersich von: Günther Nebel
Geschrieben am: 20.03.2005 16:39:17

In einer Stundenverwaltung habe ich für jeden Mitarbeiter ein eigenes Blatt
mit dem aktuellen Jahr angelegt, wobei in A2 das Datum steht und ab Spalte B z.B. Beginn - Ende, der Arbeitszeiten
Es wäre äußerst angenehm, ein Übersichtsblatt zu haben, wobei in diesem die
Stunden des vergangenen Tages angezeigt werden.
Ich meine das so:

In A1 trage ich das gewünschte Datum der Übersicht ein. In A2 bis A8 stehen dann die Hinweise wie z.B. Beginn, Pause 1, Ende...
Beginnend von Spalte B1 sind die jeweiligen Namen eingetragen, also B1 =
Huber, C1 = Maier etc... (übersicht.xls)

Wie krieg ich jetzt das hin, dass in diesem Übersichtsblatt die jeweiligen
Werte aus den Einzelblättern auftauchen.
Mit WENN und SVERWEIS haut das nicht hin. VBA-mäßig bin ich zu sehr Amateur,
aber ich vermute, dass mit einer FOR NEXT-Anweisung sowas funktionieren
könnte?

Die Stammblätter stehen zwischen LEERFORMULAR und ENDE-Blatt, also
chronologisch und sie sind mit Name und Vorname benannt.

Bild


Betrifft: AW: Arbeitszeiten aus Einzelblättern in Gesamtübersich von: Beate Schmitz
Geschrieben am: 20.03.2005 18:36:43

Hallo Günther,

habe dir eine Beispieldatei angehängt:

https://www.herber.de/bbs/user/19903.xls

Basiert auf SVERWEIS-Formel:

 
 ABCD
115.03.2005BeginnEndeArbeitzeit
2Richter08:1814:2206:04
3Maier05:5612:2406:27
4Müller01:3104:4503:14
Formeln der Tabelle
B2 : =SVERWEIS($A$1;Richter;2)
C2 : =SVERWEIS($A$1;Richter;3)
D2 : =SVERWEIS($A$1;Richter;4)
B3 : =SVERWEIS($A$1;Maier;2)
C3 : =SVERWEIS($A$1;Maier;3)
D3 : =SVERWEIS($A$1;Maier;4)
B4 : =SVERWEIS($A$1;Müller;2)
C4 : =SVERWEIS($A$1;Müller;3)
D4 : =SVERWEIS($A$1;Müller;4)
 



Die in der SVERWEIS-Formel vorkommenden Namen sind dynamische Bereiche der jeweiligen Mitarbeiterblätter; da deine Tabelle ja wächst passt sich der Bereich immer an (in der Zeilenzahl - Spaltenzahl müssest du in der Namensdefinitionsformel ändern). Dahin gelangst du über Menü/Einfügen/Namen/Namen definieren....

Gruß,
Beate


Bild


Betrifft: AW: Arbeitszeiten aus Einzelblättern in Gesamtüber von: Günther Nebel
Geschrieben am: 20.03.2005 18:57:14

Liebe Beate,

VIELEN ABER HERZLICHEN DANK !!!
Supergenial

Günther....


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeiten aus Einzelblättern in Gesamtübersich"