SVerweis mit Beachtung von Gross-/Kleinschrift

Bild

Betrifft: SVerweis mit Beachtung von Gross-/Kleinschrift
von: Jörg
Geschrieben am: 22.03.2005 13:57:58
Hallo,
ich versuche einen normalen SVerweis zu nutzen, habe aber das Problem, daß in der Suchmatrix ein Eintrag durchaus "doppelt" vorkommen kann.
Der Unterschied liegt dabei lediglich in der Gross-/Kleinschrift.
Ich muß aber die Einträge zwischen Pvk700 und PVK700 unterscheiden können...
Ideen?
Danke für Hilfe... :-)

Bild

Betrifft: AW: SVerweis mit Beachtung von Gross-/Kleinschrift
von: Boris
Geschrieben am: 22.03.2005 14:23:02
Hi Jörg,
Suchbegriff in A1, Suchspalte: C1:C100, Ergebnisspalte D1:D100.
Folgende Arrayformel:
{=INDEX(D:D;MAX(WENN(IDENTISCH(C1:C100;A1);ZEILE(1:100);-1)))}
Grüße Boris
Bild

Betrifft: AW: SVerweis mit Beachtung von Gross-/Kleinschrift
von: Beate Schmitz
Geschrieben am: 22.03.2005 14:42:29
Hallo,
da war Boris schneller, seine Formel ist natürlich ein Treffer, da ich es aber gerade fertig habe, hier noch meine Lösung (mit Hilfsspalte):
 
 ABC
3HilfsspalteSuchbegriff:Ergebnis:
4796Cpu500Peter
5   
6995Vpa700Uli
7931VPA700Max
8796Cpu500Peter
9732CPU500Otto
Formeln der Tabelle
A4 : =CODE(B4)+CODE(TEIL(B4;2;1))+CODE(TEIL(B4;3;1))+RECHTS(B4;3)
C4 : =SVERWEIS(A4;A6:C9;3;0)
A6 : =CODE(B6)+CODE(TEIL(B6;2;1))+CODE(TEIL(B6;3;1))+RECHTS(B6;3)
A7 : =CODE(B7)+CODE(TEIL(B7;2;1))+CODE(TEIL(B7;3;1))+RECHTS(B7;3)
A8 : =CODE(B8)+CODE(TEIL(B8;2;1))+CODE(TEIL(B8;3;1))+RECHTS(B8;3)
A9 : =CODE(B9)+CODE(TEIL(B9;2;1))+CODE(TEIL(B9;3;1))+RECHTS(B9;3)
 

Gruß,
Beate
Bild

Betrifft: AW: SVerweis mit Beachtung von Gross-/Kleinschrift
von: c0bRa
Geschrieben am: 22.03.2005 14:52:12
wow ;)
kann aber auch sein, dass es zufällig 2 kombinationen gibt, die durch deine berechnung die gleiche nummer kriegen... ne verkettung mit & fänd ich da sicherer (auch wenn es längere nummern ergibt)... ;)

c0bRa
Bild

Betrifft: Welch großer Trugschluss...
von: Boris
Geschrieben am: 22.03.2005 14:52:53
Hi Beate,
gib doch mal als Suchbegriff Cup500 ein ...;-)
Klar, warum?
Grüße Boris
Bild

Betrifft: AW: Welch großer Trugschluss...
von: Beate Schmitz
Geschrieben am: 22.03.2005 15:55:41
Hallo Boris,
das war eindeutig zu kurz gesprungen....
Cobra hat Recht, mit & könnte man diese Schwachstelle beseitigen, aber insgesamt ist ja deine und WF's Formel wesentlich dynamischer. Vergessen wir meins besser.
Gruß,
Beate
Bild

Betrifft: AW: SVerweis mit Beachtung von Gross-/Kleinschrift
von: Jörg
Geschrieben am: 22.03.2005 15:09:24
Danke für die schnelle Hilfe, allerdings habe ich es noch nicht ganz hinbekommen... :-(
Es wird leider der Ergebniswert aus der Zeile UNTER dem Ergebnis angezeigt... ???
Auszug aus meiner Matrix:
____|_A_____|_B_____________ |
746: | PVK700 | Serienangebote |
747: | Pvk700 | Verwalten Bonusgruppen |
748: | PVK705 | Liefervorschlagsliste |
Die Matrix liegt auch in einer anderen Datei und fängt in Zeile 2 an.
Meine Formel sieht also aktuell so aus:
{=INDEX([Maskenübersicht.xls]Menü!$B$2:$B$1000;MAX(WENN(IDENTISCH([Maskenübersicht.xls]Menü!$A$2:$A$1000;A15);ZEILE(2:1000);-1)))}
Ergebnis bei dem Suchkriterium "Pvk700" ist "Liefervorschlagliste" statt "Verwalten Bonusgruppen"?
Nebenbei, habe immer wieder im Selbststudium mit Excel zu tun, aber Array-Formeln habe ich noch nie verstanden?? Verständnishilfe wäre super, obwohl ich auch erstmal glücklich bin, wenn meine Tabelle läuft! ;-)
Bild

Betrifft: Wenn die Matrix in Zeile 2 anfängt; - dann ...
von: WF
Geschrieben am: 22.03.2005 15:23:28
Hi,
{=INDEX(D2:D100;MAX(IDENTISCH(C2:C100;A1)*ZEILE(1:99);-1))}
ZEILE(1:100) sind Platzhalter: diese müssen mit 1 beginnen / also ZEILE(1:99)
Salut WF
Bild

Betrifft: WENN brauchst Du nur bei MIN
von: WF
Geschrieben am: 22.03.2005 14:55:23
Hi Boris,
{=INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100);-1))}
langt
Gruß WF
Bild

Betrifft: NEIN! Ein Trugschluss!
von: Boris
Geschrieben am: 22.03.2005 15:54:02
Hi Walter,
grundsätzlich stimmt das - allerdings hier NICHT.
Warum?
Wenn der Suchwert gar nicht vorkommt, dann liefert
IDENTISCH(C1:C100;A1)*ZEILE(1:100)
im Ergebnis 0 - und das Maximum aus
MAX(0;-1) wäre dann Null.
Die Null wird dann an INDEX übergeben. Und bei INDEX(D:D;0) würde automatisch der Wert aus D1 zurückgegeben werden - und das kann nicht gewollt sein.
Daher die Vorschaltung von WENN - denn bei Nichtvorkommen wird anstatt FALSCH respektive Null die Zahl -1 zurückgegeben - und INDEX(D:D;-1) liefert #WERT! und nicht den Wert aus D1.
Grüße Boris
Bild

Betrifft: stimmt - und
von: WF
Geschrieben am: 22.03.2005 16:17:27
Hi Boris,
genau das gleiche hatte ich Dir ja mal als Tip gegeben - Alzheimer :-)
WF
Bild

Betrifft: Kann ich mich gar nicht mehr dran erinnern...
von: Boris
Geschrieben am: 22.03.2005 16:21:04
Hi Walter,
...also: Auch Alzheimer ;-)
Grüße Boris
Bild

Betrifft: AW: SVerweis mit Beachtung von Gross-/Kleinschrift
von: Jörg
Geschrieben am: 22.03.2005 15:24:45
WF, ich habe Deine kürzere Formel versucht, läuft auch...
aber auch mit falschem Ergebnis! ;-)
Was mache ich falsch?
Bild

Betrifft: siehe 3 Zeilen weiter oben
von: WF
Geschrieben am: 22.03.2005 15:28:46

Bild

Betrifft: ES LÄUFT! :-) SVerweis mit Gross-/Kleinschrift
von: Jörg
Geschrieben am: 22.03.2005 15:41:59
Es läuft!
Mein Problem (zum Schluss) lag in den Angaben der Zeilen.
Ich hatte nicht die korrekte Endzeile angegeben sondern 'einfach mal' eine 1000.
Dachte so könnte ich später beruhigt noch ein paar werte in die Matrix eingeben und die Formel würde immer noch funktionieren... leider nicht.
Nachdem ich das korrigiert habe, läuft die kürzere Formel ohne Probleme.
So, jetzt muß mir nur noch einer erklären, warum!?
Die Bestandteile (INDEX, MAX, IDENTISCH, ZEILE) versteh ich als Einzelelemente,
aber der Zusammenhang und das als Array ist mir nicht klar....
VIELEN DANK FÜR DIE SCHNELLE HILFE!
Bild

Betrifft: Siehe auch: Trugschluss...oT
von: Boris
Geschrieben am: 22.03.2005 15:58:13

Bild

Betrifft: Erklärung der Formel:
von: Boris
Geschrieben am: 22.03.2005 16:42:37
Hi Jörg,
ich erklär es mal an dieser (einzig richtigen ;-) ) Lösung:
{=INDEX(D:D;MAX(WENN(IDENTISCH(C1:C100;A1);ZEILE(1:100);-1)))}
Mit
WENN(IDENTISCH(C1:C100;A1);ZEILE(1:100);-1)
wird der Bereich C1:C100 zeilenweise darauf überprüft, ob der jeweilige Wert mit A1 übereinstimmt. Ist das der Fall, dann wird die Zeilennummer (dafür steht ZEILE(1:100) ) im Array belassen. Ist dies nicht der Fall, dann wird die Zahl -1 an den Array übergeben.
Vorausgesetzt, der Suchbegriff kommt im bereich C1:C100 genau EIN MAL vor, dann hat man am Ende einen Array, aus lauter -1 besteht - und irgendwo dazwischen aus DER Zeilennummer, in der der Suchbegriff steht.
Steht er z.B. in C4, dann sieht der Array so aus:
-1
-1
-1
4
-1
-1
und noch 94 mal -1.
Und aus diesem Array wird mit der Funktion MAX das Maximum ausgelesen - und das ist im Beispiel 4.
Na ja - und diese Zahl 4 wird dann an die Funktion INDEX übergeben: =INDEX(D:D;4)
Das entspricht dann dem Eintrag in D4.
Alles klar?
Grüße Boris
Bild

Betrifft: "einzig richtige Lösung" - Einspruch Euer Ehren!
von: WF
Geschrieben am: 22.03.2005 17:15:05
Hi Boris,
kommt der Suchbegriff nicht vor, gibt's bei Dir ne Fehlermeldung.
Hier nicht:
{=WENN(ANZAHL(FINDEN(A1;C2:C100))=0;"";INDEX(D2:D100;MAX(IDENTISCH(C2:C100;A1)*ZEILE(1:99);-1)))}
Gruß WF
Bild

Betrifft: Einspruch abgelehnt!
von: Boris
Geschrieben am: 22.03.2005 17:20:58
Hi Walter,
mit FINDEN wird auch auf teilweise Übereinstimmung geprüft.
Wenn irgendwo der Suchbegriff enthalten ist, dann liefert ANZAHL(FINDEN(...)) einen Wert größer Null - und die eigentliche Funktion INDEX(...) kommt zur Anwendung.
Nur leider heisst es dann nicht, dass der Suchbegriff auch exakt vorhanden sein muss, da er ja auch nur enthalten sein kann. Und schon sind wir wieder bei der Null...;-))
Grüße Boris
Bild

Betrifft: Um #WERT! zu unterdrücken...
von: Boris
Geschrieben am: 22.03.2005 17:28:35
Hi Walter,
...würd ich folgendes vorschalten:
{=WENN(ODER(IDENTISCH(C2:C100;A1));INDEX(D2:D100;MAX(IDENTISCH(C2:C100;A1)*ZEILE(1:99);-1));"")}
Grüße Boris
Bild

Betrifft: prima; - genauso haben JensF und ich uns vor ...
von: WF
Geschrieben am: 22.03.2005 20:13:05
... der Gründungszeit unserer Seite gegenseitig hochgejagt.
hinten ohne ... ;-1
Und, wenn in Spalte D nur Zahlen als Ergebnis vorkommen können:
{=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.
ist - glaub' ich - einen Beitrag wert
WF

http://www.excelformeln.de/
die ultimative Formelseite
Bild

Betrifft: Ich mach nen Beitrag draus...
von: Boris
Geschrieben am: 22.03.2005 21:47:13
Hi Walter,
...denn so ist es perfekt.
Klasse!
Grüße Boris
Bild

Betrifft: Beitrag steht zur Freigabe bereit :-) oT
von: Boris
Geschrieben am: 22.03.2005 22:05:44
Grüße Boris
Bild

Betrifft: ist im Netz
von: WF
Geschrieben am: 22.03.2005 22:27:25

Bild

Betrifft: Alles klar - und gute Ergänzung! oT
von: Boris
Geschrieben am: 22.03.2005 22:38:47
Grüße Boris
Bild

Betrifft: AW: =MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))
von: FP
Geschrieben am: 22.03.2005 23:38:22
Hallo Walter und Boris,
ganz ohne Array und total kurz und total richtig :-) :-) :-)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Da musst du aber nochmal drüber schlafen...
von: Boris
Geschrieben am: 22.03.2005 23:45:10
Hi Franz,
...und dann poste nochmal...;-)
Grüße Boris
Bild

Betrifft: AW: Da musst du aber nochmal drüber schlafen...
von: FP
Geschrieben am: 23.03.2005 00:14:59
Hallo Boris,
hatte eigentlich =VERWEIS(2;1/IDENTISCH(C1:C100);D1:D100) posten wollen, habe mich aber in meiner Testtabelle beim kopieren der Formel vertan :-(
VERWEIS liefert aber auch #NV
daher:
=WENN(SUMMENPRODUKT(N(IDENTISCH(C1:C100;A1)));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")
jetzt ohne {}, mit {} dann so:
{=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
{=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
ist natürlich eine Arrayformel und liefert den Max-Wert neben gefundenem Suchwert, oder Null :-)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Wo wir wieder bei unserem geschätzten Frank Kabel.
von: Boris
Geschrieben am: 23.03.2005 00:24:51
Hi Franz,
...wären. Immerhin spart er uns 8 Zeichen - ich werde das noch einbauen.
Deine 2. Lösung funktioniert auch nur bei Zahlen.
Grüße Boris
Bild

Betrifft: wirklich gut; - funktioniert aber nicht bei Text
von: WF
Geschrieben am: 23.03.2005 00:25:01

Bild

Betrifft: komisch...
von: FP
Geschrieben am: 23.03.2005 00:23:33
Hallo Boris,
{=INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100))}
liefert bei mir wenn das Suchwort nicht gefunden wird und auch sonst das gleiche Ergebnis wie die schöne lange Formel:
={ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
:D :D :D
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Du musst einfach lernen, zu testen...
von: Boris
Geschrieben am: 23.03.2005 00:28:48
Hi Franz,
ich weiss nicht, wie oft ich dir das schon gesagt habe:
 
 ABCDEFG
1A a1 10
2  b2   
3  c3   
4  d4   
Formeln der Tabelle
F1 : {=INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100)))}
G1 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Grüße Boris
Bild

Betrifft: AW: Meine Testumgebung...
von: FP
Geschrieben am: 23.03.2005 00:39:10
Hallo Boris,
Tabelle2
 ABCDEF
1walter TextZahlen 0
2  boris1 0
3  ist2 0
4  nicht3  
5  BORIS4  
6  und5  
7  WALTER6  
8  war7  
9  nicht8  
10  zu9  
11  finden10  
Formeln der Tabelle
F1 : {=N(INDEX(D:D;REST(0-MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100));101)))}
F2 : {=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
F3 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
F5 : {=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: ...hat eigentlich so ausgesehen...
von: FP
Geschrieben am: 23.03.2005 00:42:06
Hallo Boris,
in F1 habe ich inzwischen schon wieder lauter Blödsinn probiert...
Tabelle2
 ABCDEF
1walter TextZahlen 0
2  boris1 0
3  ist2 0
4  nicht3  
5  BORIS4  
6  und5  
7  WALTER6  
8  war7  
9  nicht8  
10  zu9  
11  finden10  
Formeln der Tabelle
F1 : {=N(INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100))))}
F2 : {=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
F3 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
F5 : {=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ich geh jetzt ins Bett.
Gute Nacht und
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Ich sehe deine von mir angemahnte Formel...
von: Boris
Geschrieben am: 23.03.2005 00:51:46
Hi Franz,
...hier nicht mehr.
Kann mich Walter nur anschließen. TESTE DEINE FORMELN, BEVOR DU SIE SENDEST!
Ich hab keine Lust, jedesmal vor veränderten Tatsachen zu stehen!
Grüße Boris
Bild

Betrifft: AW: ich hab's mir ja gedacht...
von: FP
Geschrieben am: 23.03.2005 00:58:36
Hallo Boris,
und Du auch ???
die Formel in F3 kennst Du aber schon: es ist Eure...
Tabelle2
 ABCDEF
1WALTER TextText2 0
2  borisund 0
3  istWALTER #WERT!
4  nichtist böse
5  BORISmir böse
6  undjetzt  
7  WALTERböse  
8  warweil  
9  nichtich  
10  zueuch  
11  findenschlage  
Formeln der Tabelle
F1 : {=N(INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100))))}
F2 : {=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
F3 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
F4 : =WENN(ISTNV(VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100));"";VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100))
F5 : {=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Ich hab keine Lust mehr...
von: Boris
Geschrieben am: 23.03.2005 01:07:52
Hi Franz,
...in unserem Beitrag steht VOR der von dir geposteten Formel:
Besteht die Ergebnisspalte (hier: Spalte D) ausschließlich aus Zahlen, dann reicht:
Mehr sag ich jetz nicht mehr.
Grüße Boris
Bild

Betrifft: AW: Ich auch nicht! Weil...
von: FP
Geschrieben am: 23.03.2005 01:14:05
Hallo Boris,
ich habe jetzt Eure Formel für Text gefunden - und sie ist länger als meine in F5 :-)
Tabelle2
 ABCDEFGHIJKLM
1bORIs TextText2 0 boris TextText2 78
2  borisund 0   boris78 78
3  istWALTER #WERT!   ist55 78
4  nichtist     nicht63 78
5  BORISmir     BORIS99 78
6  undjetzt     und28  
7  WALTERböse     WALTER8  
8  warweil     war3  
9  nichtich     nicht41  
10  zueuch     zu16  
11  findenschlage     finden6  
Formeln der Tabelle
F1 : {=N(INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100))))}
M1 : {=N(INDEX(K:K;MAX(IDENTISCH(J1:J100;H1)*ZEILE(1:100))))}
F2 : {=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
M2 : {=MAX(WENN(IDENTISCH(J1:J100;H1);K1:K100))}
F3 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
M3 : {=ODER(IDENTISCH(J2:J99;H1))*INDEX(K2:K99;MAX(IDENTISCH(J2:J99;H1)*ZEILE(1:98)))}
F4 : =WENN(ISTNV(VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100));"";VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100))
M4 : =WENN(ISTNV(VERWEIS(2;1/IDENTISCH(J1:J100;H1);K1:K100));"";VERWEIS(2;1/IDENTISCH(J1:J100;H1);K1:K100))
F5 : {=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
M5 : {=WENN(ODER(IDENTISCH(J1:J100;H1));VERWEIS(2;1/IDENTISCH(J1:J100;H1);K1:K100);"")}
F6 : {=WENN(ANZAHL(FINDEN(A1;C2:C100))=0;"";INDEX(D2:D100;MAX(IDENTISCH(C2:C100;A1)*ZEILE(1:99);-1)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus und endgültig
Gute Nacht
Franz
Bild

Betrifft: erst testen und dann posten (nicht umgekehrt)
von: WF
Geschrieben am: 23.03.2005 00:40:57
Deine Formel sollte mal wieder allumfassend sein; - kommt aber mit Texten nicht zurecht.
Ist betr. Zahlen ja wirklich n' Fortschritt aber TESTE Dein Zeug mal - MAN GLAUBT DIR MITTLERWEILE NICHTS MEHR, weil Du mindestens 5 Korrekturen (unaufgefordert) nachlieferst!
WF
Bild

Betrifft: AW: wenn Du meinst
von: FP
Geschrieben am: 23.03.2005 00:54:13
Hallo Walter,
@ niemand glaubt Dir mehr... -> ich könnte Dir genügend Gegenbeweise liefern:
und:
auch EURE Formel arbeitet mit 2 x Text nicht richtig ...
diese Variante (F4: etwas länger aber ohne Array ) dafür schon :-)
die Variante in F5 habe ich ja schon vorgestellt...
Tabelle2
 ABCDEF
1walter TextText2 0
2  borisund 0
3  istWALTER #WERT!
4  nichtist  
5  BORISmir  
6  undjetzt  
7  WALTERböse  
8  warweil  
9  nichtich  
10  zueuch  
11  findenschlage  
Formeln der Tabelle
F1 : {=N(INDEX(D:D;MAX(IDENTISCH(C1:C100;A1)*ZEILE(1:100))))}
F2 : {=MAX(WENN(IDENTISCH(C1:C100;A1);D1:D100))}
F3 : {=ODER(IDENTISCH(C2:C99;A1))*INDEX(D2:D99;MAX(IDENTISCH(C2:C99;A1)*ZEILE(1:98)))}
F4 : =WENN(ISTNV(VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100));"";VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100))
F5 : {=WENN(ODER(IDENTISCH(C1:C100;A1));VERWEIS(2;1/IDENTISCH(C1:C100;A1);D1:D100);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Ich kann unsere Lösung nirgends finden...
von: Boris
Geschrieben am: 23.03.2005 01:05:22
Hi Franz,
...und daher mach ich hier jetzt ein dickes Ausfrufezeichen hinter diesen Beitrag!!!
Wo ist unsere TEXT-Lösung in deinem Beispiel?
DU TESTEST NICHT und LIEST AUCH NICHT RICHTIG!!!
Gute Nacht!
Grüße Boris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVerweis mit Beachtung von Gross-/Kleinschrift"