Microsoft Excel

Herbers Excel/VBA-Archiv

"Intelligentes" Transponieren

Betrifft: "Intelligentes" Transponieren von: Ralf Junglas
Geschrieben am: 25.08.2014 22:26:44

Hallo,

ein Kunde von mir hat mir folgendes Problem angetragen:

Ausgangspunkt ist z. B. folgender Zellbereich (2 Spalten):
A 1, 2, 4
B 1, 5
C 2, 3, 4

Er soll wie folgt aufbereitet werden (4 Spalten):
1 A B
2 A C
3 C
4 C
5 B

(A, B und C sollen in 3 getrennten Spalten erscheinen).

Ich gehe davon aus, dass dies nur mit VBA gelöst werden kann, bin aber
für jeden Hinweis dankbar.

Grüße
Ralf

  

Betrifft: AW: "Intelligentes" Transponieren von: Gerd L
Geschrieben am: 25.08.2014 23:05:47

Hallo Ralf,

lade bitte eine Beispiel-Datei hoch (vorher / nachher).


Gruß Gerd


  

Betrifft: AW: "Intelligentes" Transponieren von: {Boris}
Geschrieben am: 25.08.2014 23:35:13

Hi,

warum taucht A nicht bei 4 auf?

1 A B
2 A C
3 C
4 C A
5 B

Lad mal ein kleines Beispiel hoch - Deine Beschreibung ist dennoch sehr dürftig.

VG, Boris


  

Betrifft: AW: "Intelligentes" Transponieren von: Ewald
Geschrieben am: 26.08.2014 00:55:31

Hallo,

eine Möglichkeit wäre Spalte B mit Text in Spalten aufzusplitten und dann mit der UDF Sverweis2 die Daten zu holen

 ABCD
1A124
2B15 
3C234
4    
5    
61AB  
72CA  
83C  
94AC  
105B  

ZelleFormel
B6=SVERWEIS2(A6;$A$1:$D$3;2;1;;"")&""&SVERWEIS2(A6;$A$1:$D$3;3;1;;"")&""&SVERWEIS2(A6;$A$1:$D$3;4;1;;"")
A7=WENN(A6+1 < MAX($B$1:$D$3);A6+1;MAX($B$1:$D$3))
B7=SVERWEIS2(A7;$A$1:$D$3;2;1;;"")&""&SVERWEIS2(A7;$A$1:$D$3;3;1;;"")&""&SVERWEIS2(A7;$A$1:$D$3;4;1;;"")
A8=WENN(A7+1 < MAX($B$1:$D$3);A7+1;MAX($B$1:$D$3))
B8=SVERWEIS2(A8;$A$1:$D$3;2;1;;"")&""&SVERWEIS2(A8;$A$1:$D$3;3;1;;"")&""&SVERWEIS2(A8;$A$1:$D$3;4;1;;"")
A9=WENN(A8+1 < MAX($B$1:$D$3);A8+1;MAX($B$1:$D$3))
B9=SVERWEIS2(A9;$A$1:$D$3;2;1;;"")&""&SVERWEIS2(A9;$A$1:$D$3;3;1;;"")&""&SVERWEIS2(A9;$A$1:$D$3;4;1;;"")
A10=WENN(A9+1 < MAX($B$1:$D$3);A9+1;MAX($B$1:$D$3))
B10=SVERWEIS2(A10;$A$1:$D$3;2;1;;"")&""&SVERWEIS2(A10;$A$1:$D$3;3;1;;"")&""&SVERWEIS2(A10;$A$1:$D$3;4;1;;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Bei einem Makro muß der gesamte Bereich der vorgegebenen Werte und die Zelle ab wo eingefügt werden soll bekannt sein.

Gruß Ewald


  

Betrifft: ohne VBA: Spezial-Transponieren von: Erich G.
Geschrieben am: 26.08.2014 01:13:55

Hi Ralf,
probier mal

 ABCDEFG
1A1, 2, 4     
2B1, 5 1AB 
3C2, 3, 4 2A C
4   3  C
5   4A C
6   5 B 

Formeln der Tabelle
ZelleFormel
E2=WENN(ISTZAHL(FINDEN(", "&$D2&", ";", "&INDEX($B$1:$B$3;SPALTE(A2)) &", ")); INDEX($A$1:$A$3;SPALTE(A2)); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

P.S. @Ewald: Was ist die "UDF Sverweis2"?


  

Betrifft: AW: "Intelligentes" Transponieren von: Ralf Junglas
Geschrieben am: 26.08.2014 18:09:42

Hallo,

erst Mal vielen Dank für die Antworten.
Fürs Auswerten brauche ich noch 1 oder 2 Tage.

Eine Beispieldatei steht unter dem Link:
https://www.herber.de/bbs/user/92309.xlsx

(stimmt Boris, habe ich tatsächlich vergessen, Danke)

Grüße
Ralf