Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Werkzeug
BildScreenshot zu Werkzeug Werkzeug-Seite mit Beispielarbeitsmappe aufrufen

Formelverbesserung/ Dateigröße (schwierig!!!)

    Betrifft: Formelverbesserung/ Dateigröße (schwierig!!!) von: mimi
    Geschrieben am: 01.10.2003 08:31:41

    Guten Morgen,
    das Thema zu definieren fällt mir nicht leicht. Ich ha eine Datei, die ist
    über 5 MB groß, aber besteht nur aus einer Tabelle (benutzer Bereich A1:AG24).
    Format hatte ich wegen der Größe auf "Standard" gesetzt - keine Verbesserung!
    Weiterhin keine Grafik, kein Garnix!

    liegt das evtl an dieser Formel (sie ist in fast allen Zellen) und wenn kann mann die verbessern?!? Dazu kommt noch das das ganze zum Berechnen sehr lange dauert!
    Die Verknüpfte Datei ist aber auch ca 4 mb groß. Die ist aber im Gegensatz zu dieser auch komplett mit Daten gefüllt!

    hier also die Formel (sie liefert alle Werte aus der Datei - ähnlich wie Sverweis):
    =WENN(ISTNV(VERGLEICH(ZEILE()-3;Werkzeugmängelberichte!$BF:$BF;0));"";INDEX(Werkzeugmängelberichte!C:C;VERGLEICH(ZEILE()-3;Werkzeugmängelberichte!$BF:$BF;0);1))

    Vielen dank für eure Tipps
    Michael

      


    Betrifft: AW: mal unter neuem Namen speichern.. von: Galenzo
    Geschrieben am: 01.10.2003 08:43:12

    Hallo,
    Durch viele Zellformatierungen (u.a. Zeilen oder Spalten ausblenden) kann sich die Datei ganzschön aufblähen.
    Ich denke nicht, daß es an der Formel selbst liegt.
    Schau mal, ob du deine Formatierungen reduzieren kannst - und speichere die Datei mal unter neuem Namen - das sollte die Datei dann verkleinern.


      


    Betrifft: AW: mal unter neuem Namen speichern.. von: mimi
    Geschrieben am: 01.10.2003 09:43:58

    Nein,
    das habe ich längst ausprobiert. Ich habe KEINE Zeile ein oder ausgeblendet.
    Alle Formatierungen (es waren so gut, wie gar keine da) auf Standard zurückgesetzt,
    keine Farben usw. benutzt. Ich hab sogar schon alle nicht wichtigen Zeilen und Spalten komplett gelöscht .... NIX gebraucht ;-(

    Und warum ist die Berechnung so langsam? DAS sit ja das Schlimmste.
    Ist mir ja fast egal, wie groß und wie lange das Öffnen dauert, wenn
    das Ding wenigstens schnell berechnen würde....

    Und ich habe auch schon probiert, die Formel in eine ganz neue Datei zu schreiben.
    Und weil da so viel Bezüge sind (und ich die gar nicht verstehe), bekomme ich das auch nicht hin! :-(

    Micha


      


    Betrifft: AW: Formelverbesserung/ Dateigröße (schwierig!!!) von: Hermann
    Geschrieben am: 01.10.2003 14:29:34

    Hallo Michael,

    ich glaube, wir haben ein ähnliches Problem. Schau mal oben meine Frage so ca. 13:20 Uhr 1.10.2003.

    Ob es an der Formel oder an der (Ursprungs-)Formatierung liegt, kannst du feststellen, wenn du die Zellen alle markierst mit strg c kopuierst und in eine neue Datei einfügst mit strg v.

    Danach testet, ob Formeln genauso langsam wie vorher ausgeführt werden.

    Gruß Hermann