SVERWEIS - Runden in nächst höherer Preisklasse

Bild

Betrifft: SVERWEIS - Runden in nächst höherer Preisklasse
von: Markus
Geschrieben am: 29.10.2003 16:57:47

Hallo XL-Friends

Hab wieder eine kleine Knacknuss.

In der Tabelle "Preise" habe ich eine Preisliste mit Preiskategorien.
Preisgruppe 1 -> 50 Euro
Preisgruppe 2 -> 60 Euro

usw.. es hat 20 Preisgruppen im Ganzen - Die Matrix habe ich "Preise" benannt.
Mittels SVERWEIS kann man jetzt einfach alle Daten darausholen. Nun haben wir ein neues Produkt was immer einen Aufschlag bekommt, meist 50% manchmal aber auch mehr. Nun soll sie aber in die nächst gelegenste Preisgruppe runden.
Also

Preisgruppe 1 (50 Euro) + 50% -> 75 Euro liegt zwischen PG 3 (70 Euro) und 4 (80 Euro). Nun soll er kaufmännisch auf PG 4 runden. Wäre es 74 Euro müsste er aber auf PG 3 runden. Und diesen Preis auch angeben.

Wie kriege ich sowas hin???

Die Felder sind: A1: Preisgruppe (1-20)
B1: Aufschlag in %

D1: sollte den Preis der nächstgelegenen PG angeben
D2: sollte die neue PG angeben.

Noch ein Problem ist wenn jetzt bspw. PG 20 + 50% -> dann gibt es ja keine höheren Preisgruppe mehr, dann soll der genaue Zahl angegeben werden.

Vielen vielen Dank für den support. Ich hoffe das Problem ist verständlich.

Danke!!!

Markus

Bild


Betrifft: AW: SVERWEIS - Runden in nächst höherer Preisklasse
von: Björn B.
Geschrieben am: 29.10.2003 20:57:04

Hallo Markus,

ich gehe mal davon aus, das auf dem Blatt Preise in A1 bis A20 die Preise und in B1 bis B20 die Preisgruppen stehen. In A1 auf Deiner Zieltabelle trägst Du Preis für das neue Produkt (ohne Aufschlag) ein.

Formel in D1:
=WENN(A1*(1+B1)=Preise!A20;A1*(1+B1);SVERWEIS(A1*(1+B1)+5;Preise!A1:A20;1)))

Formel in D2:
=SVERWEIS(D1;Preise!A1:B20;2)

Hilft Dir das weiter?

Gruß
Björn


Bild


Betrifft: Noch offen - +5 nicht gleich Runden.
von: Markus
Geschrieben am: 30.10.2003 09:34:46

Hallo Björn

Nur in diesem fiktiven Beispiel ist es zufälligerweise so das die Preisgruppen in 10 Euro schritte hochgehen. Die echten Preise stehen in keinem Zusammenhang zu einander. Deshalb funktioniert der +5 Euro Trick nicht wirklich.

Troztdem vielen Dank!

Daniel.


Bild


Betrifft: AW: Noch offen - +5 nicht gleich Runden.
von: Björn B.
Geschrieben am: 30.10.2003 20:12:23

Hallo Markus,

dann musst Du schon ein bischen genauer sein in Deinen Angaben.

Kann ich denn davon ausgehen, dass Du ab der Hälfte der Differenz zwischen den beiden Stufen aufrunden willst?

Gruß
Björn


Bild


Betrifft: AW: Noch offen - +5 nicht gleich Runden.
von: Arnim
Geschrieben am: 31.10.2003 00:50:42

Hallo Markus,
beim Blättern im Forum habe ich Deine Frage gelesen. Björn hat schon Recht, denn so ganz sehe ich auch nicht durch. Offensichtlich sind jedoch die Schritte der einzelnen Preisgruppen sehr unterschiedlich.
Ich habe mal rumprobiert und eine Wahnsinnsformel gebastelt. Sie könnte aber in Deinem Sinne funktionieren.
Du kannst sie Dir ja mal ansehen:
https://www.herber.de/bbs/user/1687.xls
Gruß Arnim


Bild


Betrifft: Super Armin!!!!
von: Markus
Geschrieben am: 31.10.2003 17:42:16

Du bist ein Held!!

Vielen vielen Dank!!!!


Bild


Betrifft: Respekt Armin - Gruß Björn - o. T.
von: Björn B.
Geschrieben am: 31.10.2003 21:46:40




 Bild

Beiträge aus den Excel-Beispielen zum Thema " SVERWEIS - Runden in nächst höherer Preisklasse"