Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Zählenwenn

Betrifft: Formel für Zählenwenn von: thomas
Geschrieben am: 14.08.2004 02:22:59

Also, ich schaff es nicht.

Ich möchte per Formel zählen, wer alles Urlaub hat.

Kein Problem, geht einfach mit ZÄHLENWENN. Ich schaffe es aber nicht, eine zweite Bedingung mit UND zu verknüpfen.

Es soll gezählt werden, wenn in B1 "Url" steht und darüber in A1 ein Wochentag ("Sa" oder "So") steht.

Ich denke mal, dass geht mit ZÄHLENWENN(UND()), aber ich bekomme es nicht hin.

Gezählt werden muss natürlich in einem Bereich, z.B. A1:A10 und B1:B10

MfG
T

  


Betrifft: AW: Formel für Zählenwenn von: Hans W. Herber
Geschrieben am: 14.08.2004 02:35:50

Hallo Thomas,

ZÄHLENWENN akzeptiert wie auch SUMMEWENN nur ein Kriterium. Eine Alternative stellen Mattrixformeln dar. Ein Beispiel zu einer Matrixformeln findest Du in meiner Excel-FAQ hier:
https://www.herber.de/mailing/172602h.htm

Matrixformeln sind in der Bearbeitungsleiste kenntlich an den sie umgebenden geschweiften Klammern und werden mit der Tastenkombination STRG+UMSCHALT+ENTER ohne die Klammern eingegeben.

gruss hans


  


Betrifft: AW: Formel für Zählenwenn von: Frank
Geschrieben am: 14.08.2004 10:17:41

Hi Thomas
wie sind Deine Wochentage eingegeben?
1. Als Text
2. Als Datum,. aber mit 'TTT' formatiert

Ich würde hier SUMMENPRODUKT nutzen:
1. Für Textwerte als Wochentag:
=SUMMENPRODUKT(--((A1:A10="Sa")+(A1:A10="So"));--(B1:B10="Url"))

2. Falls Spalte B Datumswerte enthält:

=SUMMENPRODUKT(--(WOCHENTAG(A1:A10;2)>5);--(B1:B10="Url"))


Gruß
Frank


 

Beiträge aus den Excel-Beispielen zum Thema "Formel für Zählenwenn"