Microsoft Excel

Herbers Excel/VBA-Archiv

Bitte nicht , wenn "p"

Betrifft: Bitte nicht , wenn "p" von: dieter-j
Geschrieben am: 24.08.2004 08:16:55

Hallo Forum,ich bastle in einer Tabelle und möchte, das die folgende Berechnung nicht erscheint, wenn in zelle w20 ein "p" steht.(Ich glaube es muss ein UND hinzu, finde aber nicht wohin).


=WENN(D200grösser null;"incl. Teilungsgeschiebe:";WENN(D200=0;""))
(grösser null lies sich hier nicht schreiben :-(
Danke für Eure Tips
dieter

  


Betrifft: AW: Bitte nicht , wenn "p" von: Harald Kapp
Geschrieben am: 24.08.2004 08:20:46

Hallo Dieter,
so etwa:

=WENN(ISTFEHLER(FINDEN("p";W20));"Deine Berechnung";"nix")

Gruß Harald


  


Betrifft: AW: Bitte nicht , wenn "p" von: Nike
Geschrieben am: 24.08.2004 08:21:49

Hi,
=wenn(D200>0;"incl. Teilungsgeschiebe";wenn(D200=0;"";"weder null noch groesser Null"))
das groesser bzw kleiner Zeichen muss mit ~ f ~ eingerahmt werden
(ohne Leerzeichen zwischen ~ und f)

Bye

Nike


  


Betrifft: AW: Bitte nicht , wenn "p" von: Werner
Geschrieben am: 24.08.2004 08:31:44

Hallo Dieter,

meintest du etwa so?

=WENN(W20="p";"";WENN(D200>0;"incl. Teilungsgeschiebe:";""))


Gruss Werner


  


Betrifft: Danke an harald,nike + werner von: dieterj
Geschrieben am: 24.08.2004 20:42:03

ja danke werner, "so meinte ich es". strahl.. :-))))
gruss dieter