Microsoft Excel

Herbers Excel/VBA-Archiv

Zellen auszählen lassen nach häufigkeit....

Betrifft: Zellen auszählen lassen nach häufigkeit.... von: jürgen
Geschrieben am: 30.08.2004 11:22:58

hallo,
ich habe eine tabelle erstellt und möchte die samstage und sonntage auszählen lassen.
und zwar wieviel F - S - N an einem samstag und sonntag vorhanden sind.
der wochentag steht in spalte a - in spalte b die F,S und N's.

kann mir jemand auf die sprünge helfen ?

beispiel siehe unten.

danke und gruß
jürgen


  


Betrifft: AW: Zellen auszählen lassen nach häufigkeit.... von: Stefan
Geschrieben am: 30.08.2004 11:25:55

Hallo Jürgen,
versuch´s mal mit der Funktion =summewenn(......

Gruß

Stefan


  


Betrifft: AW: Zellen auszählen lassen nach häufigkeit.... von: jürgen
Geschrieben am: 30.08.2004 11:36:46

hallo,
aber leider bringt mich deine antwort nicht viel weiter.

jürgen


  


Betrifft: =SUMMENPRODUKT((A1:A1000="Sa")*(B1:B1000="f")) von: Uduuh
Geschrieben am: 30.08.2004 11:56:15




  


Betrifft: AW: Zellen auszählen lassen nach häufigkeit.... von: IngoG
Geschrieben am: 30.08.2004 11:56:47

Hallo Jürgen,

folgende formel sollte es tun:

steht in spalte A wirklich ein "Sa" oder ein Datum mit Format "TTT" ?


Version1:
=summenprodukt((oder(a1:a100="Sa";a1:a100="So"))*(B1:b100="F"))

version2:

=summenprodukt((wochentag(a1:a100;2)<=6)*(B1:b100="F"))

gibt jeweils die anzahl der F's an Smstagen und sonntagen zurück...

Gruß Ingo


  


Betrifft: AW: Zellen auszählen lassen nach häufigkeit.... von: Boris
Geschrieben am: 30.08.2004 12:12:22

Hi Ingo,

Version1:
=summenprodukt((oder(a1:a100="Sa";a1:a100="So"))*(B1:b100="F"))


Sicher? ;-)

Grüße Boris


  


Betrifft: @Boris von: IngoG
Geschrieben am: 30.08.2004 13:03:53

Hallo Boris,

hatte es nicht getestet, aber scheinbar zickt die oder()-funktion wieder ;-)

also dann eben:

Version1
=SUMMENPRODUKT(((A1:A100="Sa")+(A1:A100="So")>0)*(B1:B100="F"))

Dnke für den Hinweis...
Gruß Ingo


  


Betrifft: AW: @Boris von: Frank
Geschrieben am: 30.08.2004 21:31:35

Hi Ingo
nur als Variante :-)
=SUMMENPRODUKT((A1:A100={"Sa"."So"})*(B1:B100="F"))

Frank


  


Betrifft: DANKE - hat funktioniert !!!! ( kein Text ) von: jürgen
Geschrieben am: 30.08.2004 12:31:29

.


 

Beiträge aus den Excel-Beispielen zum Thema "Zellen auszählen lassen nach häufigkeit...."