Datum verfielfältigen und danach hochzählen

Bild

Betrifft: Datum verfielfältigen und danach hochzählen
von: Raphael Käfer
Geschrieben am: 07.04.2005 13:03:22
Hallo zusammen,
ich habe folgendes Problem:
Ich gebe ein Datum (01.03.2005) in eine Zelle (A2) ein, kopiere diese Zelle und füge sie in einer bestimmten Anzahl von Zellen ein. Dann erhöhe ich das Datum um einen Tag (02.03.2005) und vervielfältige es wieder. Die Anzahl in die einzufügenden Zellen ist meistens gleich.
Kann mir jemand helfen das zu automatisieren? Am besten als Makro. Vielen Dank im Voraus!
Liebe Grüße
Raphael Käfer

Bild

Betrifft: AW: Datum verfielfältigen und danach hochzählen
von: Tobias Marx
Geschrieben am: 07.04.2005 13:14:09
Servus!
Als Makro:

Sub Datum()
anfang = 1
  For i = 1 To 31
    For j = anfang To anfang + 4
      Range("A" & j).Value = Date + i
    Next j
  anfang = anfang + 5
  Next i
End Sub

Gruss

Tobias
Bild

Betrifft: AW: Datum verfielfältigen und danach hochzählen
von: HermannZ
Geschrieben am: 07.04.2005 15:42:32
Hallo Raphael,
oder mit Formel;
Beispiel;
Doppelt
 A
215 
21601.03.2005
21701.03.2005
21801.03.2005
21901.03.2005
22002.03.2005
22102.03.2005
22202.03.2005
22302.03.2005
22403.03.2005
22503.03.2005
22603.03.2005
22703.03.2005
22804.03.2005
229 
Formeln der Tabelle
A217 : =WENN(REST(ZEILE();4)=0;A216+1;A216)
A218 : =WENN(REST(ZEILE();4)=0;A217+1;A217)
A219 : =WENN(REST(ZEILE();4)=0;A218+1;A218)
A220 : =WENN(REST(ZEILE();4)=0;A219+1;A219)
A221 : =WENN(REST(ZEILE();4)=0;A220+1;A220)
A222 : =WENN(REST(ZEILE();4)=0;A221+1;A221)
A223 : =WENN(REST(ZEILE();4)=0;A222+1;A222)
A224 : =WENN(REST(ZEILE();4)=0;A223+1;A223)
A225 : =WENN(REST(ZEILE();4)=0;A224+1;A224)
A226 : =WENN(REST(ZEILE();4)=0;A225+1;A225)
A227 : =WENN(REST(ZEILE();4)=0;A226+1;A226)
A228 : =WENN(REST(ZEILE();4)=0;A227+1;A227)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Hinweis;
die Zahl 4 in der Rest Funktion bestimmt wann die Zahl um eins erhöht wird.
Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum verfielfältigen und danach hochzählen"