Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
828to832
828to832
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Wenn Dann mit zwei Variablen

Wenn Dann mit zwei Variablen
20.12.2006 11:46:33
Pohl
Hallo liebe Forumsteilnehmer,
ich habe eine Frage zur Wenn-Dann Funktion. Habe folgenden Fall:
2 Variablen
z.B. Variable X und Y
ich möchte nun Excel sagen: wenn x=1,5 und y=2,0 dann schreibe A, wenn x=2,6 und y=3,7 dann schreibe B usw.
habe 24 abgegrenzte Fälle der zwei Variablen.
Danke für einen kurzen TIPPPPPPP!!

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn Dann mit zwei Variablen
20.12.2006 11:53:37
Rainer
=wenn(und(x=1,5;y=2,0);"A";wenn(und(x=2,6;y=3,7);"B")
Gruß
Rainer
AW: Wenn Dann mit zwei Variablen
20.12.2006 14:26:28
Pohl
Hallo,
erstmal danke für den Tip, aber nach der achten klammer zeigt er mir einen Formelfehler an - kann das sein, dass die Formel beschränkt sind?
Danke
AW: Wenn Dann mit zwei Variablen
20.12.2006 12:10:27
Matthias
Hallo,
wenn du eine Matrix mit den Werten hast (links):
Tabelle2
 ABCDEFG
1xyWert xyWert
21,52A 1,52A
32,63,7B 2,63,7B
41,14,1C    
51,54D    
61,43E    
7       
8       
9       
10       
11       
12       
13       
14       
15       
Formeln der Tabelle
G2 : =WENN(VERGLEICH(E2;$A$2:$A$27;0)=VERGLEICH(F2;$B$2:$B$27;0);BEREICH.VERSCHIEBEN($C$1;VERGLEICH(E2;$A$2:$A$27;0);0);"?")
G3 : =WENN(VERGLEICH(E3;$A$2:$A$27;0)=VERGLEICH(F3;$B$2:$B$27;0);BEREICH.VERSCHIEBEN($C$1;VERGLEICH(E3;$A$2:$A$27;0);0);"?")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Funktioniert aber nur bei eindeutigen Werten, d.h. wenn jede Zahl nur einmal in der Spalte vorkommt.
Gruß Matthias
Anzeige
AW: Wenn Dann mit zwei Variablen
20.12.2006 14:04:06
Pohl
Hallo,
beide Lösungen gehen nicht :
- Lösung mit wenn ... da bricht er mir nach dem achten Wert einfach ab bzw. sagt mir, es gäbe einen Fehler in der Formel - kann es sein, dass man mit dieser Funktion nur 7 Schachtelungen bauen kann ?
- Lösung "Vergleiche" geht nicht, da der eine Wert öfters vorkommt.
Bitte um weitere Lösungen ! Vielen Vielen Dank!

317 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige