Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht-alls Sa mit "a" zählen

Betrifft: Formel gesucht-alls Sa mit "a" zählen von: rieckmann
Geschrieben am: 14.10.2007 22:31:12

Hallo Leute,

ich suche eine Formel.

In Spalte A steht fortlaufend das Datum untereinander.
In Spalte B stehen hinter dem Datum Abkürzungen. Wie z.B, "a"

Nun soll die Formel aus dem Datum die Samstage gezählt werden, hinter dem in Spalte B ein "a" steht.
Dan die Samstage hinter denen ein "u" steht, usw.

Hier die Beispielmappe: https://www.herber.de/bbs/user/46765.xls

Würde mich über eine Lösung sehr freuen.

Gruß
Fred

  

Betrifft: AW: Formel gesucht-alls Sa mit "a" zählen von: Josef Ehrensberger
Geschrieben am: 14.10.2007 22:44:49

Hallo Fred,

Tabelle1

 ABCDEFGHIJ
101.01.2007a        
202.01.2007a        
303.01.2007a        
404.01.2007a        
505.01.2007k Formel gesucht !      
606.01.2007k        
707.01.2007k1alle Samstage aus Spalte A zusammenzählen hinter denen in Spalte B ein a steht     also 1
808.01.2007k2alle Samstage aus Spalte A zusammenzählen hinter denen in Spalte B ein k steht     also 2
909.01.2007u1alle Samstage aus Spalte A zusammenzählen hinter denen in Spalte B ein u steht     also 1
1010.01.2007u        
1111.01.2007u        
1212.01.2007u        
1313.01.2007a        
1414.01.2007a        
1515.01.2007a        
1616.01.2007u        
1717.01.2007u        
1818.01.2007k        
1919.01.2007k        
2020.01.2007k        
2121.01.2007a        
2222.01.2007a        
2323.01.2007a        
2424.01.2007u        
2525.01.2007u        
2626.01.2007u        
2727.01.2007u        
28          
29          

Formeln der Tabelle
ZelleFormel
C7=SUMMENPRODUKT((WOCHENTAG($A$1:$A$30;2)=6)*($B$1:$B$30="a"))
C8=SUMMENPRODUKT((WOCHENTAG($A$1:$A$30;2)=6)*($B$1:$B$30="k"))
C9=SUMMENPRODUKT((WOCHENTAG($A$1:$A$30;2)=6)*($B$1:$B$30="u"))
Excel Tabellen im Web darstellen  Excel Jeanie HTML




Gruß Sepp



  

Betrifft: AW: Formel gesucht-alls Sa mit "a" zählen von: Klaus K.
Geschrieben am: 14.10.2007 23:02:26

Hi
meiner Meinung nach ist auf jedenfall eine Hilfsspalte notwendig. Praktischerweise für Wochentage, die dann via Summenprodukt gezählt werden.
Siehe https://www.herber.de/bbs/user/46767.xls

Gruss
Klaus K.


  

Betrifft: ohne Hilfsspalte siehe Sepp! o.T. von: Christian
Geschrieben am: 14.10.2007 23:06:59




  

Betrifft: AW: Formel gesucht-alls Sa mit "a" zählen von: rieckmann
Geschrieben am: 15.10.2007 13:21:29

Hallo allerseits,

vielen Dank für eure Hilfe.
Es hat geklappt !

Gruß
Fred


 

Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht-alls Sa mit "a" zählen"