Microsoft Excel

Herbers Excel/VBA-Archiv

Höchstes Eingabedatum aus Blocj | Herbers Excel-Forum


Betrifft: Höchstes Eingabedatum aus Blocj von: Bernd
Geschrieben am: 11.01.2010 13:34:31

Hallo zusammen,

ich würde gerne aus Blöcken innerhalb einer Exceltabelle immer das höchste Eingabedatum pro Block ermitteln und das Datum in eine neue Zelle im ersten Datensatz des Blockes ausgeben. Anbei eine Mustervorlage, wäre schön wenn es ohne VBA auch geht!

https://www.herber.de/bbs/user/67128.xls

Gruß
Bernd

  

Betrifft: AW: Höchstes Eingabedatum aus Blocj von: Hajo_Zi
Geschrieben am: 11.01.2010 13:43:55

Halo Bernd,


Tabelle1

 ABCDE
1SchlüsselDatum    Zielspalte
261050001.10.2009    01.10.2009
361050001.05.2008     
461050015.04.2009     
561050016.07.2009     
651250001.12.2009    01.12.2009
751250001.01.2008     
851250013.07.2009     
928525510.02.2005    10.02.2005
1028522201.09.2009    01.09.2009
1128522201.01.2000     

verwendete Formeln
Zelle Formel
E2 {=WENN(ZÄHLENWENN($A$1:A2;A2)=1;MAX(WENN(A:A=A2;B:B));"")}
E3 {=WENN(ZÄHLENWENN($A$1:A3;A3)=1;MAX(WENN(A:A=A3;B:B));"")}
E4 {=WENN(ZÄHLENWENN($A$1:A4;A4)=1;MAX(WENN(A:A=A4;B:B));"")}
E5 {=WENN(ZÄHLENWENN($A$1:A5;A5)=1;MAX(WENN(A:A=A5;B:B));"")}
E6 {=WENN(ZÄHLENWENN($A$1:A6;A6)=1;MAX(WENN(A:A=A6;B:B));"")}
E7 {=WENN(ZÄHLENWENN($A$1:A7;A7)=1;MAX(WENN(A:A=A7;B:B));"")}
E8 {=WENN(ZÄHLENWENN($A$1:A8;A8)=1;MAX(WENN(A:A=A8;B:B));"")}
E9 {=WENN(ZÄHLENWENN($A$1:A9;A9)=1;MAX(WENN(A:A=A9;B:B));"")}
E10 {=WENN(ZÄHLENWENN($A$1:A10;A10)=1;MAX(WENN(A:A=A10;B:B));"")}
E11 {=WENN(ZÄHLENWENN($A$1:A11;A11)=1;MAX(WENN(A:A=A11;B:B));"")}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: AW: Höchstes Eingabedatum aus Blocj von: Bernd
Geschrieben am: 11.01.2010 15:14:31

Hallo Hajo,

irgendwie klappt es nicht so mit der Eingabe. Ich erhalte immer einen Fehler :

#ZAHL!

Kann das an einer Formatierung liegen???

Gruß
Bernd


  

Betrifft: Keine KOMPLETTE Spalte angeben von: NoNet
Geschrieben am: 11.01.2010 15:23:49

Hallo Bernd,

Hajos Lösungsvorschlag enthält einen Fehler : Man darf hier keine kompletten Spalten (A:A und B:B) angeben. So würde es klappen :

{=WENN(ZÄHLENWENN($A$1:A2;A2)=1;MAX(WENN(A$2:A2=A2;B$2:B2));"")}

Gruß, NoNet


  

Betrifft: In E2 : =WENN(A2=A1;"";MAX(WENN(A2:A$2=A2;B2:B$2)) von: NoNet
Geschrieben am: 11.01.2010 13:59:57

Hallo Bernd,

gib in E2 folgende Funktion ein und bestätige diese mit Strg+Shift+ENTER.
Diese Funktion kannst Du dann in Spalte E so weit wie benötigt nach unten kopieren.

Gruß, NoNet


  

Betrifft: Uuuups - das Wichtigste habe ich vergessen von: NoNet
Geschrieben am: 11.01.2010 14:00:57

Hallo Bernd,

ich meinte natürlich diese Funktion :

=WENN(A2=A1;"";MAX(WENN(A2:A$2=A2;B2:B$2)))



Gruß, NoNet


  

Betrifft: AW: In E2 : =WENN(A2=A1;"";MAX(WENN(A2:A$2=A2;B2:B$2)) von: Hajo_Zi
Geschrieben am: 11.01.2010 14:02:50

Hallo NoNet,

es fehlt eine Klammer am Ende.

Gruß Hajo


  

Betrifft: Ja, Betreffzeile war zu kurz - daher Nachtrag _oT von: NoNet
Geschrieben am: 11.01.2010 14:15:57

_oT


  

Betrifft: ACHTUNG Fehler in meiner Vorlage von: Bernd
Geschrieben am: 11.01.2010 15:32:16

Hallo nochmal,

ich muß leider feststellen, dass mir wohl ein dummer Fehler in der Vorlage unterlaufen ist. Was ich versucht habe, verbal einigermaßen zu beschreiben, ging leider in der Vorlage wohl daneben. Deshalb nochmals eine korrgierte und ausführlichere Version mit Erläuterung. Sorry, das mir das passiert ist.

https://www.herber.de/bbs/user/67136.xls


Gruß
Bernd


  

Betrifft: AW: ACHTUNG Fehler in meiner Vorlage von: Hajo_Zi
Geschrieben am: 11.01.2010 15:35:08

Hallo Bernd,

das Problem wurde doch von NoNet und mir gelöst (angpaste Formel von NoNet nicht gesamte Spalte) was ist an unseren Vorschlägen falsch?

Gruß Hajo


  

Betrifft: Noch ein Fehler ? - Oder Verwirrender ? von: NoNet
Geschrieben am: 11.01.2010 15:39:44

Hallo Bernd,

m.E. ist das jetzt noch verwirrender und ohne System :

Für Schlüssel "610500" ist doch der 01.10.2009 später als der 16.07.2009, oder ?
Und für Schlüssel "512500" ist doch der 01.12.2009 später als der 13.07.2009, oder ?

¿ Die geposteten Funktionen waren also korrekt !?!?

Gruß, NoNet


  

Betrifft: AW: Noch ein Fehler ? - Oder Verwirrender ? von: Bernd
Geschrieben am: 11.01.2010 17:15:19

Hallo zusammen,

heute scheint wahrlich nicht mein Tag zu sein. Der Kritik ist natürlich berechtigt. Ich muß leider aber auch gestehen, dass die Ergebnisse bei mir nicht passen. Es wird zwar immer pro Block in der ersten Zeile das Datum angezeigt, aber leider nicht das höchste, sondern wohl vielmehr das erste Datum des jeweiligen Blocks. Was kann noch falsch bei mir sein?

Gruß
Bernd


  

Betrifft: AW: Noch ein Fehler ? - Oder Verwirrender ? von: Hajo_Zi
Geschrieben am: 11.01.2010 17:21:45

Hallo Bernd,

daas kann ich nicht nachvollziehen.
Die Formel hast Du so eingegeben wie beschriebe?.

Tabelle1

 ABCDE
1SchlüsselDatum    Zielspalte
261050001.10.2009    11.01.2010
361050001.05.2008     
461050011.01.2010     
561050016.07.2009     
651250001.12.2009    11.01.2010
751250001.01.2008     
851250011.01.2010     
928525510.02.2005    10.02.2005
1028522201.09.2009    11.01.2010
1128522211.01.2010     

verwendete Formeln
Zelle Formel
E2 {=WENN(ZÄHLENWENN($A$1:A2;A2)=1;MAX(WENN($A$2:$A$11=A2;$B$2:$B$11));"")}
E3 {=WENN(ZÄHLENWENN($A$1:A3;A3)=1;MAX(WENN($A$2:$A$11=A3;$B$2:$B$11));"")}
E4 {=WENN(ZÄHLENWENN($A$1:A4;A4)=1;MAX(WENN($A$2:$A$11=A4;$B$2:$B$11));"")}
E5 {=WENN(ZÄHLENWENN($A$1:A5;A5)=1;MAX(WENN($A$2:$A$11=A5;$B$2:$B$11));"")}
E6 {=WENN(ZÄHLENWENN($A$1:A6;A6)=1;MAX(WENN($A$2:$A$11=A6;$B$2:$B$11));"")}
E7 {=WENN(ZÄHLENWENN($A$1:A7;A7)=1;MAX(WENN($A$2:$A$11=A7;$B$2:$B$11));"")}
E8 {=WENN(ZÄHLENWENN($A$1:A8;A8)=1;MAX(WENN($A$2:$A$11=A8;$B$2:$B$11));"")}
E9 {=WENN(ZÄHLENWENN($A$1:A9;A9)=1;MAX(WENN($A$2:$A$11=A9;$B$2:$B$11));"")}
E10 {=WENN(ZÄHLENWENN($A$1:A10;A10)=1;MAX(WENN($A$2:$A$11=A10;$B$2:$B$11));"")}
E11 {=WENN(ZÄHLENWENN($A$1:A11;A11)=1;MAX(WENN($A$2:$A$11=A11;$B$2:$B$11));"")}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.3



Gruß Hajo


  

Betrifft: AW: Noch ein Fehler ? - Oder Verwirrender ? von: Bernd
Geschrieben am: 11.01.2010 17:45:04

Hallo nochmal,

hier meine Exceldatei bei beiden Lösungen. Bei Dir Hajo erhalte in #-Fehler und bei Notnet leider falsche Datumswerte (kein Maximum). Was mache ich falsch??

https://www.herber.de/bbs/user/67141.xls


Gruß

Bernd


  

Betrifft: AW: Noch ein Fehler ? - Oder Verwirrender ? von: Hajo_Zi
Geschrieben am: 11.01.2010 17:54:27

Hallo Bernd,

#Fehler sehe ich nicht.

Gruß Hajo


  

Betrifft: AW: Noch ein Fehler ? - Oder Verwirrender ? von: Hajo_Zi
Geschrieben am: 11.01.2010 17:56:36

Hallo Bernd,

und benutze die Formel aus dem letzten Beitrag

Gruß Hajo


  

Betrifft: Jetzt klappt's auch! Besten Dank für die Geduld! von: Bernd
Geschrieben am: 11.01.2010 23:17:22

Hallo Hajo,

jetzt hat's geklappt. Deinen letzten Beitrag hatte ich nicht mehr gelesen, als dich die Datei nochmal hochgeladen hatte. Ich habe das Gefühl, dass die Aktualisierungfunktion des Forums nicht immer "zeitnah" funktioniert. Aber sei's drum, Deine Lösung funktioniert auch perfekt, jetzt habe ich die Qual der Wahl!

Gruß
Bernd


  

Betrifft: NotNet ist gut - ich brech zusammen ;-) von: NoNet
Geschrieben am: 11.01.2010 17:59:34

Hallo Bernd,

wenn Du aus meinem Nicknamen das erste "t" streichts (es tut nicht Not, dass Du hier zwei "t"s verwendest ;-), dann verrate ich Dir die Lösung :

{=WENN(A2=A1;"";MAX(WENN(A$2:A$9999=A2;B$2:B$9999)))}

Gruß, NotNet


  

Betrifft: Nun klappt es!!!! Super! von: Bernd
Geschrieben am: 11.01.2010 23:08:27

Hallo NotNet,

vielen Dank, jetzt ist es perfekt! Und an das "t" habe ich auch gedacht!

Gruß
Bernd


Beiträge aus den Excel-Beispielen zum Thema "Höchstes Eingabedatum aus Blocj"