autoeingabe

Informationen und Beispiele zu den hier genannten Dialog-Elementen:


Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: autoeingabe
von: Harry
Geschrieben am: 09.07.2002 - 22:31:54

Hallo

Habe gestern eine Lösung zu meinem Problem bekommen.
Nun habe ich aber ein Neues !?!

Der Wert z soll in einen Kalender unterhalb der Tage zwischen
Start und Ende

Bei dieser Lösung müssen alle Tage in einer Reihe stehen um sie zu finden.
In meinem Kalender ist aber
Januar ab Zelle F6 bis Zelle aj6
Februar ab Zelle F12 bis Zelle aj 12
usw.

Sub Autoeingabe()
Dim start As Date, ende As Date, z As String
Dim c As Integer, d As Integer
start = InputBox("Bitte Startdatum eingeben")
ende = InputBox("Bitte das Enddatum")
z = InputBox("welches Kürzel soll eingetragen werden?")
'Anfangsspalte finden
c = 1
d=6
Do Until Cells(d, c) = start
c = c + 1
Loop
'bis Enddatum eintragen
Do Until Cells(d, c) = ende + 1
If Weekday(Cells(d, c)) > 1 And Weekday(Cells(d, c)) < 7 Then 'Wochenende?
Cells(d + 3, c) = z
End If
c = c + 1
Loop
End Sub

Meine Frage : Wie kann ich das bestehende ändern ohne dass ich
d angeben muß !


mfg

Harry

nach oben   nach unten

Re: autoeingabe
von: PeterW
Geschrieben am: 09.07.2002 - 23:02:00

Hallo Harry,

warum hast Du Deinen Tabellenaufbau nicht beim ersten Posting erwähnt?
Das Problem ergibt sich durch den Monatswechsel, der zur Folge hat, dass der Zeilenzähler um 6 hochgesetzt werden muss. Dummerweise sind die Monate aber nicht gleich lang. Für den Januar macht Spalte F bis AJ noch Sinn, aber was steht im Februar in den Spalten AH bis AJ (von Schaltjahren mal abgesehen)?

Gruß
Peter
PS: warum fängst Du einen neuen Thread an? Und vielen Dank für die Rückmeldung, dass Dein Problem zumindest teilweise gelöst wurde.

nach oben   nach unten

Re: autoeingabe
von: Harry
Geschrieben am: 09.07.2002 - 23:33:37

Hallo Peter

Das mit der "Nicht"-Rückmeldung tut mir leid.

Der neuen Thread dachte ich wegen einem anderen Problem.

Würde mich trotzdem freuen wenn du mir weiterhelfen könntest.

mfg

Harry


nach oben   nach unten

Re: autoeingabe
von: PeterW
Geschrieben am: 10.07.2002 - 00:17:29

Hallo Harry,

sind die Spalten AH bis AJ der Monate, die weniger als 31 Tage haben jetzt leer oder nicht; steht da vielleicht eine Formel drin, die berechnet, ob der Monat noch weitere Tage hat?
Ohne Infos keine Lösungsansätze.

Gruß
Peter


nach oben   nach unten

Re: autoeingabe
von: Harry
Geschrieben am: 10.07.2002 - 07:03:23

Hallo Peter

Nur am 29. Februar steht eine Formel
=WENN(REST(G1;4)>0;"";AG13+1)

Bei den anderen Monaten ist die Zelle leer und die Tage
sind fixiert.

mfg
Harry


nach oben   nach unten

Re: autoeingabe
von: PeterW
Geschrieben am: 10.07.2002 - 14:59:47

Hallo Harry,

teste mal


Option Explicit

Sub Autoeingabe()
Dim start As Date, ende As Date, z As String
Dim As Integer, d As Integer

start = InputBox("Bitte Startdatum eingeben")
ende = InputBox("Bitte das Enddatum")
z = InputBox("welches Kürzel soll eingetragen werden?")

c = 6
d = 6 * Month(start)

'Anfangsspalte finden
Do Until Cells(d, c) = start
    c = c + 1
Loop

'bis Enddatum eintragen
Do Until Cells(d, c) = ende + 1
    If WeekDay(Cells(d, c)) > 1 And WeekDay(Cells(d, c)) < 7 Then 'Wochenende?
        Cells(d + 3, c) = z
    End If
    c = c + 1
    
    If Not IsDate(Cells(d, c)) Then 'Sprung in nächsten Monat
        d = d + 6
        c = 6
    End If
Loop

End Sub

In AH 12 hab ich die Formel:
=WENN(MONAT(AG12)=MONAT(AG12+1);AG12 +1;"")

Gruß
Peter

nach oben   nach unten

Re: autoeingabe
von: Harry
Geschrieben am: 10.07.2002 - 20:52:56

Hallo Peter

Die Lösung passt perfekt auf meinen Kalender.

Danke

Harry


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Inhalte in Spalte löschen"