Formelsuche für Variablen abgleich der Zellen

Bild

Betrifft: Formelsuche für Variablen abgleich der Zellen
von: Tino
Geschrieben am: 29.11.2015 01:21:44

Hallo Zusammen,
Heute ein Neues Thema von mir.
Ich bau in meinem Projekt einen Eigenen Kalender mit ein um die Informationen Zeitlich einzuordnen.
Ich möchte Zelle F3 mit Spalte B abgleichen und den dazugehörigen Wert aus Spalte C in Zelle F5,F6, bis F20 anzeigenlassen. Formel dafür IN Zelle D5 =SVERWEIS($F$3;$B$3:$C$20;2;FALSCH)
Logischer weise wird in Zelle F5 und folgende bei der gleichen Formel das selbige Ergebnis ausgeworfen.
Ich möchte mit einer Formel den nächsten Wert mit dem Selben Datum ausgegeben bekommen, soweit verfügbar sonst sollen die Zellen leer bleiben.
Es ist denke ich nicht schwer aber ich komme leider nicht drauf. Könnt Ihr mir helfen?
Beispieltabelle habe ich hoch geladen. https://www.herber.de/bbs/user/101878.xlsx
Vielen Dank!!!
Gruß Tino

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: SF
Geschrieben am: 29.11.2015 01:31:10
Hola,
als Matrixformel:

=WENNFEHLER(INDEX($C$3:$C$23;KKLEINSTE(WENN($B$3:$B$23=$F$3;ZEILE($3:$23)-2);ZEILE(A1)));"")
Gruß,
steve1da

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Tino
Geschrieben am: 29.11.2015 01:57:17
Hallo Steve1da,
leider funktioniert deine Formel so noch nicht richtig. In der Zelle F6 steht jetzt der Bank Termin vom 02.04.2016 und nicht der Werkstatt Termin vom 26.04.2016. Woran liegt das?
Kannst du mir die Formel erklären, ich mag sie verstehen.
Vielen Dank!
Gruß Tino

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: SF
Geschrieben am: 29.11.2015 01:59:17
Hola,
hast du die Formel mit Strg-Shift-Enter abgschlossen?
Gruß,
steve1da

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Tino
Geschrieben am: 29.11.2015 02:09:02
Hallo Steve1da,
ich kleiner Depp :( habes natürlich vergessen. Ich bin begeistert, habe den ganzen Abend gegrübelt.
Vielen Vielen Dank!
magst du mir erklären wie sie aufgebaut ist?
Gruß Tino

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Over
Geschrieben am: 29.11.2015 09:49:25
Hallo Tino,
ich probiers mal ...
von innen nach aussen

WENN($B$3:$B$23=$F$3;ZEILE($3:$23)-2);ZEILE(A1))

hier wird nacheinander geprüft, ob der Wert in Spalte B (zeile 3...23) dem Wert in F3 entspricht
--> Ja: wird von der Zeilennummer zwei abgezogen (bei der Zelle, wo die Bedingung zutraf)
damit der erste Wert (wenn er zutrifft) die Nr. 1 bekommt
--> Nein: kommt FALSCH rein (Voreinstellung wenn nichts anderes angegeben wird, wie z.B. "")
1. B3=F3 --> falsch
2. B4=F3 --> 2
...
21. B23=F3 --> falsch
--> das Teilergebnis ist ein Feld; die Ergebnisse durch Semikolon getrennt :
{FALSCH;2;FALSCH;FALSCH;5;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH}
KKleinste(); zeile(A1)

da sich beim runterkopieren A1 --> A2 --> A3 sich ändert, wird die daraus ermittelte Zeilennummer
immer um eins größer --> damit ermittelt die Funktion KKleinste aus dem vorher erzeugten Datenfeld
in der 1. Zeile den kleinsten Wert (der Zellen, die im ersten Schritt der Zelle F3 entsprachen)
in der 2. Zeile den zweitkleinsten Wert (der Zellen, die im ersten Schritt der Zelle F3 entsprachen)
in der 3. Zeile den drittkleinsten Wert (der Zellen, die im ersten Schritt der Zelle F3 entsprachen)
...
Zelle für Zelle
für F5, würde mit zeile(A1) der kleinste Wert --> 2 ermittelt
für F6, würde mit zeile(A2) der zweitkleinste Wert --> 5 ermittelt
ab Zelle F7 liefert KKleinste den Fehlerwert #Zahl!
als Nächstes werden mit der Indexformel anhand der mit KKleinsten bestimmten Rangfolge
aus der Wertetabelle die Terminart ermittelt
für F5 "Zahnartzt" da es in der einspaltigen Matrix C3:C23 der zweite Wert von oben ist
für F6 "Werkstatt" da es in der einspaltigen Matrix C3:C23 der fünfte Wert von oben ist
ab F7 käme immer #Zahl!
was mit der abschließende WennFehler-Funktion unterdückt,
in dem beim Auftreten eines Fehlerwertes eine leere Zeichenkette ausgegeben wird.
Die Matrixfomel (Abschluss mit Strg + Shift + Enter), ist im Prinzip ein Paket von Gleichungen das abgearbeitet wird - nur alles in einer Zelle.
hoffe es hilft
Lg Daniel Ov

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Tino
Geschrieben am: 30.11.2015 02:35:53
Hallo Daniel,
vielen Dank! für den Versuch. Soweit verstehe ich das, jetzt habe ich sie in mein Aktieves Projekt eingebunden und siehe da sie funktioniert leider nicht.
Meine Aktuelle Formel sieht so aus:
=WENNFEHLER(INDEX($C$900000:$C$1040000;KKLEINSTE(WENN($B$900000:$B$1040000=$J$4; ZEILE($900000:$1040000)-2);ZEILE(A900000)));"")
was mache ich falsch? :|
Vielen Dank!
Gruß Tino

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Luschi
Geschrieben am: 30.11.2015 04:31:59
Hallo Tino,
daran sieht man, daß Du den Lösungsvorschlag noch nicht verinnerlicht hast und Du Dir unsicher _ bist, was die Formel überhaupt macht. Ersetze den letzten Formelterm 'ZEILE(A900000)' gegen 'ZEILE(A1)'; also so:


=WENNFEHLER(INDEX($C$900000:$C$1040000;KKLEINSTE(WENN($B$900000:$B$1040000=$J$4; ZEILE($900000:$ _
1040000)-2);ZEILE(A1)));"")
und mit    Userbild
abschließen
Gruß von Luschi
aus klein-Paris

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Tino
Geschrieben am: 30.11.2015 06:36:23
Guten Morgen Zusammen,
Ja Luschi, du hast recht ich habe Angst was falsch zu machen. Der Bezug 'Zeile(A1)'hatte ich probiert und 'Zeile(A900000)' war mein zweiter Lösungsversuch. Sie funktioniert leider nicht und ich frage mich ob es vielleicht an dem Makro liegt. Das Makro fügt auf 900001 eine Zeile ein und löscht eine Zeile in 1039999. Kann dies das Problem sein?
Sry, sollte ich auf dem Schlauch stehen!
Vielen Dank!
Gruß Tino

Bild

Betrifft: AW: Formelsuche für Variablen abgleich der Zellen
von: Werner
Geschrieben am: 30.11.2015 10:02:24
Hallo Tino,
hast du eigentlich die Aggregat-Formel von neopa mal probiert? Wahrscheinlich nicht, zumindest kam von dir darauf keine Reaktion.
Zudem solltest du den Beitrag wieder auf offen stellen wenn dein Problem nicht gelöst ist (Haken im Kästchen rechts neben dem Feld zur Passworteingabe).
Gruß Werner

Bild

Betrifft: AW: wieder einafcher mit AGGREGAT() ...
von: ... neopa C
Geschrieben am: 30.11.2015 18:09:07
Hallo Tino,
... hier brauchst Du nur zweimal den Zellbereich anzupassen (und den von Dir offensichtlich geänderten Zellbezug des Datumswert von F$3 auf J$4)
=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE(C$900000:C$1040000)/(B$900000:$B$1040000=J$4);ZEILE(A1))); "")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: wieder einafcher mit AGGREGAT() ...
von: Tino
Geschrieben am: 01.12.2015 04:07:37
Guten Morgen Liebe Helfer,

da ich wie vielleicht gemerkt, aktuell nur nachts Arbeite bitte ich vorab meine Begriffsstutzigkeit zu entschuldigen. Ich habe alle Lösungsansätze ausprobiert und möcht nun bekanntgeben, dass ich aufgebe. Ich habe im Upload die Excel in aufgeräumter Version angehangen und wäre euch zu größtem Dank verpflichtet wenn jemand Lust hat sich das anzuschauen.


File ohne Makro: https://www.herber.de/bbs/user/101919.xlsx
Danke!

Beste Grüße

Tino

Bild

Betrifft: AW: vielleicht hättest Du bei Tag betrachtet ...
von: ... neopa C
Geschrieben am: 01.12.2015 07:59:16
Hallo Tino,
... die von Dir gemachten Fehler selbst gefunden.
Bei Deiner vorhanden Datenstruktur wäre in J5 folgende Formel richtig und ausreichend:
=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE(C$899836:C$900000)/(B$899836:B$900000=J$4);ZEILE(A1)));"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: wieder einafcher mit AGGREGAT() ...
von: Tino
Geschrieben am: 02.12.2015 07:06:49
Guten Morgen Werner,
vielen Dank für deine Unterstüzung, natürlich auch an den Rest, der zur Lösungsfindung beigetragen hat.
Das Eintragen funktioniert nun blendent!
Gruß Tino

Bild

Betrifft: AW: schneller und einfacher mit AGGREGAT() ...
von: neopa C
Geschrieben am: 29.11.2015 10:30:49
Hallo Tino,
... nachfolgende Formel(n) nach unten ziehen. Zuvor in E5 benutzerdefiniertes Zahlenformat: 0".";; zuweisen. Die Formel in F5 ist zwar von der Wirkungsweise her auch eine MATRIXformel, bedarf aber nicht des spez. Eingabeabschlusses. Deswegen nenne ich diese spez. Formelart auch Matrixfunktion(alität)sformel:

 BCDEF
1Datentabelle  Ergebnis für  gewähltes Datum
2DatumWert  
302.01.2016Frisor  26.04.2016
426.04.2016Zahnarzt  
501.03.2016Strom Ableser 1.Zahnarzt
602.04.2016Bank Termin 2.Werkstatt
726.04.2016Werkstatt   
8     
9     

Formeln der Tabelle
ZelleFormel
E5=(F5<>"")*ZEILE(A1)
F5=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE(C$1:C$99)/(B$1:$B$99=F$3); ZEILE(A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Feedback?
von: Werner
Geschrieben am: 29.11.2015 11:45:02
Hallo Tino,
bist du das auch?
https://www.herber.de/forum/messages/1460505.html
Gruß Werner

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formelsuche für Variablen abgleich der Zellen"