rang fängt nicht von "oben" an

Bild

Betrifft: rang fängt nicht von "oben" an
von: prudel
Geschrieben am: 25.09.2003 00:40:27

Hallo,
mein Prob:
Ich habe eine Spalte 1 (Inhalt: 1,2,3...), in einer Spalte 2 mit "RANG(D8;$D$8:$D$32;0)" auswerten.
Es sind 25 Zeilen es kommt normal auch die "25" als Ergebnis. Nur wenn ich z.b. 2 mal die 1 in der Spalte 1 habe, wird als höchster Wert in Spalte 2 die 24 (natürlich 2mal) verbeben und und als nächtster Wert die 23!
Ich möchte aber 2 mal die 25 und als nächster Wert die 23 haben!?
Wie bekomme ich das hin?
Für jede Hilfe dankbar
Gruss
Peter

Bild


Betrifft: =ZÄHLENWENN($A$1:$A$7;"<="&A1)
von: IngoG
Geschrieben am: 25.09.2003 01:23:39

Hallo Peter,
versuchs mal mit der obigen Formel

Gruß Ingo


Bild


Betrifft: AW: =ZÄHLENWENN($A$1:$A$7;"<="&A1)
von: prudel
Geschrieben am: 25.09.2003 02:31:24

Hallo Ingo,
vielen Dank!
passt zwar nicht ganz, hat mir aber weitergeholfen.
Ich hab jetzt deine Formel auf Spalte "I" zwischengelagert und dann:
=WENN(I8>1;RANG(D8;$D$8:$D$32;0)+I8-1;RANG(D8;$D$8:$D$32;0))
zur Auswertung genommen. So funkt das auch!
Aber da müsste es doch noch einen leichteren Weg geben, oder!?
Gruss
Peter


Bild


Betrifft: AW: =ZÄHLENWENN($A$1:$A$7;"<="&A1)
von: FCH
Geschrieben am: 25.09.2003 09:34:12

Hi Peter,

in einem Rutsch müsste das so gehen:

=RANG(D8;$D$8:$D$32)+ZÄHLENWENN($D$8:$D$32;D8)-1

Gruß
FCH


Bild


Betrifft: =ZÄHLENWENN($D$1:$D$25;">"&D1)+1
von: IngoG
Geschrieben am: 25.09.2003 09:46:47

HalloPeter,
Dann eben so (hoffentlich ist es auch das was du meinst);-)
Gruß Ingo


 Bild

Beiträge aus den Excel-Beispielen zum Thema " adressliste mit excel ?"