Das Archiv des Excel-Forums

Ungültige Einträge finden.

Bild

Betrifft: Ungültige Einträge finden.
von: Senior

Geschrieben am: 12.10.2003 16:44:37

Hallo Experten,
aus einer Tabelle B2 Bis F250 mit 3-stelligen ganzen Zahlen zb. 180 , 285 ... sollen ungültige Einträge gefunden werden, zb. 1,25, 24.2, 22), ... Kann man das ohne VBA Kenntnisse lösen?

Noch eine Frage: Gibt es eine Liste über Excel Funktionen mit besseren Erklärungen, als diese in der Hilfe Datei stehen? Zb. „COUNTIF"
mfg. Senior
Bild


Betrifft: AW: Ungültige Einträge finden.
von: Ramses
Geschrieben am: 12.10.2003 17:18:07

Hallo

wenn du nicht löschen willst, geht das auf zwei verschiedene Varianten

Tabelle1
 ABCD
1Zahlen  Zahlen
2123  123
31.23Ungültig 1.23
422Ungültig 22
5145  145
6167  167
723.6Ungültig 23.6
Formeln der Tabelle
B2 : =WENN(ODER(REST(A2;1)<>0;A2<100);"Ungültig";"")
B3 : =WENN(ODER(REST(A3;1)<>0;A3<100);"Ungültig";"")
B4 : =WENN(ODER(REST(A4;1)<>0;A4<100);"Ungültig";"")
B5 : =WENN(ODER(REST(A5;1)<>0;A5<100);"Ungültig";"")
B6 : =WENN(ODER(REST(A6;1)<>0;A6<100);"Ungültig";"")
B7 : =WENN(ODER(REST(A7;1)<>0;A7<100);"Ungültig";"")
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Um die Zellen Rot anzuzeigen, markiere den Datenbereich und füge folgende Formel in: Format - Bedingte Formatierung > Formel ist ein:
=ODER(REST(D2;1)<>0;D2<100)
Die Zellbezüge bitte anpassen.
Gruss Rainer

Bild


Betrifft: AW: Ungültige Einträge finden.
von: Senior
Geschrieben am: 12.10.2003 17:33:24

Das ist sehr kompliziert, ich hab noch mal nachgeschaut, Die Tabelle hat 10 Spalten also von B2: K250 kann aber noch „wachsen". Ich müsste dann eine große menge „WENN" Funktionen eingeben. Geht es nicht einfacher.
Senior


Bild


Betrifft: AW: Ungültige Einträge finden.
von: Ramses
Geschrieben am: 12.10.2003 17:51:40

Hallo

Wenn es einfach wäre, könnte es ja jeder :-)

Markiere die Spalten B:K und trage dort die Formatierung ein, dann geht es automatisch.
Für alles weitere gibt es nur ein Makro

Gruss Rainer


Bild


Betrifft: AW: Ungültige Einträge finden.
von: Senior
Geschrieben am: 12.10.2003 18:44:33

Mit "Bedingte Formatierung" hat es geklappt. Allerdings werden dann auch Leerzellen angezeigt.
mfg
Senior


Bild


Betrifft: AW: Ungültige Einträge finden.
von: Ramses
Geschrieben am: 12.10.2003 19:40:20

Hallo

dann erweitere die Formel

=UND(ODER(REST(D2;1)<>0;D2<100);D2<>"")

Dann werden Leerzeilen nicht berücksichtigt.

Gruss Rainer


 Bild