Microsoft Excel

Herbers Excel/VBA-Archiv

Zeitzuschläge für Arbeitsstunden

Betrifft: Zeitzuschläge für Arbeitsstunden von: Andreas
Geschrieben am: 06.09.2004 14:55:10

hallo Cracks !

jetzt gibts was zum grübeln :

1)was muss ich tun, damit excel automatisch erkennt, das es zwichen 20:00 Uhr und 06:00 Uhr einen Stundenaufschlag von 10% gibt ?

2)was muss ich tun, damit excel automatisch erkennt, das es zwichen an Sonntagen(00.01-23:59)einen Stundenaufschlag von 25% gibt ?

3)was muss ich tun, damit excel automatisch erkennt, das es zwichen an Feiertagen(00.01-23:59)einen Stundenaufschlag von 25% gibt ?

oh gott oh gott... ich hoffe ihr wisst was ich hier sagen will....

danke im Voraus !

gruss andreas

  


Betrifft: AW: Zeitzuschläge für Arbeitsstunden von: Basti
Geschrieben am: 06.09.2004 14:59:35

1 und 2 kann man mit der Systemuhr machen.
Weiss zwar auf die schnelle nicht wie, aber 3 kann excel von alleine nicht.
Besser gesagt Windows kann es nicht. Bei Windows sind keine Feiertage eingespeichert.
Die Tage musst du wenn manuell irgendwie eintragen.

Gruß Basti


  


Betrifft: AW: Zeitzuschläge für Arbeitsstunden von: UweN
Geschrieben am: 06.09.2004 15:10:34

Hi Andreas,

für die Ermittlung der Feiertage kann Dir vermutlich diese Seite weiterhelfen:
http://www.excelformeln.de/formeln.html?welcher=3

Hier findest Du so ziemlich Alles zur Ermittlung von Deutschen Feiertagen.

Viele Grüße
Uwe


  


Betrifft: AW: Zeitzuschläge für Arbeitsstunden von: Gert Seler
Geschrieben am: 06.09.2004 16:03:36

Hallo Andreas,
zu 1.) =WENN(UND(Anfang>6:00;Ende<20:00;StdLohn;StdLohn*1,1)
2.) =WENN(WOCHENTAG((A1;2)>6;StdLohn*1,25) die 2 stellt die EU-Woche ein, 1Tag=MONTAG.
Zu 3.) mußt Du einen Jahreskalender mit allen Feiertagen anlegen und mit einem
Verweis auf die Liste der Feiertage zeigen.
mfg
Gert


 

Beiträge aus den Excel-Beispielen zum Thema "Zeitzuschläge für Arbeitsstunden"