Fehlermeldung "#WERT!" unterdrücken ???

Bild

Betrifft: Fehlermeldung "#WERT!" unterdrücken ??? von: Marco
Geschrieben am: 14.02.2005 11:51:52

Hallo,

ich habe folgendes Problem: ich kopiere Daten in eine Tabelle in einem anderem Blatt. Die Zellen in der Tabelle sind mit Funktionen belegt. Nachdem Kopiervorgang erscheint die Fehlermeldung "#WERT!". Ich muss dann jedesmal die erste Zelle der Spalte anklicken und runterziehen, damit die Zahlen wieder erscheinen. Kann man dies automatisieren oder direkt unterdrücken?

Für Tipps wäre ich sehr dankbar!

Gruß

Marco

Bild


Betrifft: AW: Fehlermeldung "#WERT!" unterdrücken ??? von: heikoS
Geschrieben am: 14.02.2005 12:03:40

Hallo Marco,

Dich interessieren nur die Zahlen? Ohne die Verknüpfungen/Berechnungen vom Originalblatt? Dann den Inhalt der Zwischenablage mit Bearbeiten - Inhalte einfügen - Werte auf das neue Tabellenblatt bringen.


Gruß Heiko


Bild


Betrifft: AW: Fehlermeldung "#WERT!" unterdrücken ??? von: Marco
Geschrieben am: 14.02.2005 12:29:05

Hallo Heiko,

in der Tabelle habe ich Funktionen, die die Werte, also die reinkopierten Zahlen direkt berechnen. Eigentlich 0/8/15, aber durch das kopieren erscheint die Fehlermeldung. Durch deinen Tipp würde ich doch die Funktion aus der Zelle durch die Daten überschreiben und das möchte ich verhindern. Gibt es nicht einen Makro-Befehl den ich hinter das kopieren setzen kann oder per Schaltfläche?

Danke dir!

Gruß

Marco


Bild


Betrifft: Beispielmappe? oT von: heikoS
Geschrieben am: 14.02.2005 12:35:25




Bild


Betrifft: AW: Beispielmappe von: Marco
Geschrieben am: 14.02.2005 12:43:33

Hallo,

habe gerade versucht eine Mappe zu erstellen. Entweder ist diese zu groß oder die Bezüge fehlen, so dass du damit nichts anfangen kannst.

Du musst dir vorstellen, ich habe eine Summenfunktion die die Werte aus drei Zellen addieren soll. Durch das kopieren variiren diese Werte, anstatt die neuen Werte zu summieren erscheint die Fehlermeldund. Ich schätze es kann den Bezug nicht auf anhiebt feststellen.

Gruß

Marco


Bild


Betrifft: Frage von: heikoS
Geschrieben am: 14.02.2005 14:17:02

Hallo Marco,

verstehe ich das richtig: Du hast in einer Spalte (z.B. D) die Summenformel (z.B. in D1: =Summe(a1:c1) und nachdem Du die Zellen a1:c1 gefüllt hast, erscheint der Fehler?


Gruß Heiko


Bild


Betrifft: AW: Frage von: Marco
Geschrieben am: 14.02.2005 14:46:32

Hi,

genau so ist es. Ich kopiere neue Werte in die Zellen und anschließend erscheint die Fehlermeldung. Ich muss manuell den ersten Wert anklicken und über die anderen Werte rüberziehen, damit die Summe erscheint.

Hast du eine Idee voran das liegen kann?

Gruß

Marco


Bild


Betrifft: AW: Frage von: heikoS
Geschrieben am: 14.02.2005 15:36:38

Hallo Marco,

ein Problem, daß ich aus SAP-downloads kenne. Lösungen: Nur Werte einfügen; Zellen auf Standard formatieren; Zellinhalte mit 1 multiplizieren o.ä. Oder in d1 statt =summe(a1:c1) benutzt Du =summenprodukt(a1:c1*1). Wird allerdings bei sehr großen Anwendungen auch langsam, weil es eine Matrixfunktion ist.

Du mußt halt aus den Textzahlen Zahlen machen.


Gruß Heiko


Bild


Betrifft: AW: Frage von: Marco
Geschrieben am: 14.02.2005 16:01:22

Hi,

meine Daten hole ich mir aus SAP-Downloads. Ich werde deine Vorschläge testen und sage dir dann noch Bescheid.

Schonmal vielen Dank!

Gruß

Marco


Bild


Betrifft: AW: Klappt nicht, ... von: Marco
Geschrieben am: 14.02.2005 16:18:26

Hi,

ich habe es mit deinem Formatvorschlag probiert und mit der Summenproduktfunktion, obwohl dazu muss ich sagen ich hatte diese in einer benutzerdefinierten Fubktion eingefügt "=SummeSichtbar(C2:BV2)". Hast du vielleicht noch eine andere Idee? Es nervt gewaltigt die Zellen manuell umzustellen wie gesagt mit Zelle runterziehen.

Danke dir!

Gruß

Marco


Bild


Betrifft: AW: Klappt nicht, ... von: andre
Geschrieben am: 14.02.2005 17:49:46

Hallo Marco,
wenn es mit Anfassen und Runterziehen geht dann zeichene das mal auf und hänge es an Dein Makro zum Kopieren hinten dran ...


Bild


Betrifft: AW: Klappt nicht, ... von: Marco
Geschrieben am: 15.02.2005 06:56:19

Hallo Andre,

ich schätze was anderes bleibt mir wohl nicht übrig.

Danke dir!

Gruß

Marco


Bild


Betrifft: AW: Nachtrag von: Marco
Geschrieben am: 15.02.2005 07:12:09

nochmal ich,

das Problem ist, das der Kopierer sich in einer anderen Mappen befindet. Vielleicht hat noch Jemand einen Tipp für mich. ich versuche es mal mit WorkbookBeforeOpen. Kann man die meine selbstdefinierte Fu´nktion nicht irgendwie ergänzen?

Gruß

Marco


Bild


Betrifft: AW: Nachtrag2 von: Marco
Geschrieben am: 15.02.2005 08:44:11

Hallo,

ich habe es gerade per Makro ausprobiert. Komischerweise funktioniert es nicht. Vielleicht weil die Zelle nicht direkt angeklickt wird?

Gruß

Marco


Bild


Betrifft: AW: Nachtrag2 von: andre
Geschrieben am: 15.02.2005 16:39:40

Hallo Marco,
wenn das Kopierprogramm in einer anderen Mappe ist dann fange am besten von dort an aus aufzuzeichnen. Also erst in die andre Mappe gehen, dann Aufzeichnung starten, usw. Wenn es dann noch nicht geht poste mal den code den Du bekommen hast...
Grüße, Andre


Bild


Betrifft: AW: Nachtrag von: Marco
Geschrieben am: 15.02.2005 19:22:57

Hi,

das Problem ist, dass die Aufzeichnung automatisch beendet wird, wenn ich die Mappe schließe und die Andere öffne.

Gruß

Marco


Bild


Betrifft: AW: Nachtrag von: andre
Geschrieben am: 15.02.2005 19:32:23

... und warum schließt Du sie? Wie soll denn das Makro die Daten einfügen wenn die Mappe wo das Makro steht geschlossen ist? Versteckte Kamera ist das nicht eventuell ??
Grüße, andre


Bild


Betrifft: AW: Nachtrag von: Marco
Geschrieben am: 16.02.2005 07:36:49

Scherzkeks, aber erstmal einen guten Morgen! Was ich benutze ist ein Tabellenkopierer. das Programm kopiert einzelne Tabellenblätter aus Mappen und fügt diese gefiltert in eine Andere ein. Ich schätze dann, dass kann ich vergessen, oder! Vielleicht mit WorkbookBeforeOpen? Als ich das probiert hatte hat der Bildschirm nur geblitzt und passiert ist nichts. Fällt dir noch was anderes ein?

Danke dir!

Gruß

Marco


Bild


Betrifft: AW: Nachtrag von: Wolle
Geschrieben am: 16.02.2005 16:45:35

Hallo Marco,
ich glaube dein Probleme liegt daran, dass Excel in einer Zelle nichts aus sich selber berechnen kann, oder anders ausgedrückt: eine Zelle kann entweder Daten oder Formeln enthalten.

Daraus folgt, das die zu kopierenden Daten nur in einen Bereich kopiert werden dürfen, der ausschließlich Daten enthält. Damit müssten dann die Formeln funktionieren.

Gruß
Wolle


Bild


Betrifft: AW: Aber wie...? von: Marco
Geschrieben am: 16.02.2005 17:02:33

Hallo Wolle,

aber die Daten werden doch nur in Zellen kopiert in denen Zahlen vorhanden. Die Zelle mit der SummenFunktion wird ja nicht angesprochen oder habe ich dich da falsch verstanden? Die Zahlen werden in die Zellen A,B,C kopiert und in D steht dann die Summe.
Hast du nicht eine Idee wie ich das vermeiden kann?

Danke dir!

Gruß

Marco


Bild


Betrifft: AW: Aber wie...? von: Tim
Geschrieben am: 18.02.2005 15:04:00

Kopier die Formel einfach mit.

Tim


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldung "#WERT!" unterdrücken ???"