Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis-Anfrage | Herbers Excel-Forum


Betrifft: sverweis-Anfrage von: Malvira
Geschrieben am: 17.11.2009 11:12:38

Hallo Forum!

Habe auf die Schnelle folgende Anfrage:

Ich möchte per SVERWEIS folgende Aufgabe lösen:



Eintritt_Schwimmbad

Stunden Erw. Jugendl. Senioren
a b c
1 4,50 € 3,50 € 2,00 €
2 8,00 € 6,00 € 4,50 €
3 11,00 € 9,00 € 6,00 €
4 15,00 € 12,50 € 10,00 €
5 15,00 € 12,50 € 10,00 €
6 20,00 € 15,00 € 18,00 €
7 18,00 € 16,00 € 18,00 €
8 22,00 € 20,00 € 20,00 €

ganzer Tag 25,00 € 20,00 € 22,50 €

wer?
a

wie lange?
1

Eintritt:
"x"

D.h. wenn ich zB "a" und "1" eingebe, soll mir der Eintrittspreis für den "Erw." und einer Std. ausgegeben werden.

Ist das ohne große Komplikationen möglich?

VIELEN DANK!

Grüße
P. Malvira

  

Betrifft: AW: sverweis-Anfrage von: Matthias5
Geschrieben am: 17.11.2009 11:20:08

Hallo Malvira,


Tabelle1

 ABCDEFG
1StundenErw.Jugendl.Senioren  Wer?b
2  abc  Wie lange?ganzer Tag
314,53,52  Eintritt:20
42864,5     
531196     
641512,510     
751512,510     
86201518     
97181618     
108222020     
11ganzer Tag252022,5     

verwendete Formeln
Zelle Formel
G3 =INDEX(B3:D11;VERGLEICH(G2;A3:A11;0);VERGLEICH(G1;B2:D2;0))

Tabellendarstellung in Foren Version 4.8

https://www.herber.de/bbs/user/65975.xls

Gruß,
Matthias


  

Betrifft: AW: sverweis-Anfrage von: David
Geschrieben am: 17.11.2009 11:23:21

Hallo Malvira,

zum Beispiel so:

https://www.herber.de/bbs/user/65976.xls

Rückmeldung wäre nett.

Gruß
David


  

Betrifft: Lösung per =INDEX(VERGLEICH();VERGLEICH()) von: NoNet
Geschrieben am: 17.11.2009 11:23:39

Hallo P.Malvira,

das kann man z.B. so lösen (siehe Funktion in A22) :

ABCD
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

Funktionen im Tabellenblatt :
Zelle Formel 
A22   =INDEX(B5:D13;VERGLEICH(A19;A5:A13;0);VERGLEICH(A16;B4:D4;0)

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: es geht schon mit SVERWEIS() und sogar kürzer ... von: neopa
Geschrieben am: 17.11.2009 12:47:54

Hallo,

... und zwar z.b. so:

 ABCDEFG
1StundenErw.Jugendl.Senioren PersonSenioren
214,50 €3,50 €2,00 € Dauer3
328,00 €6,00 €4,50 €   
4311,00 €9,00 €6,00 € Preis6,00 €
5415,00 €12,50 €10,00 €   
6515,00 €12,50 €10,00 €   
7620,00 €15,00 €18,00 €   
8718,00 €16,00 €18,00 €   
9822,00 €20,00 €20,00 €   
10Tag25,00 €20,00 €22,50 €   
11       

Formeln der Tabelle
ZelleFormel
G4=SVERWEIS(G2;A:D;VERGLEICH(G1;A1:D1;))

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
G1Liste =$B$1:$D$1 
G2Liste =$A$2:$A$10 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



@NoNet,

momentan hab ich keinen Zugriff auf Exceltreffen.de. Liegt es evtl. daran, dass jetzt die Fotos eingestellt sind?


Gruß Werner,
... , - ...


  

Betrifft: OT@neopa : Nein, sorry - Ich auch nicht :-( _oT von: NoNet
Geschrieben am: 17.11.2009 12:56:24

_oT