Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis...es muss so einfach sein! | Herbers Excel-Forum


Betrifft: Sverweis...es muss so einfach sein! von: Werner Schulz
Geschrieben am: 22.10.2008 10:02:56

Hallo Ihr alle!

Ich habe ein banales Problem bei dem ich jetzt das ein oder andere Stünchen verbracht habe.

Für einen größerer Neubaumaßnahme habe ich eine Übersichtstabelle erstellt in dem einige Mitarbeiter Mängel notieren können. Die Eingabe habe ich Über Gültigkeit beschränkt um bessere Suchmöglichkeiten zu gewährleisten (Es werden sehr viele Mängel erwartet).

https://www.herber.de/bbs/user/56184.xls

Mit dieser Tabelle kann man einen Überblick über alle Schäden gewinnen.

Gleichzeitig soll über den Hyperlink in J2 eine detailierte Schadensanzeige aufgerufen werden, hier im Beispiel die Tabelle 001. Dort können alle Detailinformationen mit Fotors hinterlegt werden.

https://www.herber.de/bbs/user/56185.xls

Dort sollen nun in der ersten Zeile via Sverweis (oder anders) die Werte der Übersichtstabelle von A2 bis I2 wiedergegeben werden.

In den anderen Zeilen der Schadensanzeige wird ein Bearbeiter den Sachstand festhalten. Von den Schadensanzeigen wie 001 wird es natürlich dem entsprechend viele (Bis 1000) geben.

Meine Frage (in der hoffendlich Verständlichen) Erklärung.

Wie verknüpfe ich die Tabelle 001 (und alle anderen) Tabellen mit der Übersichtstabelle?

Vielen Dank im Voraus!

Grüße

Der Werner

  

Betrifft: AW: Sverweis...es muss so einfach sein! von: fcs
Geschrieben am: 22.10.2008 14:24:25

Hallo Werner,

die Nummer der Schadensanzeige muss in eine Zelle der detailierten Schadensmeldung eingetragen sein, dann kann man per SVERWEIS die Informationen aus der Übersichtsdatei einlesen.

Problem: die Datei "Schadensuebersicht.xls" darf nicht mehr beliebig in Verzeichnissen verschoben werden, wenn die Verknüpfungen erstellt sind.

Beispiel:

Schaden Nr.	Datum	Haus	Etage
001	23.9.08	Verwaltung "neu"	Keller 0.
Formeln (wenn Schadensübersicht.xls geöffnet ist):
B2: =SVERWEIS($A$2;[Schadensuebersicht.xls]Schaden!$A:$M;2;FALSCH)
C2: =SVERWEIS($A$2;[Schadensuebersicht.xls]Schaden!$A:$M;3;FALSCH)
D2: =SVERWEIS($A$2;[Schadensuebersicht.xls]Schaden!$A:$M;4;FALSCH)

Formeln (wenn Schadensübersicht.xls geschlossen ist):
B2: =SVERWEIS($A$2;'C:\Lokale Daten\Test\[Schadensuebersicht.xls]Schaden'!$A:$M;2;FALSCH)
C2: =SVERWEIS($A$2;'C:\Lokale Daten\Test\[Schadensuebersicht.xls]Schaden'!$A:$M;3;FALSCH)
D2: =SVERWEIS($A$2;'C:\Lokale Daten\Test\[Schadensuebersicht.xls]Schaden'!$A:$M;4;FALSCH)


Gruß
Franz


  

Betrifft: AW: Sverweis...es muss so einfach sein! von: David
Geschrieben am: 22.10.2008 14:35:17

Hallo Werner,

folgende Formel als Grundidee:

=INDIREKT("[56184.xls]Schaden!"&ADRESSE(VERGLEICH(TEIL(ZELLE("Dateiname";A1);SUCHEN("["; ZELLE("Dateiname";A1))+1;SUCHEN(".xls";ZELLE("Dateiname";A1))-SUCHEN("[";ZELLE("Dateiname";A1))-1); [56184.xls]Schaden!$A:$A;0);SPALTE()+1))

Dabei sind folgende Änderungen vorzunehmen bzw. Vorraussetzungen zu beachen:
56184.xls musst du ersetzen durch den Namen der Datei mit deinen Schäden
Der Name der Detail-Datei muss identisch sein mit der Bezeichnung in der ersten Spalte deiner Schadensdatei (z. Bsp. 001.xls, 002.xls etc)
In A1 wird jetzt der Wert aus Spalte B der Schadenstabelle geschrieben, da ja dort in Spalte A die Nummer steht, die nicht unbedingt gebraucht wird. Das kannst du mit Spalte()+1 steuern (das +1 ggf. weglassen, bzw. erhöhen)

Rückmeldung wäre nett.

Gruß
David


  

Betrifft: AW: Sverweis...es muss so einfach sein! von: Werner Schulz
Geschrieben am: 22.10.2008 15:02:29

Danke meine Herren,


ich habe die erste Lösung gerade Probiert.....scheint zu funktionieren!

Komme aber leider erst morgen dazu das im Detail umzusetzen!!


Vielen Dank für die Arbeit!!

Der Werner


Beiträge aus den Excel-Beispielen zum Thema "Sverweis...es muss so einfach sein!"