zellinhalte zählen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:


Excel-Version: 97
nach unten

Betrifft: zellinhalte zählen
von: alex
Geschrieben am: 29.04.2002 - 07:43:56

Hallo Forum,

ich möchte in einem bestimmtem bereich z.b.a1:c87 alle unterschiedlichen zellinhalte anzeigen lassen und wenn sie mehrmals vorkommen sollen sie auch noch gezählt werden.

hat jemand eine idee wie man das bewerkstelligen könnte?

nach oben   nach unten

Re: zellinhalte zählen
von: Tobi@s
Geschrieben am: 29.04.2002 - 07:59:38

Hi, wie willst du dir denn die Inhalte anzeigen lassen? Gruß

nach oben   nach unten

Re: zellinhalte zählen
von: Savarol
Geschrieben am: 29.04.2002 - 08:21:10

=WENN(ZÄHLENWENN($A$1:$C$87;A1)>1;ZÄHLENWENN($A$1:$C$87;A1);"") Allerdings musst du diese Formel für jede Zelle machen.

nach oben   nach unten

Re: zellinhalte zählen
von: alex
Geschrieben am: 29.04.2002 - 08:21:41

z.B auf einem zweiten tabellenblat

nach oben   nach unten

Re: zellinhalte zählen
von: alex
Geschrieben am: 29.04.2002 - 08:23:19

ich würde das lieber mit einem makro lösen.

nach oben   nach unten

Re: zellinhalte zählen
von: Tobi@s
Geschrieben am: 29.04.2002 - 11:11:24

Hi, ich hoffe, das dürfte klappen. Er sucht in einem festzulegenden Bereich (Tabelle1) nach den Begriffen und trägt sie in Tabelle2 in Spalte A ein. Dann sortiert er das ganze und fischt alle doppelten Werte aus und zeigt die korrekte Anzahl (= Spalte B) an und löscht die überflüssigen Zeilen. Hier das Programm: Sub Auslesen() Sheets(1).Select 'Aktiviert erstes Blatt Eingabe = InputBox("Bitte gib Anfangs- und Endbereich ein." & vbCr & _ "(Trennzeichen = Doppelpunkt)") ABereich = Left(Eingabe, InStr(2, Eingabe, ":") - 1) 'AnfangBereich EBereich = Right(Eingabe, Len(Eingabe) - Len(ABereich) - 1) 'EndBereich Range(ABereich).Select 'Anfang ASp = ActiveCell.Column 'AnfangSpalte AZe = ActiveCell.Row 'AnfangZeile Range(EBereich).Select 'Ende ESp = ActiveCell.Column 'EndSpalte EZe = ActiveCell.Row 'EndZeile For x = ASp To ESp 'alle Spalten For y = AZe To EZe 'alle Zeilen Sheets(1).Select 'Aktiviert erstes Blatt Wert = Cells(y, x).Value If Wert <> "" Then 'Wert enthalten? Sheets(2).Select 'Ergebnisblatt Range("A65536").Select Selection.End(xlUp).Select If Selection.Value <> "" Then Cells(ActiveCell.Row + 1, ActiveCell.Column).Select 'rutscht an letzte Stelle ActiveCell.Value = Wert 'fügt Wert ein End If Next Next 'sortiert und kürzt Sheets(2).Select Selection.Sort Key1:=Range("A1"), Order1:=xlAscending, Header:=xlGuess, _ OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom Ze = 1 Cells(Ze, 1).Select Do Wert = Cells(Ze, 1).Value 'Wert If Wert = "" Then Exit Do Wert1 = Cells(Ze + 1, 1).Value 'nächster Wert If Wert = Wert1 Then 'gleich? Anz = Cells(Ze, 2).Value 'vorhandene Anzahl? If Anz = "" Then Anz = 1 'Ansonsten setzen Cells(Ze + 1, 1).Select 'gezählte Zeile markieren Selection.EntireRow.Delete 'löschen Cells(Ze, 2).Value = Anz + 1 'Anzahl erhöhen Ze = 0 'Am Anfang beginnen End If Ze = Ze + 1 Loop End Sub Cu

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "zellinhalte zählen"