Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Fehler NV dann ..

Betrifft: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:22:05

Hallo, hätte gerne wenn in der Zelle C4 der Fehler #NV vorkommt, dass die Zeile in der sich die Formel befindet den Wert NO wiedergibt, ansonsten YES

Habe es so probiert (in der Zeile D4 steht folgende Formel)
=WENN(C4=FEHLER.TYP(7);NO;YES)

Kriege aber einen Fehler (NV). Was mache ich falsch?
VG

  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:24:38

=WENN(ISTNV(D14);"no";"Yes")

GrußformelHomepage


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:27:34

Hallo Hajo,

kriege den Fehler #Name?

bei =WENN(ISTNV(C4);NO;YES)

Gruß


  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:28:37

ich habe es für eine Deutsche Version gemacht, es ist ja ein Deutsches Forum.

GrußformelHomepage


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:30:19

Verstehe ich nicht. Habe auch die deutsche Version
Sonst wäre es ja auch IF und ISNA?
Was meinst du denn genau.

VG


  

Betrifft: Frage noch offen .. von: Henschel
Geschrieben am: 04.09.2014 14:30:54

kT


  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:31:58

Gut dann kann ich es nicht nachvollziehen. Die Funktion sollte es auch schon in 2010 geben, kann ich aber erst am Abend prüfen.

Gruß Hajo


  

Betrifft: AW: Wenn Fehler NV dann .. von: Christian
Geschrieben am: 04.09.2014 14:54:38

Hallo,

Du musst die Eingabe auch mit "" tätigen!

Also statt WENN(ISTNV(C4);NO;YES) WENN(ISTNV(C4);"NO";"YES")

MfG Christian


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 15:02:20

Danke, habs nun anders gelöst. Habe gefiltert und YES bzw NO eingefügt. Danke euch allen für die Mühe bzw den Aufwand

VG


  

Betrifft: AW: Wenn Fehler NV dann .. von: yummi
Geschrieben am: 04.09.2014 14:30:45

Hallo Henschel,

=WENN(WENNFEHLER(C4;"NO")=FALSCH; "YES";WENNFEHLER(C4;"NO"))

Gruß
yummi


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:36:01

Hallo yummi,
wenn ich deine Version eingebe dann steht bei NV = NV und bei den Zellen wo kein NV vorkommt FALSCH

=WENN(WENNFEHLER(C4;"NO")=FALSCH; "YES";WENNFEHLER(C4;"NO"))
so stehts bei mir in D4

Klappt noch nicht ganz


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:37:13

Kleine Ergänzung: Der fehler der mir angezeigt wird lautet #NAME? nicht NV


  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:37:38

das ist aber nur allgemein Fehler, Du wolltest aber #NV abfragen oder habe ich das falsch verstanden?

Gruß Hajo


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:40:30

Ich wollte nur NV, da nur der Fehler NV vorkommt in der Spalte. Das hast du richtig verstanden. Wenn es mit Allgemein klappt, wäre das aber auch in Ordnung.

VG


  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:41:43


Tabelle1

 DE
14#NVno
15 No
16 Yes

verwendete Formeln
Zelle Formel Bereich N/A
D14=SVERWEIS(C3;D1:F6;M20)  
E14=WENN(ISTNV(D14);"no";"Yes")  
E15:E16=WENN(ISTFEHLER(D14);"No";"Yes")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Wenn Fehler NV dann .. von: Henschel
Geschrieben am: 04.09.2014 14:46:27

Ganz komisch. Bei dir kommt die selbe Lösung raus:
Wenn in C4 #NV steht, steht in D4 NAME? statt NO und wenn da ein Wert ist, steht Falsch statt Yes


  

Betrifft: AW: Wenn Fehler NV dann .. von: Hajo_Zi
Geschrieben am: 04.09.2014 14:47:57

vielleicht hat Deine Datei eine Macke, versuche es in einer neuen.

Gruß Hajo


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Fehler NV dann .."