Formel für Zahlenüberwachung

Bild

Betrifft: Formel für Zahlenüberwachung
von: Christian
Geschrieben am: 02.03.2005 08:41:56
Hallo Forum und Excelhelfer,
Ich hoffe Ihr könnt mir mal wieder weiter helfen.
In Zeile A1 - A30 habe ich die Werte 0100 - 1900.
Diese Werte kommen in der Tabelle immer in verschiedener Reihenfolge vor.
Da ein Wert z.B. ( 0900 ) in Spalte A1-30 nur 3 mal auftauchen darf,
brauche ich eine Formel die das ganze überwacht.
Wenn ein Wert 1,2 oder 3 mal eingetragen ist, soll ein Wert "ok" ausgegeben werden.
Sollte der Wert 4 mal oder mehr in Spalte A1-30 auftauchen soll ein "X" ausgegben werden.

Zeile A 1 | 0900
Zeile A 2 | LEER
Zeile A 3 | 1000
Zeile A 4 | LEER
Zeile A 5 | 0100
Zeile A 6 | LEER
Zeile A 7 | 0400
Zeile A 8 | LEER
Zeile A 9 | 0900
Zeile A 10 | LEER
Zeile A 11 | 1700
Zeile A 12 | LEER
Zeile A 13 | 0100
Zeile A 14 | LEER
Zeile A 15 | 1000
Zeile A 16 | LEER
Zeile A 17 | 0400
Zeile A 18 | LEER
Zeile A 19 | 1700
Zeile A 20 | LEER
Zeile A 21 | 1000
Zeile A 22 | LEER
Zeile A 23 | 0400
Zeile A 24 | LEER
Zeile A 25 | 0100
Zeile A 26 | LEER
Zeile A 27 | 0400
Zeile A 28 | LEER
Zeile A 29 | 0900
Zeile A 30 | LEER
MfG
Christian

Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Holger Levetzow
Geschrieben am: 02.03.2005 08:46:20
Hallo Christian,
wo soll das x ausgegeben werden?
Warum nimmst Du nicht "Daten"/Gültigkeit". Dann kannst Du die Eingabe eines 4. Wertes ganz verhindern.
Holger
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: c0bRa
Geschrieben am: 02.03.2005 08:48:18
hallo
Formel für B1:
=WENN(SUMME(ZÄHLENWENN($A$1:$A1;$A3))>3;ZÄHLENWENN($A$1:$A1;$A3)&"x";"ok)
hab die Formel nur aus einer meiner Tabellen raus udn an deine angepasst... die musst dann noch auf deine sachen evtl anpassen...
hier mal meine original:
=WENN(B2="";"";WENN(SUMME(ZÄHLENWENN($B$2:$B2;$B2))>1;ZÄHLENWENN($B$2:$B2;$B2)&"x";"OK"))
die gibt bei doppelten einen wert wie z.b. 2x oder 3x aus, wonach sich dann eine bedingte formatierung richtet, die die zeile dann rot einfärbt...

Das Forum lebt auch von Rückmeldungen...
c0bRa
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Christian
Geschrieben am: 02.03.2005 12:07:05
@ Holger
"Daten"/Gültigkeit" kann ich nicht nutzen, da sich der Zeilenwert
von A1-A30 bis zu 100 mal wiederholt.
Geht also weiter mit A31-A60 dann A61-A90 u.s.w. für die dann auch
je eine Kontrolle eingefügt werden soll.
Da durch wird der Wert den ich nicht mehr als 3 mal haben möchte
in dem Tabellenblatt bis zu 300 mal vorhanden sein.
"Daten"/Gültigkeit" bezieht sich glaube ich nur auf das ganze Tabellenblatt.
------------------------------------------------------------------
@c0bRa
Ich weis jetzt nicht genau ob es an der Formel liegt, oder ob ich irgendwas übersehe.
Ic habe die Formel mal in B1 eingefügt und die Werte eingegeben wie sie oben aufgeführt
sind.
Die Formel vergleicht jetzt aber nur den Wert der in A1 steht.
Wenn ein anderer Wert 4 mal eingetragen wird bleibt es auf "ok".

MfG
Christian
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Holger Levetzow
Geschrieben am: 02.03.2005 16:04:43
Hallo Christian,
Gültigkeit kannst Du auch für einzelne Bereiche festlegen, also für A1:A30, A31:A60, ...
versuche bei Gültigkeit mal folgende Formel:
=ZÄHLENWENN(INDIREKT("A"&GANZZAHL((ZEILE()-1)/30)*30+1&":A"&(GANZZAHL((ZEILE()-1)/30)+1)*30);A1)
die kannst Du für die ganze Spalte A auf einmal einrichten (!) und liefert Dir das Gewünschte.
Holger
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Holger Levetzow
Geschrieben am: 02.03.2005 18:11:03
natürlich musst Du den Rest ergänzen, z.B.
=ZÄHLENWENN(INDIREKT("A"&GANZZAHL((ZEILE()-1)/30)*30+1&":A"&(GANZZAHL((ZEILE()-1)/30)+1)*30);A1)<=3
Holger
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Christian
Geschrieben am: 02.03.2005 18:11:37
Hallo Holger,
danke erst mal das du mir noch mal weiter geholfen hast.
Leider habe ich mit der Gültigkeitsüprüfung noch nicht gearbeitet und muss erst mal
verstehen wo ich was eintragen muss, damit ich auch in irgend einer Zelle das "x" für
falsch und das "ok" richtig erscheint.
Die Formel habe ich jetzt eingefügt und Benutzerdefiniert eingestellt.
Jetzt muss ich aber erst mal sehen was ich da für Haken setzen muss und wo für die
anderen Reiter sind.
Falls ich es hin bekommen, werde ich mich hier melden.
MfG
Christian
Bild

Betrifft: AW: Formel für Zahlenüberwachung
von: Holger Levetzow
Geschrieben am: 03.03.2005 07:24:08
Guten Morgen, Christian,
unter Daten/Gültigkeit/Einstellungen wählst Du bei "zugelassen" den Eintrag "benutzerdefiniert" und kopierst die Formel unten in das Feld "Formel".
Du erhälst dann kein "ok" oder "x", sondern es wird das Eingeben eines 4. Wertes einfach verhindert.
Brauchst Du ein "x" oder OK, müssen wir eine Formel in eine Extra-Zelle schreiben. Dann schreibe kurz, in welcher Zelle was passieren soll, wenn wo was passiert ist :-)
Holger
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel für Zahlenüberwachung"