Abfrage mit mehreren Kriterien

Bild

Betrifft: Abfrage mit mehreren Kriterien von: Heinz
Geschrieben am: 14.04.2005 12:42:23

Liebe Excellenten,

ich habe ein Tabelle mit 3 Spalten und möchte gerne
bestimmmte Kombinationen zählen.

Spalte1.... Spalte2....Spalte3
1.................1;2;.......1;2;
1.................2;..........1;2;3;
2.................1;..........2;3;
2.................2;..........1;2;
1.................1;2;.......1;
2.................1;2;.......2;

Ich suche also eine Formel die mir folgendes ausgibt
Spalte1 = 2
Spalte2 = 2 (enthalten)
Spalte3 = 1 (enthalten)
In meinem Beispiel wäre das die Zeilen4 und 6
(die Kombination kommt also 2x vor).

Das Problem: In den Spalten2 und 3 sind "Mehrfachnennungen".
Ich bräuchte irgendwie eine "Summe(wenn " oder "Summenprodukt"
Formel die Stellvertreter-Zeichen animmt
z.B. Summenprodukt (Spalte1=2)*(Spalte2="*2") usw.)

Habt Ihr eine Idee?
Ich freue mich auf Eure Rückmeldungen.

Heinz

Bild


Betrifft: AW: Abfrage mit mehreren Kriterien von: Luc
Geschrieben am: 14.04.2005 13:26:01

Hallo Heinz,
die Inhalte der Spalten 2 u.3 kann man also als Text in Listenform aus Zahlen bzw Ziffern betrachten. Wichtig wäre hier zu wissen, ob die aufgelisteten Zahlen (Listenelemente) aus mehrziffrigen Zahlen oder stets nur aus Einzelziffern bestehen oder ob das egal ist, weil z.B. sowohl eine einzelne 2 (...;2;...) als auch eine 2 in einer 12 (...;12;...) relevant ist. In den beiden letzten Fällen könnten nämlich evtl Funktionen wie FINDEN bzw SUCHEN oder adäquate VBA-Lösungen in die Formel integriert wdn, im ersten Fall nicht.
Dein Erklärungsbsp ist übrigens leicht missverständlich. Du suchst hier doch die 2, die in jedem einbezogenen Zelleninhalt auftreten muss?!
Momentan habe ich zu wenig Zeit, mich eingehender mit dem Problem zu befassen. Denke heute abend drüber nach.
Gruß Luc :-?


Bild


Betrifft: AW: Abfrage mit mehreren Kriterien von: Mac4
Geschrieben am: 14.04.2005 13:37:44

Hallo Heinz,

ich hätte diese Lösung anzubieten, wobei ich hier nur auf das Ergebnis 1 komme (in Zeile 6 fehlt doch die 1 in Spalte C)

=SUMMENPRODUKT((A1:A10=2)*(ISTZAHL(FINDEN(2;B1:B10;1)))*(ISTZAHL(FINDEN(1;C1:C10;1))))

Marc


Bild


Betrifft: Yeah - Perfekt Vielen Dank o.T. von: Heinz
Geschrieben am: 14.04.2005 13:42:01




Bild


Betrifft: AW: Abfrage mit mehreren Kriterien von: Heinz
Geschrieben am: 14.04.2005 13:38:53

Hallo Luc,

es handelt sich nur um einzifferige Zahlen.

Zum mißverständlichen Erklärungsbeispiel:
Ich suche die Anzahl der Zeilen, wenn alle 3 Bedingungen gleichzeitg erfüllt sind.
(also quasi eine Wenn-dann mit 3 Bedingungen...

Schöne Grüße.

Heinz


Bild


Betrifft: AW: Abfrage mit mehreren Kriterien von: HermannZ
Geschrieben am: 14.04.2005 15:03:42

Hallo Heinz,

ein Beispiel;

Versuch
 ABCDEFG
78       
7921;123<< Anzahl der Übereinstimmungen
80221;1,2    
8121;22    
82212;1    
8311;1;22    
8421;1;22    
85       
Formeln der Tabelle
D79 : {=SUMME(($A$79:$A$84=2)*(WENN(ISTFEHLER(FINDEN(2;$B$79:$B$84)>0);0;1))*(WENN(ISTFEHLER(FINDEN(2;$C$79:$C$84)>0);0;1)))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Abfrage mit mehreren Kriterien"