Den jeweils nächstgrößeren Wert addieren...

Bild

Betrifft: Den jeweils nächstgrößeren Wert addieren...
von: R.Schmitt
Geschrieben am: 20.04.2005 16:07:47
Einen schönen Nachmittag allerseits,
nachdem ich mich die vergangenen Tage damit
herumgeschlagen habe, Ränge in Abhängigkeit
eines Kunden zu Gruppen oder Bundesländern
zu vergeben (was mir Dank der Hilfe hier aus
dem Forum und Array Formel und Summenprodukt
auch gelungen ist), stehe ich nun wieder vor
einem dieser elenden Formelprobleme :
https://www.herber.de/bbs/user/21427.xls

In der Spalte D möchte ich den Verkauf des
Produktes (A oder B) "aufkumulieren" d.h.
der Kunde mit dem größten Verkauf beginnend
und dann den nächstgrößten Verkauf jeweils
geteilt durch den Gesamtverkauf dieses Pro
duktes (daneben mal ein Beispiel - wie das
gedacht ist)
In Abhängigkeit des kumulierten Verkaufs-
anteils soll dann der Kunde in eine der drei
Kategorien A/B/C eingeordnet werden.
Wie man in den Spalten H bis M sieht ist das
im sortierten Zustand der Liste und "zu Fuß"
ja kein Problem(*hüstel*)
Nur wie bekomme ich diesen Lösungsweg in eine
einzige Formel in der Spalte D ?
Muß dazu wieder Arrayformel und ähnliche
"Schreckgespenster" bemüht werden ??
Für eure Hilfe vielen Dank
R.Schmitt

Bild

Betrifft: AW: Den jeweils nächstgrößeren Wert addieren...
von: Mac4
Geschrieben am: 20.04.2005 16:26:12
Hi,
hier mal was auf Dein Beispiel bezogen:
=SVERWEIS((SUMME($J$2:J2)/SUMMEWENN(I:I;"A";J:J))*100;{0."A";50."B";75."C"};2)
und runterziehen!
Marc
Bild

Betrifft: Klappt nur mit den Bezügen
von: R.Schmitt
Geschrieben am: 20.04.2005 16:45:07
Hallo und danke...
hat auch soweit funktioniert.
Jetzt habe ich die Formel aber auf die Liste
geändert, die ich ja eigentlich bearbeitet
haben wollte - siehe Anhang.
https://www.herber.de/bbs/user/21432.xls
also die unsortierte.
Und da haut´s irgendwie nicht hin.
Könntest Du da noch mal drüberschau´n ?
Vielen Dank
Bild

Betrifft: AW: Klappt nur mit den Bezügen
von: Mac4
Geschrieben am: 20.04.2005 17:01:07
Hi,
da hatte ich es mir doch etwas zu leicht gemacht (das sortieren hatte ich übersehen).
Versuchs mal so:
=SVERWEIS((SUMMENPRODUKT(($C$2:$C$73>C2)*($B$2:$B$73=B2)*C2:C73)/SUMMEWENN(B:B;"A";C:C))*100;{0."A";50."B";75."C"};2)
Marc
Bild

Betrifft: AW: Klappt nur mit den Bezügen
von: R.Schmitt
Geschrieben am: 20.04.2005 17:23:01
Hallo Formel-Experte,
Hut ab - wo lernt man sowas ???
Zwar liefert mir dieser Alptraum
nur #Name als Ergebnis, aber es
ist immer wieder beeindruckend,
was Du aus dem Hut zauberst.
Gibt´s da irgendein Buch ?
Ich bastel´jetzt mal an der Formel
herum und versuche das auch alleine,
würde aber notfalls nochmal auf dich
zurückkommen.
Viele Grüße
R.Schmitt
Bild

Betrifft: AW: Klappt nur mit den Bezügen
von: Mac4
Geschrieben am: 22.04.2005 07:41:39
Hi,
wieso Alptraum??
Excel ist doch so schön - und lernen kann man es sogar fast ausschließlich durch learning by doing (und mit Unterstützung einiger freundlicher Forumsteilnehmer).
Schönes Wochenende
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Den jeweils nächstgrößeren Wert addieren..."