Herbers Excel-Forum - das Archiv

Überprüfung von mehreren Argumenten

Bild

Betrifft: Überprüfung von mehreren Argumenten
von: joachim

Geschrieben am: 13.12.2006 07:04:19
Guten Morgen zusammen…
Ich habe mich in ein Problem verbissen und komme nicht mehr raus…
(siehe File https://www.herber.de/bbs/user/38937.xls) ich möchte in Tabelle2 folgendes Ergebnis/Formel (c3:c7) haben:
Excel soll prüfen ob sich der Name aus Tabelle2 (b3:b7) in Tabelle1 (b3:b7) befindet, wenn dies der Fall ist soll Excel prüfen ob hinter dem Namen Tabelle1 (c3:c7) derselbe Buchstabe steht wie in Tabelle2 (e3) wenn das auch stimmt dann müsste Excel das Ergebnis in € aus Tabelle1 (d4 und d5) in Tabelle2 bei Thomas und Inge eintragen. Wenn nicht dann den Wert 0. ich versuche es schon seit 30 Min. mit SUMMEWENN funzt aber nicht..
Kann mir jemand helfen???
Danke schon mal
Bild

Betrifft: AW: Überprüfung von mehreren Argumenten
von: Regina
Geschrieben am: 13.12.2006 07:42:24
Hallo Joachim ,
versuch es mal so
geschweifte Klammern nicht eingeben, sondern Formel mit ctrl+Shift + Enter abschließen
={SUMME(WENN((Tabelle1!$B$3:$B$7=Tabelle2!B3)*(Tabelle1!$C$3:$C$7=Tabelle2!$E$3);Tabelle1!$D$3:$D$7))}
Gruß regina
Bild

Betrifft: AW: Überprüfung von mehreren Argumenten
von: Joachim
Geschrieben am: 13.12.2006 07:50:41
Hammer cool
vielen Dank Regina
sag mal was bedeutet das mit der geschweiften Klammer?
Bzw. kannst Du mir die Formel kurz erklären?
Danke
Joachim
Bild

Betrifft: AW: Überprüfung von mehreren Argumenten
von: Erich G.

Geschrieben am: 13.12.2006 08:15:53
Hallo Joachim,
es geht auch ohne Matrixformel, mit SUMMENPRODUKT.
Eine sehr schöne Erläuterung zu Matrixfomeln kannst du dir über den Link "Matrix verstehen" ansehen.
 BC
3Michael0,00 €
4Thomas50,00 €
5Inge20,00 €
6Peter0,00 €
7Anton0,00 €

Formeln der Tabelle
ZelleFormel
C4=SUMMENPRODUKT((Tabelle1!$B$3:$B$7=B4)*(Tabelle1!$C$3:$C$7=$E$3)*Tabelle1!$D$3:$D$7)
C5{=SUMME(WENN((Tabelle1!$B$3:$B$7=Tabelle2!B5)*(Tabelle1!$C$3:$C$7=Tabelle2!$E$3);Tabelle1!$D$3:$D$7))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Bild

Betrifft: AW: Überprüfung von mehreren Argumenten
von: regina

Geschrieben am: 13.12.2006 19:17:21
Hallo, Joachim ,
die geschweiften Klammern bedeuten, dass es sich um eine Matrixformel handelt.
Das erkennt Excel nur, wenn Du die Foreml mit ctrl+shift und Enter abschliesst.
Ich habe die mal unter www.excelformeln.de
gefunden, dort gibt es auch noch mehr interessante Formeln auch eine gute Internetseite.
Aber natürlich kein Vergleich mit dieser " :-)"
Gruß Regina
 Bild
Excel-Beispiele zum Thema "Überprüfung von mehreren Argumenten"
Druck aus mehreren Tabellenblättern auf eine Druckseite Daten von mehreren Blättern auf ein Druckblatt
Werte in mehreren Spalten sortieren Den selben Bereichsnamen in mehreren Tabellenblättern
Tabelle nach mehreren Kriterien summieren Auswahl von Zellen in mehreren Zeilen verhinden
Wert von einer Zelle zur anderen in mehreren Tabellen übernehmen Benannte Bereich aus mehreren Arbeitsmappen importieren
Filtern über VBA nach mehreren Kriterien Kosten nach mehreren Kriterien erfassen