Microsoft Excel

Herbers Excel/VBA-Archiv

Drei Bedingungen abfragen | Herbers Excel-Forum


Betrifft: Drei Bedingungen abfragen von: Henry
Geschrieben am: 10.12.2009 13:26:48

Hallo Excel-Fachleute
Für einen Eintrag in Zelle D2, müssen in den Zellen A2, B2 und C2 bestimmte Bedingungen erfüllt sein – z.B: A2=“Firmenname“, B2=“ja“, C2=““ (leer) DANN sollte die Zahl 3 in D2 einfügefügt werden, sonst nichts.
Mittels WENN(UND… schaffte ich es nicht.
Wer kann mir die Formel dazu verraten?
Vielen Dank
Gruss Henry

  

Betrifft: AW: Drei Bedingungen abfragen von: ransi
Geschrieben am: 10.12.2009 13:31:35

HAllo

Bei "Excel gut" ist doch nicht sooo schwer:
Mach mal so:
Tabelle1

 ABCD
1    
2FirmennameJa 3

Formeln der Tabelle
ZelleFormel
D2=WENN(UND(A2="Firmenname"; B2="ja";C2=""); 3;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: Drei Bedingungen abfragen von: Henry
Geschrieben am: 10.12.2009 13:43:20

Ja, dear ransi
Du hast natürlich recht, ich hätte bei Excel "miserabel" notieren sollen, denn ich habe viiiiel zu weit gesucht.
Kompliment und herzlichen Dank für die schnelle Hilfe
Gruss Henry


  

Betrifft: AW: Drei Bedingungen abfragen von: Björn B.
Geschrieben am: 10.12.2009 13:33:51

Hallo,

der Ansatz war schon richtig.
Du musst einfach eins nach dem anderen prüfen.
Also als "DANN" immer die nächste Prüfung bzw. am Ende den gewünschten Wert und als SONST immer nichts, also "".

=WENN(A2="Firmenname";WENN(B2="ja";WENN(C2="";3;"");"");"")

So funktioniert es.

Gruß
Björn B.


  

Betrifft: AW: Drei Bedingungen abfragen von: Henry
Geschrieben am: 10.12.2009 14:34:58

Hallo Björn
Vielen Dank für die Hilfe. So hat's dann auch funktioniert. Ich habe viel zu weit gesucht!
Grüsse Henry


Beiträge aus den Excel-Beispielen zum Thema "Drei Bedingungen abfragen"