Microsoft Excel

Herbers Excel/VBA-Archiv

Schnitt in Abhängigkeit von zwei Kriterien | Herbers Excel-Forum


Betrifft: Schnitt in Abhängigkeit von zwei Kriterien von: Christian
Geschrieben am: 13.02.2012 16:01:58

Guten Tag,

bitte entschuldigt erstmal diese nichtssagenden Titel, ich kann mein Problem aber nicht in drei Wörtern zusammenfassen. Mit der SuFu habe ich zwar viele Fragen nach "Summewenn mit zwei Kriterien" gefunden, aber mein Problem konnte ich trozdem nicht lösen.

Hier eine Beispieltabelle:

Tabelle2

 ABCDEF
1Auftrag Nr.12345
2MonatJanuarMärzFebruarJanuarJanuar
3PersonJakobLudwigSarahJakobSarah
4Sauberkeit41543
5Pünktlichkeit52112
6Freundlichkeit23332
7Schnitt3,7232,72,3

Formeln der Tabelle
ZelleFormel
B7=RUNDEN(SUMME(B4:B6)/ANZAHL(B4:B6); 1)
C7=RUNDEN(SUMME(C4:C6)/ANZAHL(C4:C6); 1)
D7=RUNDEN(SUMME(D4:D6)/ANZAHL(D4:D6); 1)
E7=RUNDEN(SUMME(E4:E6)/ANZAHL(E4:E6); 1)
F7=RUNDEN(SUMME(F4:F6)/ANZAHL(F4:F6); 1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

In Zeile 7 wird einfach nur der Schnitt aus den drei darüber stehenden Werten gebildet (=Schnitt aus den bewerteten Kriterien eines definierten Auftrages)

Die Tabelle wird im Endausbau nach hinten spaltenweise Zug um Zug erweitert

Ich möchte nun eine Auswertung erstellen, in der für jede Person der Schnitt aus den durchschnittlichen Auftragsbewertungen pro Monat berechnet wird.

In etwa so:

Tabelle2

 ABCDE
12Auswertung    
13     
14PersonJakobSarahLudwigAnton
15Schnitt Januar    
16Schnitt Februar    
17Schnitt März    


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

In Zelle B15 sollte nun der Wert 3,2 (=(3,7+2,7)/2) stehen.

Gibt's dafür eine Formellösung oder muss ich in VBA gehen?

Danke für Eure Hilfe!

Christian

  

Betrifft: Tabelle transponieren und dann PIVOT-Tabelle von: NoNet
Geschrieben am: 13.02.2012 16:23:44

Hallo Christian,

wenn Du die Tabelle "drehst" (transponierst) - also Zeilen und Spalten vertauschst, dann lässt sich daraus eine tolle PIVOT-Tabelle erstellen :

ABCDEFG
1
2
3
4
5
6

Funktionen im Tabellenblatt :
Zelle Formel 
G2   =RUNDEN(MITTELWERT(D2:F2);1) 
G3   =RUNDEN(MITTELWERT(D3:F3);1) 
G4   =RUNDEN(MITTELWERT(D4:F4);1) 
G5   =RUNDEN(MITTELWERT(D5:F5);1) 
G6   =RUNDEN(MITTELWERT(D6:F6);1) 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Hier die PIVOT-Tabelle :
ABCDE
1
2
3
4
5
6
7
8

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: AW: Tabelle transponieren und dann PIVOT-Tabelle von: Christian
Geschrieben am: 13.02.2012 16:44:28

Hallo NoNet,

werde ich versuchen. Danke für den Hinweis!

Schöne Grüße

Christian


Beiträge aus den Excel-Beispielen zum Thema "Schnitt in Abhängigkeit von zwei Kriterien"