Microsoft Excel

Herbers Excel/VBA-Archiv

Suchergebnisse aus Formel ausgeben

Betrifft: Suchergebnisse aus Formel ausgeben von: Sebastian
Geschrieben am: 30.08.2020 16:29:50

Hallo zusammen,

ich möchte eine Liste von Usernames automatisch einer Liste von Nutzern zuordnen. In Spalte A stehen die "echten" Namen. Die ersten 3 Buchstaben (Spalte B) sollen nun als Suchindex über die gesamte Matrix (E1-E3) verwendet werden und den Wert in Spalte C ausgeben.



Leider habe ich keine Formel finden können, die diese Arbeit übernehmen kann. Hat hier jmd eine Idee wie ich das Problem gelöst bekomme?

Vielen Dank im Voraus!
Sebastian

Betrifft: AW: mit INDEX() und VERGLEICH() ...
von: neopa C
Geschrieben am: 30.08.2020 16:40:45

Hallo Sebastian,

... so: =WENNFEHLER(INDEX(C:C;VERGLEICH("*"&B1&"*";E:E;0));"")

Gruß Werner
.. , - ...

Betrifft: AW: mit INDEX() und VERGLEICH() ...
von: Sebastian
Geschrieben am: 30.08.2020 16:49:17

Hallo Werner,

danke für die schnelle Antwort! Als ausgewiesener Wert erscheint bei der Formel nur "0", nicht aber der Wert aus der Suchmatrix. Wie schaffe es den Wert gleich mit auszugeben?

VG
Sebastian

Betrifft: AW: dann liegen Deine Daten anders vor ...
von: neopa C
Geschrieben am: 30.08.2020 16:54:43

Hallo Sebastian,

... lade doch einfach mal eine XLSX-Datei anstelle eines Bild hier hoch, in der Du die Formel eingesetzt hast. Dann kann ich Dir auch sagen, wo ich Deine Angaben anders interpretiert habe als Du sie hast.

Gruß Werner
.. , - ...

Betrifft: AW: dann liegen Deine Daten anders vor ...
von: Sebastian
Geschrieben am: 30.08.2020 16:59:43

Klar! Anbei die Datei:
https://www.herber.de/bbs/user/139925.xlsx

Betrifft: AW: wenn Du es in C ermitteln willst, dann ...
von: neopa C
Geschrieben am: 30.08.2020 17:04:59

Hallo Sebastian,

... natürlich so: =WENNFEHLER(INDEX(E:E;VERGLEICH("*"&B2&"*";E:E;0));"") und nach unten kopieren, ansonsten gibt es ja Zirkelbezüge.

Gruß Werner
.. , - ...

Betrifft: AW: wenn Du es in C ermitteln willst, dann ...
von: Sebastian
Geschrieben am: 30.08.2020 17:17:28

Super, funktioniert einwandfrei!

Danke!

Betrifft: AW: gerne owT
von: neopa C
Geschrieben am: 30.08.2020 17:23:01

Gruß Werner
.. , - ...

Betrifft: AW: wenn Du es in C ermitteln willst, dann ...
von: Luschi
Geschrieben am: 30.08.2020 18:20:08

Hallo Sebastian,

wenn Du aus Neopa's Erstvorschlag:
=WENNFEHLER(INDEX(C:C;VERGLEICH("*"&B1&"*";E:E;0));"")
seinen 2. Vorschlag:
=WENNFEHLER(INDEX(E:E;VERGLEICH("*"&B2&"*";E:E;0));"")
nicht selbst ableiten kannst, so zeigt es doch, daß Du von dieser Lösung NIX verstanden hast - schade...

Gruß von Luschi
aus klein-Paris

Beiträge aus dem Excel-Forum zum Thema "Suchergebnisse aus Formel ausgeben"