Microsoft Excel

Herbers Excel/VBA-Archiv

Top 5 Werte mit KGrößte und Bedingung | Herbers Excel-Forum


Betrifft: Top 5 Werte mit KGrößte und Bedingung von: chrissey
Geschrieben am: 26.01.2010 13:24:33

Hallo Leut,

kriegs leider nicht hin und bin auf Hilfe angewiesen.

Habe in der Spalte A Kosten. In der Spalte B steht das Jahr in dem die Kosten angefallen sind ( 2006 - 2010 ).

Jetz möchte ich gerne in Zelle C1 - C5 eine Formel oder fünf ;-) Die mir in C1 den größten Wert
in C2 den zweitgrößten Wert, usw bis 5 eben suchen, aber unter der Nebenbedingung dass
in der Spalte B 2009 steht.

Hoffe das ist verständlich erklärt und jmd kann mir helfen

Danke Euch schon mal und liebe Grüße

Chrissey

  

Betrifft: AW: Top 5 Werte mit KGrößte und Bedingung von: jockel
Geschrieben am: 26.01.2010 13:38:59

hi Chrissey, meinst du so? einmal mit starr 2009 in der formel und einmal flexibel mit auswahl des jahres in E1..:

Tabelle2

 ABCDE
1KostenJahr6777502008
21002006666667 
31112006533333 
41222006421222 
51332006410211 
61442006   
71552006   
81662006   
91772007   
101882007   
111992007   
122102007   
132212007   
142322007   
152432007   
166672008   
172002008   
182112008   
192222008   
207502008   
211002008   
223332008   
233992009   
244102009   
254212009   
266662009   
276772009   
28502009   
295332009   
303002009   

Formeln der Tabelle
ZelleFormel
C1{=KGRÖSSTE(WENN($B$2:$B$30=2009;$A$2:$A$30;); ZEILE(A1))}
D1{=KGRÖSSTE(WENN($B$2:$B$30=$E$1;$A$2:$A$30;); ZEILE(A1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =VERGLEICH(A2;$D$1:$D$5;0)Abc
B21. / Zellwert ist gleich =$E$1Abc
A31. / Formel ist =VERGLEICH(A3;$D$1:$D$5;0)Abc
B31. / Zellwert ist gleich =$E$1Abc
A41. / Formel ist =VERGLEICH(A4;$D$1:$D$5;0)Abc
B41. / Zellwert ist gleich =$E$1Abc
A51. / Formel ist =VERGLEICH(A5;$D$1:$D$5;0)Abc
B51. / Zellwert ist gleich =$E$1Abc
A61. / Formel ist =VERGLEICH(A6;$D$1:$D$5;0)Abc
B61. / Zellwert ist gleich =$E$1Abc
A71. / Formel ist =VERGLEICH(A7;$D$1:$D$5;0)Abc
B71. / Zellwert ist gleich =$E$1Abc
A81. / Formel ist =VERGLEICH(A8;$D$1:$D$5;0)Abc
B81. / Zellwert ist gleich =$E$1Abc
A91. / Formel ist =VERGLEICH(A9;$D$1:$D$5;0)Abc
B91. / Zellwert ist gleich =$E$1Abc
A101. / Formel ist =VERGLEICH(A10;$D$1:$D$5;0)Abc
B101. / Zellwert ist gleich =$E$1Abc
A111. / Formel ist =VERGLEICH(A11;$D$1:$D$5;0)Abc
B111. / Zellwert ist gleich =$E$1Abc
A121. / Formel ist =VERGLEICH(A12;$D$1:$D$5;0)Abc
B121. / Zellwert ist gleich =$E$1Abc
A131. / Formel ist =VERGLEICH(A13;$D$1:$D$5;0)Abc
B131. / Zellwert ist gleich =$E$1Abc
A141. / Formel ist =VERGLEICH(A14;$D$1:$D$5;0)Abc
B141. / Zellwert ist gleich =$E$1Abc
A151. / Formel ist =VERGLEICH(A15;$D$1:$D$5;0)Abc
B151. / Zellwert ist gleich =$E$1Abc
A161. / Formel ist =VERGLEICH(A16;$D$1:$D$5;0)Abc
B161. / Zellwert ist gleich =$E$1Abc
A171. / Formel ist =VERGLEICH(A17;$D$1:$D$5;0)Abc
B171. / Zellwert ist gleich =$E$1Abc
A181. / Formel ist =VERGLEICH(A18;$D$1:$D$5;0)Abc
B181. / Zellwert ist gleich =$E$1Abc
A191. / Formel ist =VERGLEICH(A19;$D$1:$D$5;0)Abc
B191. / Zellwert ist gleich =$E$1Abc
A201. / Formel ist =VERGLEICH(A20;$D$1:$D$5;0)Abc
B201. / Zellwert ist gleich =$E$1Abc
A211. / Formel ist =VERGLEICH(A21;$D$1:$D$5;0)Abc
B211. / Zellwert ist gleich =$E$1Abc
A221. / Formel ist =VERGLEICH(A22;$D$1:$D$5;0)Abc
B221. / Zellwert ist gleich =$E$1Abc
A231. / Formel ist =VERGLEICH(A23;$D$1:$D$5;0)Abc
B231. / Zellwert ist gleich =$E$1Abc
A241. / Formel ist =VERGLEICH(A24;$D$1:$D$5;0)Abc
B241. / Zellwert ist gleich =$E$1Abc
A251. / Formel ist =VERGLEICH(A25;$D$1:$D$5;0)Abc
B251. / Zellwert ist gleich =$E$1Abc
A261. / Formel ist =VERGLEICH(A26;$D$1:$D$5;0)Abc
B261. / Zellwert ist gleich =$E$1Abc
A271. / Formel ist =VERGLEICH(A27;$D$1:$D$5;0)Abc
B271. / Zellwert ist gleich =$E$1Abc
A281. / Formel ist =VERGLEICH(A28;$D$1:$D$5;0)Abc
B281. / Zellwert ist gleich =$E$1Abc
A291. / Formel ist =VERGLEICH(A29;$D$1:$D$5;0)Abc
B291. / Zellwert ist gleich =$E$1Abc
A301. / Formel ist =VERGLEICH(A30;$D$1:$D$5;0)Abc
B301. / Zellwert ist gleich =$E$1Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




  

Betrifft: {=KGRÖSSTE((B1:B99=2009)*A1:A99;ZEILE(A1))} von: WF
Geschrieben am: 26.01.2010 13:40:26

und runterkopieren

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

Salut WF


  

Betrifft: hatte die Dollars vergessen von: WF
Geschrieben am: 26.01.2010 13:44:58

{=KGRÖSSTE((B$1:B$99=2009)*A$1:A$99;ZEILE(A1))}


  

Betrifft: AW: hatte die Dollars vergessen von: chrissey
Geschrieben am: 26.01.2010 14:03:15

Danke funktioniert super!!! Ihr seid die Besten,...



Grüße


Beiträge aus den Excel-Beispielen zum Thema "Top 5 Werte mit KGrößte und Bedingung"