Microsoft Excel

Herbers Excel/VBA-Archiv

Sortieren mit Zahl+Buchstabe

    Betrifft: Sortieren mit Zahl+Buchstabe von: Holger R.
    Geschrieben am: 29.09.2003 08:45:20

    Guten Tag,

    es gibt da eine knifflige Sache, über die ich schon länger grüble. Und zwar habe ich eine Auftragsverwaltung als Excel-Datei. Jeder Auftrag bekommt eine fortlaufende Nummer, zum Beispiel 1500, 1501, 1502 usw. Nun kommt es aber vor, dass eine Sache, die schon mal bearbeitet wurde, erneut auf den Tisch kommt. Da möchte mein Chef, dass ich dann die "Nummer" 1500A vergebe, damit die Akte später im Regal leichter gefunden wird. Das Problem habe ich nun aber in der Datei: 1500A wird nicht als Zahl erkannt und nicht mitsortiert. Es hängt immer unten dran an meiner Liste. Es treten auch bei diversen Makro-Abfragen Fehler auf. Hat jemand eine Idee, wie man die solche Daten in Excel "richtig" sortieren kann? Also 1500, 1500A, 1501 usw.

    Viele Grüße,
    Holger

      


    Betrifft: AW: Darf es VBA sein? - o.T. von: Matthias G
    Geschrieben am: 29.09.2003 09:00:04

    -


      


    Betrifft: AW: Sortieren ohne VBA von: Matthias G
    Geschrieben am: 29.09.2003 09:08:27

    Hallo Holger,
    also ohne VBA geht's mit einer Hilsspalte.
    Angenommen, die, Auftragsnummern stehen in Spalte A hat die Hilsspalte folgende Formel (hier Zeile 3):

    =WENN(RECHTS(A3;1)="A";WERT(LINKS(A3;LÄNGE(A3)-1))+0,5;A3)

    macht aus 1500A die Zahl 1500,5 und lässt andere Werte so wie sie sind - nach der Hilfsspalte kannst du dann sortieren.
    Etwas komplizierter wäre es, wenn noch "B" oder "C" oder noch mehr angehängt würden.

    Grüße,
    Matthias


      


    Betrifft: AW: Sortieren ohne VBA von: Holger R.
    Geschrieben am: 29.09.2003 09:23:09

    Hmm, wäre eine Überlegung wert, aber ich befürchte, mein Chef will auch "B" und "C"...
    Es sei Dir gedankt!


      


    Betrifft: AW: Sortieren mit VBA? von: Matthias G
    Geschrieben am: 29.09.2003 09:29:11

    Hallo Holger,
    und was ist mit einer VBA-Lösung? Wäre einfacher zu schreiben als dieser Formelwust.

    Matthias


      


    Betrifft: AW: Sortieren mit VBA? von: Holger R.
    Geschrieben am: 29.09.2003 11:03:04

    es darf auch gerne VBA sein :-)


      


    Betrifft: AW: Sortieren mit VBA? von: Matthias G
    Geschrieben am: 29.09.2003 11:19:53

    Hallo Holger,
    folgende Funktion:
    Public
    Function Auftragsnummer(ByVal z As String) As Single
    Dim wert As Single
    z = UCase(Trim(z))
    If IsNumeric(z) Then
        Auftragsnummer = z
        Exit Function
    End If
    wert = Val(z)
    Auftragsnummer = wert + Asc(Right(z, 1)) / 100
    End Function
    


    Geht von A bis Z (Ascii-Wert), macht z.B. aus 23434B der Wert 23434,66016.

    Grüße,
    Matthias


      


    Betrifft: AW: Sortieren mit Zahl+Buchstabe von: Panicman
    Geschrieben am: 29.09.2003 10:30:17

    Hallo Holger,

    hier mal 2 Sortierformeln




    C2 {=LINKS(KKLEINSTE(WERT(LINKS($A$2:$A$9;4)&WENN(LÄNGE($A$2:$A$9)>4;CODE(RECHTS($A$2:$A$9));"00"));ZEILEN($1:1));4)&WENN(RECHTS(KKLEINSTE(WERT(LINKS($A$2:$A$9;4)&WENN(LÄNGE($A$2:$A$9)>4;CODE(RECHTS($A$2:$A$9));"00"));ZEILEN($1:1));2)="00";"";ZEICHEN(RECHTS(KKLEINSTE(WERT(LINKS($A$2:$A$9;4)&WENN(LÄNGE($A$2:$A$9)>4;CODE(RECHTS($A$2:$A$9));"00"));ZEILEN($1:1));2)))}
    E2 {=KKLEINSTE(WERT(LINKS($A$2:$A$9;4)&WENN(LÄNGE($A$2:$A$9)>4;CODE(RECHTS($A$2:$A$9));"00"));ZEILEN($1:1))}
    F2 {=WENN(ISTFEHLER(WERT(LINKS(E2;4)&WENN(RECHTS(E2;2)="00";"";ZEICHEN(RECHTS(E2;2)))));LINKS(E2;4)&WENN(RECHTS(E2;2)="00";"";ZEICHEN(RECHTS(E2;2)));WERT(LINKS(E2;4)&WENN(RECHTS(E2;2)="00";"";ZEICHEN(RECHTS(E2;2)))))}
    und runterkopieren
    Achtung alles Arrayformeln. Geschweifte Klammer nicht mit eingeben, sondern die Zelle anstatt mit Enter, mit STRG-SHIFT-Enter abschließen. Das erzeugt sie

    https://www.herber.de/bbs/user/1201.xls
    Gruß
    Holger


      


    Betrifft: AW: Arrayformeln von: Matthias G
    Geschrieben am: 29.09.2003 10:50:49

    Hallo Panicman,
    sag mal wie geht das mit diesen Arrayformeln?
    Aus der Excelhilfe werd ich irgendwie nicht schlau.
    Kennst du eine Site, in der das gut erklärt ist?

    Viele Grüß,
    Matthias


      


    Betrifft: AW: Arrayformeln von: Panicman
    Geschrieben am: 29.09.2003 10:57:58

    Hallo Matthias,

    durch die Bestätigung mit STRG-SHIFT-ENTER baut XL intern eine Matrix über den angegebenen Bereich auf. Diese Matrix kann man dann Zeilenweise auswerten.
    Mehr kann ich dir auch nicht dazu sagen. Es funzt einfach.
    Das habe ich mit auch nur von Boris (Meister des ARRAYs) abgeschaut.

    Gruß
    Holger


      


    Betrifft: AW: Danke für den Tipp - o.T. von: Matthias G
    Geschrieben am: 29.09.2003 11:05:58

    -


     

    Beiträge aus den Excel-Beispielen zum Thema " Sortieren mit Zahl+Buchstabe"