vba Zelle Kopieren, einfügen, Tabelle anbei...

Bild

Betrifft: vba Zelle Kopieren, einfügen, Tabelle anbei...
von: mcpfennig
Geschrieben am: 14.03.2005 18:39:56
Hier die Tabelle,
https://www.herber.de/bbs/user/19666.xls (mit Test-Makros)
Ein paar Jahre nicht mehr geschrieben und irgendwie komm ich nicht mehr rein...
In das Tabellenblatt "re" schreibe ich in Spalte A den Namen vom Tabellenblatt, welches ausgewählt werden soll, in Spalte B die Zeile des Tabellenblattes, die ausgewählt werden soll, wenn ich dann ENTER drücke,
soll aus dem angegebenen Tabellenblatt aus der angegebenen Zeile das Feld E in Spalte "C" von "re" kopiert werden und das Feld "F" im Tabellenblatt "1" auf
den Wert "1" gesetzt werden.
In der nächsten Zeile soll sich der Prozess wiederholen....
Wenn s jemand weiss, und mir schreibt wie, wäre ich echt happy..
Der Tip mit den " 3-D "-Formeln war zwar nicht schlecht, funktioniert hier aber nicht.

Bild

Betrifft: indirekt() geht der erste teil..
von: ransi
Geschrieben am: 14.03.2005 19:20:54
hallo mc
zumindest den ersten teil kanst du mit Indirekt() lösen.
 
 ABCD
11111Schaukel80
12210Schneefitzer45
Formeln der Tabelle
C11 : =WENN(ISTFEHLER(INDIREKT(A11&"!A"&B11));"";INDIREKT(A11&"!A"&B11))
D11 : =WENN(ISTFEHLER(INDIREKT(A11&"!E"&B11));"";INDIREKT(A11&"!E"&B11))
C12 : =WENN(ISTFEHLER(INDIREKT(A12&"!A"&B12));"";INDIREKT(A12&"!A"&B12))
D12 : =WENN(ISTFEHLER(INDIREKT(A12&"!E"&B12));"";INDIREKT(A12&"!E"&B12))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: AW: indirekt() geht der erste teil..
von: mcpfennig
Geschrieben am: 14.03.2005 19:35:57
Super !! funktioniert und sogar ohne VBA .... Dankeschön.....,
wenn eine Idee da ist, wie die Felder jetzt noch von 0 auf 1 umgemünzt werden können, wäre die Tabelle "perfekt"
Mit freundlichen Grüßen: mcpfennig
Bild

Betrifft: mit summenprodukt() der zweite teil..
von: ransi
Geschrieben am: 14.03.2005 19:51:55
hallo mc
..mal auszugsweise für blatt1:
 
 F
9verkauft
101
111
120
130
Formeln der Tabelle
F10 : =(SUMMENPRODUKT((Re!$C$11:$C$28='1'!A10)*1;(Re!$D$11:$D$28='1'!E10)*1)=SUMMENPRODUKT(('1'!$A$10:$A$100='1'!A10)*1;('1'!$E$10:$E$100=E10)*1))*1
F11 : =(SUMMENPRODUKT((Re!$C$11:$C$28='1'!A11)*1;(Re!$D$11:$D$28='1'!E11)*1)=SUMMENPRODUKT(('1'!$A$10:$A$100='1'!A11)*1;('1'!$E$10:$E$100=E11)*1))*1
F12 : =(SUMMENPRODUKT((Re!$C$11:$C$28='1'!A12)*1;(Re!$D$11:$D$28='1'!E12)*1)=SUMMENPRODUKT(('1'!$A$10:$A$100='1'!A12)*1;('1'!$E$10:$E$100=E12)*1))*1
F13 : =(SUMMENPRODUKT((Re!$C$11:$C$28='1'!A13)*1;(Re!$D$11:$D$28='1'!E13)*1)=SUMMENPRODUKT(('1'!$A$10:$A$100='1'!A13)*1;('1'!$E$10:$E$100=E13)*1))*1
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: AW: mit summenprodukt() der zweite teil..
von: mcpfennig
Geschrieben am: 14.03.2005 20:42:07
Danke für die wirklich gigantische Hilfe.
Der Begriff Summenprodukt war mir bis heute völlig unbekannt.
Wenn ich mit meiner Excel-Unkenntnis aber viel Fleiß etwas tun kann, einfach mailen und ich stehe zur verfügung.
Jetzt muss ich ein wenig experimentieren und mal alle Varianten durchlaufen lassen.
Dankeschön sagt mcpfennig....
Bild

Betrifft: AW: mit summenprodukt() der zweite teil..
von: mcpfennig
Geschrieben am: 14.03.2005 20:51:09
Danke für die wirklich gigantische Hilfe.
Der Begriff Summenprodukt war mir bis heute völlig unbekannt.
Wenn ich mit meiner Excel-Unkenntnis aber viel Fleiß etwas tun kann, einfach mailen und ich stehe zur verfügung.
Jetzt muss ich ein wenig experimentieren und mal alle Varianten durchlaufen lassen.
Dankeschön sagt mcpfennig....
Bild

Betrifft: AW: vba Zelle Kopieren, einfügen, Tabelle anbei..
von: mcpfennig
Geschrieben am: 14.03.2005 19:28:09
https://www.herber.de/bbs/user/19666.xls
Bild

Betrifft: Knigge
von: Ramses
Geschrieben am: 14.03.2005 19:37:08
Hallo
Verzeih mir den diskreten Hinweis, aber auf meiner Seite des Computers, sitzt kein Hund und auch kein Volltrottel.
Was sollen wir mit diesem Beitrag machen ?
Gruss Rainer
Bild

Betrifft: AW: Knigge
von: mcpfennig
Geschrieben am: 14.03.2005 19:47:05
Hallo...
Entschuldige bitte,
hab ich vor lauter Eifer vergessen...
Werde mich bessern....
Danke für die Info...
mcpfennig
 Bild

Beiträge aus den Excel-Beispielen zum Thema "vba Zelle Kopieren, einfügen, Tabelle anbei..."