Microsoft Excel

Herbers Excel/VBA-Archiv

Zeile (Zahl) ermitteln

Betrifft: Zeile (Zahl) ermitteln von: Erich M.
Geschrieben am: 22.05.2005 11:40:55

Hallo EXCEL-Freunde,

ich suche eine Formel mit der ermittelt wird, welcher Wert (Datum) in welcher
Zeile steht (SVERWEIS??):

Forumfrage
 ABCD
1  EingabeFORMEL ??
2Zeitraumvon03.02.046
3 bis06.02.049
4    
502.02.04   
603.02.04   
704.02.04   
805.02.04   
906.02.04   
1007.02.04   
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Besten Dank für eine Hilfe!


mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
EXCEL und Lottogewinne machen glücklich: http://48678.rapidforum.com
  


Betrifft: vergleich() von: ransi
Geschrieben am: 22.05.2005 11:46:50

hallo erich

 
 ABCD
1  EingabeFORMEL ??
2Zeitraumvon03.02.20046
3 bis06.02.20049
4    
502.02.2004   
603.02.2004   
704.02.2004   
805.02.2004   
906.02.2004   
1007.02.2004   
Formeln der Tabelle
D2 : =VERGLEICH(C2;A:A;0)
D3 : =VERGLEICH(C3;A:A;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


  


Betrifft: AW: vergleich() von: Erich M.
Geschrieben am: 22.05.2005 12:02:08

Hallo ransi,

das geht ja fix - DANKE!
Ergänzungsfrage: Mit dieser Lösung ermittle ich einen Bereich, der dann mit Hilfe INDIReKT
für eine Summenermittlung verwendet wird. Jetzt habe ich das Problem, dass ich INDIREKT
in der Tabelle "Tipps" anwende und INDIREKT sich auf "gezZahlen" bezieht; das kriege ich nicht hin:
Tipps
 STUVWX
1von16.05.05406B406:U411BB406
2bis21.05.05411 UU411
Formeln der Tabelle
U1 : =VERGLEICH(T1;gezZahlen!A:A;0)
V1 : =$X1&":"&$X2
X1 : =W1&U1
U2 : =VERGLEICH(T2;gezZahlen!A:A;0)
X2 : =W2&U2
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


In V1 müsste stehen: =gezZahlen!B406:U411
Dieser Inhalt wird für INDIRKET verwendet:
Tipps
 UV
4Zahlgezogen
520
Formeln der Tabelle
U5 : =WENN(ISTFEHLER(INDEX(P:P;VERGLEICH(S5;R:R;0)));0;INDEX(P:P;VERGLEICH(S5;R:R;0)))
V5 : {=WENN(SUMME(ZÄHLENWENN(U5;INDIREKT(V$1)))>0;SUMME(ZÄHLENWENN(U5;INDIREKT(V$1)));0)}
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Besten Dank nochmal!

mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
EXCEL und Lottogewinne machen glücklich: http://48678.rapidforum.com


  


Betrifft: noch offen; o.T. von: Erich M.
Geschrieben am: 22.05.2005 12:21:37



mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
EXCEL und Lottogewinne machen glücklich: http://48678.rapidforum.com


  


Betrifft: AW: noch offen; o.T. von: Matze
Geschrieben am: 22.05.2005 12:57:06

Hallo Erich,

Vorschlag, Du schreibst den Namen des Tabellenblattes in eine Zelle und baust den Bezug in der Formel in V1 gemäß den Bsp. zusammen.

Beispiele für das Zusammensetzten von Bezügen: (diese Beispiele habe ich selber im Einsatz!
INDIREKT("'"&B$2&"'!$A$2:$P$30") in diesem Beispiel in B2 der Name des Tabellenblattes
MAX(INDIREKT("'"&A13&"'!A:A"))

mfg Matze


  


Betrifft: Perfekt Matze!! Vielen Dank!! o.T. von: Erich M.
Geschrieben am: 22.05.2005 13:18:11



mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
EXCEL und Lottogewinne machen glücklich: http://48678.rapidforum.com


  


Betrifft: oder so... von: ingoG
Geschrieben am: 22.05.2005 21:36:30

Hallo zusammen,

man kann mE auch ohne hilfszellen usw die summe zwischen von und bis datum (einschließlich) berechnen...
in tabelle1 stehen in spalte a die daten und in spalte b die zu addierenden werte und
in tabelle2 in a1 das von-datum, in a2 das bis-datum und in b1 die folgende formel:

=SUMME(INDIREKT("tabelle1!b"&VERGLEICH(A1;Tabelle1!A:A;0)&":B"&VERGLEICH(A2;Tabelle1!A:A;0)))

es handelt sich hier nicht um eine matrixformel, sollte also relativ fix arbeiten...

Gruß Ingo

PS eine rückmeldung wäre nett...


  


Betrifft: ......noch ergänzen? von: Erich M.
Geschrieben am: 22.05.2005 22:35:57

Hallo Ingo,

danke; ohne Matrix spare ich mir wahrscheinlich Speicherkapazitäten in der eh dicken Datei.
Aber ich bräuchte noch eine Ergänzung und schaffs nicht.
Bei meiner Summe geht es um ZÄHLENWENN. Wenn Du meine Formel ansiehst, dann ist die Summe
abhängig vom Inhalt U5 - wie kann man das noch einbauen?

Danke nochmal!

Und bei der Gelegenheit; hast Du hier evtl. auch eine Idee damit ich weiterkomme:
https://www.herber.de/forum/index.htm?https://www.herber.de/forum/messages/614412.html

mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
EXCEL und Lottogewinne machen glücklich: http://48678.rapidforum.com


 

Beiträge aus den Excel-Beispielen zum Thema "Zeile (Zahl) ermitteln"