Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Teilzelleninhalt in Zeile auslesen

Teilzelleninhalt in Zeile auslesen
Lemmi
Hallo zusammen,
ich möchte in einer Zeile die Zellen nach eine Zeichenfolge durchsuchen!
-die Formel soll in D8 sein.
- die Werte sollen ab E8: bis IV 8 gesucht werden! (Zeilenweise)
-die Zelleninhalte haben Text oder Zahlenformat
z. B Suchtext -123
Zelleninhalte können z. B. -123456 oder -123987 ... sein.
Ist der gesuchte Inhalt mehrfach vorhanden wird der Suchtext jedoch nur 1 x ausgegeben.
Gruß
Lemmi
AW: Teilzelleninhalt in Zeile auslesen
14.09.2009 17:15:35
{Boris}
Hi,
Arrayformel:
{=INDEX(E8:IV8;VERGLEICH("-123*";E8:IV8&"";))}
Grüße Boris
AW: Teilzelleninhalt in Zeile auslesen
14.09.2009 17:35:33
Lemmi
Hallo Boris,
vielen Dank!
Kannst Du mir noch eine Tipp geben wie ich es vermeide die Ausgabe NV oder ähnliches vermeide?
Leider funktioniert meine wenn Bedingung nicht !
{=WENN(INDEX(D8:IV8;VERGLEICH("-123*";J8:IV8&"";))="";"";INDEX(D8:IV8;VERGLEICH("-123*";J8:IV8&"";))) }
Also die Zelle soll Leer sein wenn dieser Suchtext nicht gefunden worden ist!
Gruß
Lemmi
Siehe NoNet...
14.09.2009 17:36:34
{Boris}
Hi Lemmi,
...ISTZAHL ist die richtige Abfrage.
Grüße Boris
AW: Siehe NoNet...
14.09.2009 17:55:20
Lemmi
wie meinst Du das ?
Gruß
Lemmi
Anzeige
AW: Teilzelleninhalt in Zeile auslesen
14.09.2009 17:48:56
Lemmi
hallo,
habe Formel gerade in Datenbank eingebunden!
bekomme leider immer unterschiedliche Werte heraus!
wenn -123 gesucht wird dann gibt mir die Formel -123456 heraus. Ich benötige nur den Suchwertals Ausgabe!
Kannst Du noch einmal nachschauen?
Gruß
Lemmi
Per Matrix-Funktion
14.09.2009 17:22:10
NoNet
Hallo Lemmi,
gib in D8 folgende Funktion ein und bestätige sie mit Strg+Shift+ENTER :
=WENN(ISTZAHL(VERGLEICH("*-123*";TEXT(E8:IV8;"@");0));INDEX(E8:IV8;0;VERGLEICH("*-123*";TEXT(E8:IV8;"@");0));"Nööö, is nich drin !")
Gruß, NoNet
AW: Per Matrix-Funktion
14.09.2009 18:02:29
Lemmi
Hallo No Net,
..kann Du mir noch helfen!
Wenn der Wert gefunden worden ist gibt die Formel den kompleten Zelleninhalt wieder ich möglich nur den Zahlenwert -123 auszugegeben!
Kannst Du Formel noch anpassen?
Gruß
Lemmi
Anzeige
Nur Suchbegriff ausgeben - Sinn ?
14.09.2009 18:08:11
NoNet
Hallo Lemmi,
das hast Du aber sehr schlecht formuliert, dass Du nur den Suchwert haben möchtest - zumindest haben Boris und ich das SO nicht verstanden !
Worin liegt der Sinn, den Suchwert auszugeben, den Du doch bereits kennst ?
Aber : Nichts ist unmöglich - so funktioniert das :
=WENN(SUMMENPRODUKT(ISTZAHL(FINDEN("-123";E8:IV8))*1);"-123";"nöö, is nich drin")
Wieder mit Strg+Shift+ENTER bestätigen !
Gruß, NoNet
AW: Nur Suchbegriff ausgeben - Sinn ?
14.09.2009 21:20:51
Lemmi
Hallo NoNet,
ich prüfe eine Datenzeile und wenn einen Wert -123 vorkommt ist die Datenzeile die im Pivot- Tabellen ausblenden kann!
Wenn nun ich immer einen anderen Wert als Prüftext ausgegeben bekomme, wird die Auswahl viel zu lang!
Ich habe im moment über 50000 Dateinzeilen die bereinigt werden müssen!
Deshalb benötige ich immer die selben Ausgabewerte !
Gruß
Lemmi
Anzeige
ich versuche auch mal mein Glück.
14.09.2009 18:27:09
Tino
Hallo,
Tabelle1

 CD
6Suchtext456
7 456
8  
9  
10123496-545454456
11123457123464
12123458123465
13123459123466
14123460123467
15123461123468
16123462123469
17123463123470

Formeln der Tabelle
ZelleFormel
D7=WENN(SUMMENPRODUKT(ISTZAHL(FINDEN(D6;C10:D17))*1)>0;D6;"")

Gruß Tino
Anzeige
AW: ich versuche auch mal mein Glück.
14.09.2009 23:18:17
Lemmi
Tino
klapt alles wunderbar !
Vielen Dank!
Gruß
Lemmi

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige