Microsoft Excel

Herbers Excel/VBA-Archiv

Werte vergleichen mit Kriterien | Herbers Excel-Forum


Betrifft: Werte vergleichen mit Kriterien von: Thomas Seidenstücker
Geschrieben am: 18.01.2012 09:16:58

Hallo Forum,

ich möchte eine einen Wert in Spalte D mit Spalte B prüfen (Zelle D1=Spalte B ). Zudem wird ein Kriterium neben der Spalte B, Spalte C ("N" oder "U") zugehörig zu Spalte B angewendet.
"N" steht für einen Wert in Spalte E
"U" steht für einen Wert in Spalte F

Ich habe es mit einer WENN Funktion versucht:
=WENN(($B$3:$B$600=D3)*($C$3:$C$600="N");E3;WENN(($C$3:$C$600="U");F3))

Das klappt auch bis auf die Unterscheidung der Kriterien "N" und "U". Es wird nur "N" (Spalte F) und der zugehörige Wert (Kosten in €) übernommen Spalte G.

Die Matrix-Tastenkombi habe ich berücksichtigt (STRG+UMSCH+RETURN).

Ich danke für Eure zahlreiche Unterstützung.

Thomas.

  

Betrifft: AW: Neues Excel? Zelle D1 jetzt in Spalte B??? von: JoWE
Geschrieben am: 18.01.2012 10:33:52




  

Betrifft: AW: Neues Excel? Zelle D1 jetzt in Spalte B??? von: Thomas Seidenstücker
Geschrieben am: 18.01.2012 10:47:14

Hallo,
Einen Zellenwert D3 soll mit gesamter Spalte B gesucht und auf vorhandensein geprüft. Dann gilt das weitere Kriterium.
D3 (Funktion) soll dann heruntergezogen werden bis Zeile 600.

Kannst du helfen?
Danke.


  

Betrifft: AW: Werte vergleichen mit Kriterien von: Rudi Maintaire
Geschrieben am: 18.01.2012 10:46:21

Hallo,
($B$3:$B$600=D3) fehlt im hinteren WENN()

Gruß
Rudi


  

Betrifft: AW: Werte vergleichen mit Kriterien von: Thomas Seidenstücker
Geschrieben am: 18.01.2012 11:18:04

Hallo,
das habe ich nicht verstanden.
=WENN(($B$3:$B$600=D3)*($C$3:$C$600="N");E3;(WENN(($C$3:$C$600="U");F3))).

So geht es auch nicht.

Gruß.


  

Betrifft: AW: Werte vergleichen mit Kriterien von: Rudi Maintaire
Geschrieben am: 18.01.2012 15:42:44

Hallo,

 BCDEFG
3buh233
4cn    
5du    
6en    
7fn    
8gn    
9hu    
10in    
11ju    

ZelleFormel
G3{=WENN(SUMME((B3:B11=D3)*(C3:C11="n"));E3;WENN(SUMME((B3:B11=D3)*(C3:C11="u"));F3;""))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Gruß
Rudi


Beiträge aus den Excel-Beispielen zum Thema "Werte vergleichen mit Kriterien"