Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Tage eines Monats automatisch ausfüllen

Tage eines Monats automatisch ausfüllen
16.01.2013 19:18:09
Andreas
Hallo Excel Profis,
Ich habe noch 2 Probleme mit einer Excel-Mappe.
Ich möchte bei Eingabe eines Datums in Zelle C8 das die Zeile bis zum Monatsende in Tagesschritten automatisch ausgefüllt wird.
Gleichzeitig soll die jeweilige Spalte bis C30 grau hinterlegt werden, wenn der Tag auf ein Wochenende oder Feiertag fällt. Die Feiertage sind im Blatt "Feiertage" C2 bis C12 notiert.
Ich habe eine Mappe hochgeladen aus der ersichtlich wird, wie es aussehen soll.
https://www.herber.de/bbs/user/83438.xls
Kann mir Jemand helfen, ist zu hoch für mich.
Danke schon mal!
mfg, Andreas

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Tage eines Monats automatisch ausfüllen
16.01.2013 20:28:42
Andreas
Hallo Hajo,
Danke für die schnelle Hilfe. Hab meine Mappe fast fertig. Nur das mit den Feiertagen einfärben habe ich nicht hinbekommen.
Kannst du mir weiterhelfen?
https://www.herber.de/bbs/user/83439.xls
Vielen Dank!
mfg, Andreas

Anzeige
AW: Tage eines Monats automatisch ausfüllen
16.01.2013 20:44:28
Hajo_Zi
Hallo Andreas,
warum übernimmst Du nicht mein Beispiel?
Gruß Hajo

AW: Tage eines Monats automatisch ausfüllen
16.01.2013 21:04:06
Andreas
Hallo Hajo,
Ich habe dein Beispiel, soweit ich es verstanden habe, in meiner Mappe umgesetzt. Die Mappe ist mir so vorgegeben, wollte diese nur etwas automatisieren.
Geht ja auch alles, nur die bedingte Formatierung der Feiertage funktioniert nicht nicht.
Die Mappe die ich hochgeladen habe ist schon die überarbeitete.
mfg, Andreas

SVERWEIS-Parameter oder VERGLEICH
17.01.2013 00:56:48
Erich
Hi Andreas,
schau dir mal die SVERWEIS-Parameter bei der Feiertags-Formatierung an. Woher kommt da die 2?
Statt
=ISTFEHLER(SVERWEIS(C$8;Feiertage;2;0))=FALSCH
stimmt
=ISTFEHLER(SVERWEIS(C$8;Feiertage;1;0))=FALSCH
oder besser
=NICHT(ISTFEHLER(SVERWEIS(C$8;Feiertage;1;0)))
oder noch besser, weil SVERWEIS überhaupt nicht gebraucht wird:
=ISTZAHL(VERGLEICH(C$8;Feiertage;0))
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
AW: Vielen Dank!
17.01.2013 07:45:42
Andreas
Hallo Erich G.
Dein Istzahl-Vergleich funktioniert super.
Vielen Dank, und einen schönen Tag noch.
mfg, Andreas

AW: Vielen Dank!
17.01.2013 07:56:14
hary
Hallo
Einen hab ich auch noch. ;-)
Fuer Feiertage 1. Bedingung: =ZÄHLENWENN(Feiertage;C$8)~f~
Fuer Wochenende 2. Bedingung: ~f~=WOCHENTAG(C$8;2)>5
gruss hary

AW: Vielen Dank!
18.01.2013 07:49:30
Andreas
Hallo Hary,
Funktioniert auch bestens.
Danke!
mfg, Andreas
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige