Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit "Zählenwenn" ..

Betrifft: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 22.08.2014 18:28:44

Hallo,
ein Problem, mit dem ich nicht zurechtkomme:
In der u.g. Liste kann ich für die Spalten mit der Überschrift "Verkauf" bzw. "Ausbilder) keine Summen bilden mit 'zählenwenn', da dort eben mehrere 'zählenwenn-Begriffe' (z.B. Ausbilder 1. Jahr, Ausbilder 2. Jahr) als eine Summe gezählt werden sollen. Solange ich nur nach einem 'zählenwenn' suche, da klappt es.
Habe es auch schon mit "summewenn" probiert, aber auch da kommt der "Gartenzaun".

Gibt es da ein Möglichkeit ? Wahrscheinlich liege ich mit dieser Funktion nicht richtig?

Hier mal die Beispieldatei: https://www.herber.de/bbs/user/92243.xlsx

es grüßt
Wolfgang

  

Betrifft: AW: Problem mit "Zählenwenn" .. von: {Boris}
Geschrieben am: 22.08.2014 18:32:26

Hi Wolfgang,

Du zählst in EINER Zelle (z.B. =WENN($D9="Adorf";ZÄHLENWENN(C9;"Leitung");"") ). Das ist nicht die Regelanwendung für ZÄHLENWENN.
Was ist denn Dein Wunschergebnis?

VG, Boris


  

Betrifft: AW: Problem mit "Zählenwenn" .. von: Hajo_Zi
Geschrieben am: 22.08.2014 18:32:28

Halo Wolfagng,

ich sehe nur eine Zählenwenn in der Art
ZÄHLENWENN(M16;"Leitung");
Warum Zählenwenn?
Du sprachst von mehreren Bedingungen, die sehe ich nicht.

GrußformelHomepage


  

Betrifft: AW: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 22.08.2014 18:49:31

Hallo,
in der Spalte "Verkauf" wollte ich eben die Summe von Verkauf Eins, Verkauf Zwei und Verkauf Drei haben, wenn in der Spalte "Ort" der Ort Adorf steht.
So ist die Formel in H9 eingetragen:
=WENN($C9="Adorf";ZÄHLENWENN(D9;"Verkauf Eins")+ZÄHLENWENN(D9;"Verkauf Zwei")+ZÄHLENWENN(D9; "Verkauf Drei");"")

es grüßt
Wolfgang


  

Betrifft: AW: Problem mit "Zählenwenn" .. von: {Boris}
Geschrieben am: 22.08.2014 18:54:48

Hi Wolfgang,

so wie Du es beschreibst, hast Du in der Formel in H9 nur die Bezüge vertauscht. Mach aus C9 => D9 und aus D9 => C9.

VG, Boris


  

Betrifft: ...Ist dann aber immer noch irrational! ;-> orT von: Luc:-?
Geschrieben am: 22.08.2014 19:34:01

Gruß, Luc :-?


  

Betrifft: AW: ...Ist dann aber immer noch irrational! ;-> orT von: WolfgangA
Geschrieben am: 22.08.2014 19:38:19

Hallo Luc und Boris,
das hat mir schon geholfen.

Es geht mit eben darum, dass in der Liste es viele verschiedene Tätigkeiten gibt mit unterschiedlichen Namen und die Tätigkeiten sollen dann in der entsprechenden Spalte zusammengefasst werden und das soll anhand vom Ort abhängig sein. Die Orte werden max. 10 sein.

Hoffe es wird verstanden.

es grüßt
Wolfgang


  

Betrifft: AW: ...Ist dann aber immer noch irrational! ;-> orT von: {Boris}
Geschrieben am: 22.08.2014 20:10:54

Hi Wolfgang,

trag doch mal Deine WUNSCHergebnisse per Hand in die Tabelle ein - dann wird es deutlicher.
Ich glaube für den Moment, dass Du schlicht ZÄHLENWENN mit 2 Bedingungen brauchst - aber ich will nicht unnötig spekulieren ;-)

VG, Boris


  

Betrifft: hier mal ohne die Hilfsmatrix ... von: Matthias L
Geschrieben am: 23.08.2014 07:32:15

Hallo

 CDEFGHI
4   Adorf
5   LeitungEinkaufVerkaufAusbilder
6   3223
7       
8tätig alsOrt LeitungEinkaufVerkaufAusbilder
9AusbilderAdorf nicht nötignicht nötignicht nötignicht nötig
10LeitungAdorf nicht nötignicht nötignicht nötignicht nötig
11Verkauf EinsBdorf nicht nötignicht nötignicht nötignicht nötig
12Ausbilder 1.JahrCdorf nicht nötignicht nötignicht nötignicht nötig
13EinkaufAdorf nicht nötignicht nötignicht nötignicht nötig
14Verkauf ZweiAdorf nicht nötignicht nötignicht nötignicht nötig
15Ausbilder 1.JahrAdorf nicht nötignicht nötignicht nötignicht nötig
16LeitungAdorf nicht nötignicht nötignicht nötignicht nötig
17Verkauf EinsAdorf nicht nötignicht nötignicht nötignicht nötig
18Ausbilder 2. JahrCdorf nicht nötignicht nötignicht nötignicht nötig
19EinkaufAdorf nicht nötignicht nötignicht nötignicht nötig
20Verkauf ZweiBdorf nicht nötignicht nötignicht nötignicht nötig
21Ausbilder 1.JahrAdorf nicht nötignicht nötignicht nötignicht nötig
22LeitungAdorf nicht nötignicht nötignicht nötignicht nötig
23Verkauf DreiBdorf nicht nötignicht nötignicht nötignicht nötig

Formeln der Tabelle
ZelleFormel
F6=SUMMENPRODUKT(($C$9:$C$23=F$5)*($D$9:$D$23=$F$4))
G6=SUMMENPRODUKT(($C$9:$C$23=G$5)*($D$9:$D$23=$F$4))
H6=ZÄHLENWENNS(D9:D23;F4;C9:C23;H5&"*")
I6=ZÄHLENWENNS(D9:D23;F4;C9:C23;I5&"*")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



https://www.herber.de/bbs/user/92245.xlsx

Gruß Matthias


  

Betrifft: [Danke] AW: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 24.08.2014 11:41:59

Hallo Boris und Matthias,
danke für die Hilfe, kann erst heute zurückschreiben.
Das mit der Matrix hilft mir schon sehr und ich müsste auch damit arbeiten, denn manche Begriffe sind doch unterschiedlich und können mit dem "*" nicht aufgefangen werden, wie Matthias es in der Formel hat.
Da ist "zählenwenn" besser.

Luc:
Versuche es nochmal zu erklären:
Es ist eine Namensliste, jeder Name hat eine "Arbeitsbezeichnung" (leider auch mit unterschiedlichen Bezeichnungen) und dann gibt es ca. 10-15 unterschiedliche Orte.
Nun wollte ich eben eine Zusammenfassung nach Orten und die "Arbeitsbezeichnung" in einer Gruppe = Überschrift zusammenfassen! Das mit dem Beispiel von Matthias kommt dem ähnlich, aber da die Arbeitsbezeichnungen unterschiedliche Namen haben, geht es eben nicht mit dem "*" sondern kann über "zählenwenn" die Gruppen bestimmen.
Hoffe nun ist es nicht mehr irrational ;-)

Trotzdem Danke!

es grüßt
WolfgangA


  

Betrifft: [Danke] AW: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 24.08.2014 13:25:44

Hallo,
nun bin ich zwar mit eurer Hilfe schon weit gekommen, aber die Formeln so abzuändern, dass auch noch zwischen Herren und Damen zu unterscheiden ist, sprengt den Rahmen?
Frage:
Eine Summe bilden von allen Frauen (denke bei Männern ist es analog), die in Adorf tätig sind; es gibt nur die Bezeichnung "Frau" oder "Meister'in 1 ff": also "*.'in" zum Bezug von Adorf?

Mit Zählenwenn klappt es nicht (ähnlich der Formel von Matthias:=ZÄHLENWENNS(D9:D23;F4;C9:C23;"*.in"+"Frau")).

es grüßt
WolfgangA


  

Betrifft: hat sich gelöst .. von: WolfgangA
Geschrieben am: 24.08.2014 13:35:37

Hallo,
muss ja nur die beiden formeln verbinden! dann klappt es!

Gruss WolfgangA


  

Betrifft: [Danke] AW: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 24.08.2014 16:32:58

Hallo,
nun habe ich trotzdem noch eine Frage:
Wollte nun die Summe bilden aus der Spalte "F", die vor dem Eintrag den Zusatz "ex" hat mit der folgenden Formel:
=WENN(F15="ex*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"")

Bekomme als Ergebnis eine NULL, obwohl in der Zelle D15 "Frau" steht??
Egal ob ich =WENN(F15=ex&"*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"") oder
=WENN(F15=""ex"&"*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"")
eingebe.

es grüßt
WolfgangA


  

Betrifft: [Danke] AW: Problem mit "Zählenwenn" .. von: WolfgangA
Geschrieben am: 24.08.2014 16:33:03

Hallo,
nun habe ich trotzdem noch eine Frage:
Wollte nun die Summe bilden aus der Spalte "F", die vor dem Eintrag den Zusatz "ex" hat mit der folgenden Formel:
=WENN(F15="ex*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"")

Bekomme als Ergebnis eine NULL, obwohl in der Zelle D15 "Frau" steht??
Egal ob ich =WENN(F15=ex&"*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"") oder
=WENN(F15=""ex"&"*";ZÄHLENWENN(D15;"Herr")+ZÄHLENWENN(D15;"Frau");"")
eingebe.

es grüßt
WolfgangA


  

Betrifft: [Danke] AW: Problem mit "Zählenwenn" .. von: Daniel
Geschrieben am: 24.08.2014 23:33:44

Hi

Der einfache Vergleich mit = kann nicht mit Jokerzeichen umgehen.
F15="ex*" wird nur dann wahr, wenn in der Zelle auch genau "ex*" steht und nichts anderes.

Hier musst du so formulieren:
=WENN(Links(F15;2)="ex";...
Oder
=WENN(Zählenwenn(F15;"ex*");...

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Problem mit "Zählenwenn" .."