Summe bilden wenn Rechnungsnummer gleich

Bild

Betrifft: Summe bilden wenn Rechnungsnummer gleich von: Andreas
Geschrieben am: 08.04.2005 17:57:31

Hallo Zusammen,
ich komme einfach nicht vorwärts und brauche Hilfe. Ich habe eine Tabelle mit ca. 6000 Zeilen. In Spalte "C" stehen alle Rechnungsnummern. In Spalte "O" die Umsätze. Ich möchte das in Spalte "P" der Gesamtumsatz der Rechnung steht. Teilweise ist in "C" nur eine Rechnung mit einem Umsatz in "O". Sehr häufig aber auch mehrere Positonen in einer Rechnung. Das heißt, die Rechnungsnummer taucht u.U. 25x in Folge auf.
Wie bekomme ich das geregelt. Die Spalten dazwischen benötige ich aber nach der Bearbeitung weiter zur Auswertung. Schon jetzt mal DANKE!
Gruss Andreas

Bild


Betrifft: Guckst du Funktion SUMMEWENN() von: Boris
Geschrieben am: 08.04.2005 18:02:47

Hi Andreas,

die wurde nämlich extra für Dich und dein Problem geschaffen (sofern die Summenspalte nur einspaltig ist). ;-)

Grüße Boris


Bild


Betrifft: AW: Summe bilden wenn Rechnungsnummer gleich von: Andreas
Geschrieben am: 08.04.2005 21:59:45

Ja danke... Super.... ich packe es nicht. Die Tabelle macht alles bloss nicht rechnen. Bitte nochmal von ganz vorn. Ja? Danke!


Bild


Betrifft: AW: Summe bilden wenn Rechnungsnummer gleich von: Andreas
Geschrieben am: 08.04.2005 22:18:20

.... Das Problem scheint mir, das ich doch nicht alle 6000 Zeilen zu Fuss durchforsten kann und jedesmal eine neue Bedingung schreibe. Wat denn nu? HILFEEEEE...........


Bild


Betrifft: AW: Summe bilden wenn Rechnungsnummer gleich von: Andreas
Geschrieben am: 09.04.2005 01:30:48

Also ich würds so machen:
Die Liste nach dem gemeinsamen Indexmerkmal sortieren (Rechnungsnummer).
Dann einen Indikator per WENN einbauen, der anzeigt wenn es sich um eine Summenzeile handelt.
Dann noch eine Aufsummierung mit Ausnahme wenn die Rechnungsnummer eine andere ist.

Siehe Beispieldatei:
https://www.herber.de/bbs/user/20904.xls

Andreas


Bild


Betrifft: =SUMMEWENN(A$2:A2;A2;C$2:C2) von: Boris
Geschrieben am: 09.04.2005 21:16:46

Hi Andreas,

in der Beispieldatei in E2 und dann runterkopieren. Die Hilfsspalte ist überflüssig.
Ein Paradefall für SUMMEWENN.

Grüße Boris


Bild


Betrifft: AW: Summe bilden wenn Rechnungsnummer gleich von: Andreas
Geschrieben am: 09.04.2005 19:03:46

Hallo Andreas hier Andreas ;)
HEUREKA... Vielen Dank! Es hat geklappt. Das WE ist gerettet. Habe mir Heute noch EXEL Bücher gekauft um mich stärker um das Thema zu bemühen. Leider verlangt unser veraltetes Warenwirtschaftssystem ein gewisses Maß an Hirnakrobatik... Werde fleißig trainieren.
Vielen Dank an ALLE
Gruss Andreas


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden wenn Rechnungsnummer gleich"