Microsoft Excel

Herbers Excel/VBA-Archiv

wenn wert in spalte dann .... formel verallgemeine

Betrifft: wenn wert in spalte dann .... formel verallgemeine von: Bastian Eberl
Geschrieben am: 13.08.2008 15:00:14

hallo zusammen,

hier eine beispieldatei für ein problem von mir:

https://www.herber.de/bbs/user/54580.xls

das funktioniert wunderbar. Allerdings muss ich den range in der spalte über die oder funktion festlegen und ist damit nicht wirklich variable.

gibt es eine möglichkeit, die wenn dann abfrage über eine ganze spalte oder zumindest eine grössere range zu machen?

danke und gruss
bastian

  

Betrifft: AW: wenn wert in spalte dann .... formel verallgemeine von: Daniel
Geschrieben am: 13.08.2008 15:17:08

HI

du kannst diesen Wahrheitswert:

ODER(A2=3;A3=3;A4=3;A5=3;A6=3;A7=3)


durch diesen ersetzen:

ZählenWenn(A2:A7;3)>0



in der Zählenwenn-Funktion kannst du den Zellbereich natürlich beliebig gross wählen, die ganze Spalte mit A:A funktioniert auch.

Gruß, Daniel


  

Betrifft: AW: wenn wert in spalte dann .... formel verallgemeine von: Beate Schmitz
Geschrieben am: 13.08.2008 15:19:17

Hallo Bastian,

hierbei werden alle Zahlen aus C summiert, die dem Suchwert (in absteigender Reihenfolge 3;2;1) entsprechen:

 ABCDE
1Reason IDPricechange DateOSP/RRP ASP/RRP--> PL6
211. Jan. 08100,02 90
322. Jan. 08100  
432. Jan. 0890  
541. Mai. 0880  
6415. Jun. 0870  
741. Aug. 0860  

Formeln der Tabelle
ZelleFormel
E2=WENN(ZÄHLENWENN(A:A;3); SUMMEWENN(A:A;3;C:C); WENN(ZÄHLENWENN(A:A;2); SUMMEWENN(A:A;2;C:C); SUMMEWENN(A:A;1;C:C)))


Kürzer ist die Formel, wenn du den Suchwert in eine Zelle schreibst:

 ABCDEFG
1Reason IDPricechange DateOSP/RRP ASP/RRP--> PL6 Suchwert:
211. Jan. 08100,02 210 4
322. Jan. 08100    
432. Jan. 0890    
541. Mai. 0880    
6415. Jun. 0870    
741. Aug. 0860    

Formeln der Tabelle
ZelleFormel
E2=WENN(ZÄHLENWENN(A:A;G2); SUMMEWENN(A:A;G2;C:C); "kein Treffer")


Gruß,
Beate


  

Betrifft: AW: wenn wert in spalte dann .... formel verallgemeine von: Bastian Eberl
Geschrieben am: 13.08.2008 15:27:21

Hallo Daniel,
hallo Beate,

vielen Dank für Eure hilfe. Ich denke das Deine Lösung, Daniel für mich die richtige ist.
Beate, Deine Lösung summiert die Zellen falls in A zweimal 2 oder 3 oder 1 vorkommt. Das brauche ich nicht.

Daher, vielen Dank ihr zwei!

Viele Grüsse
Bastian


 

Beiträge aus den Excel-Beispielen zum Thema "wenn wert in spalte dann .... formel verallgemeine"