Microsoft Excel

Herbers Excel/VBA-Archiv

VBA- Zeilen ausblen. Wert in Spalte mehrfach

Betrifft: VBA- Zeilen ausblen. Wert in Spalte mehrfach von: Urs
Geschrieben am: 22.09.2014 10:59:02

Hallo allerseits
Ich suche eine VBA Lösung mit der ich
A) in einem schon gefilterten Blatt alle Zeilen ausblenden kann die in der Spalte C einen Ausdruck mehrfach anzeigen. Er darf nur einmal vorkommen, alle andern sollen ausgeblendet oder versteckt sein (nicht gelöscht).
B) wie lautet der Befehl, wenn ich diesen Dupplettenfilter wieder aufheben will.
Danke für Eure Hilfe. Gruss Urs

  

Betrifft: AW: VBA- Zeilen ausblen. Wert in Spalte mehrfach von: Hajo_Zi
Geschrieben am: 22.09.2014 11:05:21

mache Hilfsspalte und Filter >1


Tabelle1
 EF
1wert11
2wert21
3wert12
4wert22
5wert13
6wert23

verwendete Formeln
Zelle Formel Bereich N/A
F1:F6=ZÄHLENWENN($E$1:E1;E1)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: VBA- Zeilen ausblen. Wert in Spalte mehrfach von: Urs
Geschrieben am: 22.09.2014 12:57:53

Hallo Hajo,
Danke für Deine schnelle Hilfe. Ich habe aber entdeckt, dass ich den Vergleich aus 2 Spalten machen muss (habe etwas übersehen) und komme nun auf folgende Lösung in den Zellen. Ich muss 2 zusätzliche Spalten einfügen und die Zellinhalte lauten wie folgt:
BY2: =Verketten(C2;D2)
BZ2: =ZÄHLENWENN($BY$2:BY2;BY2)
Wie fülle ich das per VBA ab, wenn das überall dort eingesetzt wird wo der Zellwert in Spalte 1 nicht leer ist?
Danke und Gruss Urs


  

Betrifft: AW: VBA- Zeilen ausblen. Wert in Spalte mehrfach von: Daniel
Geschrieben am: 22.09.2014 11:08:20

Hi

dazu müsstest du in einer Hilfsspalte die jeweils ersten Werte (dh. die die angezeigt werden sollen) mit einem bestimmten Wert kennzeichnen (z.B. 1) und alle anderen mit einem anderen Zeilen (z.B. 0) und dann diese Hilfsspalte zusätzlich in den Autofilter mit aufnehmen und in dieser Spalte nach 1 Filtern.

zum Markieren der Werte kannst du folgende Formeln verwenden (Formel für Zeile 2 der Hilfsspalte):
a) Tabelle ist nach Spalte C sortiert: =Wenn(C1=C2;0;1)
b) Tabelle ist nicht nach Spalte C sortiert: =Wenn(Vergleich(C2;C:C;0)=Zeile();1;0)

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "VBA- Zeilen ausblen. Wert in Spalte mehrfach"