Zählenwenn

Bild

Betrifft: Zählenwenn
von: Andre
Geschrieben am: 11.06.2015 08:38:28

Hallo,
ich habe 2 Spalten A und B
A
90001
90002
90004
B
90001
90003
90004
Ich würde gerne prüfen, ob B2 in A2:A2000 enthalten ist. Wenn ja, dann 1, wenn nein, dann 0.
Ich scheitere aber mit Zählenenwenn: =ZÄHLENWENN(A$2:A$2000;B2)
Habt ihr ne Idee?
VG
André

Bild

Betrifft: AW: Geht doch
von: hary
Geschrieben am: 11.06.2015 08:49:49
Moin
Funzt doch.



Tabelle1

 ABC
290001900011
390004900030
490002900041

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C2:C4=ZÄHLENWENN(A$2:A$2000;B2)  =COUNTIF(R2C[-2]:R2000C[-2],RC[-1])

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Bild

Betrifft: AW: Falsch gelesen
von: hary
Geschrieben am: 11.06.2015 08:58:07
Moin nochmal
Geht auch so.
=MIN(1;ZÄHLENWENN(A$2:A$2000;B2))
gruss hary

Bild

Betrifft: AW: Zählenwenn
von: TerPursche
Geschrieben am: 11.06.2015 08:50:05
Hallo,
bin selber Neuling, aber wenn ich das richtig verstehe und du nicht die Anzahl der B2 in A2:A2000 sondern die Ausgabe 1, wenn es mindestens einmal auftaucht und die Ausgabe 0, wenn es keinmal auftaucht, müsste Folgendes dir helfen:

=WENN(ZÄHLENWENN(A$1:A$2000; B2)>0; 1; 0)
Kein Gewähr für die potimalste Lösung ;)
Gruß

Bild

Betrifft: AW: Zählenwenn
von: UweD
Geschrieben am: 11.06.2015 08:50:31
Hallo
so...

Tabelle1

 ABC
1Überschrift AÜberschrift BB in A?
290001900011
390002900021
490004900041
5 900030

verwendete Formeln
Zelle Formel Bereich N/A
C2=(ZÄHLENWENN($A$2:$A$2000;B2)>0)*1  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.03 einschl. 64 Bit


Gruß UweD

Bild

Betrifft: AW: Zählenwenn
von: Andre
Geschrieben am: 11.06.2015 09:01:39
Hm nix klappt bei mir (OpenOffice)
Kann es an der Formatierung der Zellen liegen? Sind alle als Zahl formatiert...
Bei mir kommt als Ergebnis immer 0 raus, egal welche Lösungsvariante ich eintrage...

Bild

Betrifft: AW: Zählenwenn
von: UweD
Geschrieben am: 11.06.2015 09:07:18
Hab noch nie OpenOffice benutzt

Bild

Betrifft: stell doch mal eine kleine Beispieldatei ein ....
von: der neopa C
Geschrieben am: 11.06.2015 17:26:22
Hallo André,
... ich hab zwar auch kein OpenOffice, aber die Wirkungsweise der Funktion ZÄHLENWENN() unterscheidet
sich da mit größter Wahrscheinlichkeit nicht von der im Excel.
Nur an Hand einer Datei lässt sich da wohl mehr zu schreiben.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn"